Ändern des Webdienstes, der in der primären Datenverbindung Ihrer Formularverbindung verwendet wird

Wichtig :  Dieser Artikel wurde maschinell übersetzt. Bitte beachten Sie den Haftungsausschluss. Die englische Version des Artikels ist als Referenz hier verfügbar: hier.

Inhalt dieses Artikels

(Übersicht)

Vorbemerkung

Ändern Sie die Verbindung zum Abfragen von Daten

Ändern Sie die Verbindung zum Absenden von Daten

Übersicht

Wenn Sie zuerst eine Formularvorlage mit einer primären Datenverbindung zu einem Webdienst entwerfen, verwenden Sie u. U. eine Testumgebung, in der der Webdienst entwickelt wird. Wenn der Webdienst für die Bereitstellung bereit ist, müssen Sie die primäre Datenverbindung in Ihrer Formularvorlage von der Textumgebung zu dem Standort des bereitgestellten Webdienstes ändern.

Wenn Sie den Webdienst in den Hauptfenster Verbindung ändern, erstellt Microsoft Office InfoPath eine primäre Datenquelle mit Feldern und Gruppen, die die XML-Schema in den neuen Webdienst entsprechen. Wenn die Schemas im alten und neuen Webdienste identisch sind, wird InfoPath automatisch die vorhandenen Steuerelemente in der Formularvorlage für die Felder in der neuen Datenquelle gebunden. Wenn Sie die Felder und Gruppen in der neuen Datenquelle nicht die Felder und Gruppen in der alten Datenquelle übereinstimmen, entfernt InfoPath die Datenquelle Bindung von den Steuerelementen an. Wenn InfoPath die Bindung von den Steuerelementen entfernt, müssen Sie die Steuerelemente aus der Formularvorlage entfernen oder auf andere Felder in der neuen Datenquelle zu binden.

Je nach dem Entwurf Ihrer Formularvorlage weist die primäre Datenverbindung möglicherweise eine Abfragedatenverbindung, eine Absendedatenverbindung oder beides auf. Falls die primäre Datenverbindung sowohl eine Abfrage- als auch eine Absendedatenverbindung aufweist und der Webdienst die Speicherorte gewechselt hat, müssen Sie beide Verbindungen ändern.

Hinweis : Weitere Verknüpfungen zu Informationen über das Ändern sekundärer Datenverbindungen zu anderen externen Datenquellen finden Sie im Abschnitt Siehe auch.

Nach Ändern der primären Datenverbindung sollten Sie die Formularvorlage veröffentlichen und testen, um sicherzustellen, dass die Datenverbindung zum Webdienst ordnungsgemäß funktioniert, wenn die Benutzer auf Ihrer Formularvorlage basierende Formulare ausfüllen. Außerdem sollten Sie einen Test durchführen, um sicherzustellen, dass die auf Ihrer Formularvorlage basierenden vorhandenen Formulare nach wie vor erwartungsgemäß funktionieren. Wenn Sie Ihre Tests abgeschlossen haben, können Sie Benutzern ermöglichen, das Ausfüllen von auf dieser Formularvorlage basierenden Formularen zu beginnen. Verknüpfungen zu weiteren Informationen über das Veröffentlichen einer Formularvorlage finden Sie im Abschnitt Siehe auch.

Seitenanfang

Vorbemerkung

Bevor Sie die primäre Datenverbindung ändern, benötigen Sie vom Webdienstadministrator folgende Informationen:

  • Den Speicherort des neuen Webdienstes.

  • Überprüfung, ob der neue Webdienst die Codierung "document/literal" verwendet. InfoPath kann nur Webdienste vom Typ "document/literal" konsumieren.

  • Die Namen der Vorgänge im zu verwendenden Webdienst.

  • Überprüfung, dass die Schemas im alten und neuen Webdienst identisch sind.

Seitenanfang

Ändern der Abfragedatenverbindung

  1. Klicken Sie im Menü Extras auf Primäre Datenquelle umwandeln.

  2. Klicken Sie im Datenverbindungs-Assistenten auf Neue Verbindung erstellen mit auf Daten empfangen, und klicken Sie dann auf Weiter.

  3. Klicken Sie unter Wählen Sie den in der Formularvorlage zu verwendenden Datenverbindungstyp aus auf Webdienst, und klicken Sie dann auf Weiter.

  4. Geben Sie auf der nächsten Seite des Assistenten an, wo sich der Webdienst befindet, und klicken Sie dann auf Weiter.

    Hinweis : Wenn Sie einem Webdienst mithilfe eines Servers Universal Description Discovery and Integration (UDDI) suchen möchten, klicken Sie auf UDDI durchsuchen, geben Sie die URL des UDDI-Servers ein, die Sie suchen, angeben, ob Sie nach Anbieter oder nach einem Dienst, der bereitgestellt wird, suchen möchten, geben Sie ein Suchschlüsselwort ein, und klicken Sie dann auf Suchen möchten. Webdienste, die das Stichwort entsprechen, werden in der Liste Suchergebnis angezeigt. Wählen Sie den Webdienst, den Sie verwenden möchten, und klicken Sie dann auf OK.

  5. Klicken Sie in der Liste Wählen Sie eine Methode aus auf den Webdienstvorgang, durch den Daten an das Formular zurückgegeben werden, und klicken Sie dann auf Weiter.

  6. Wenn vom Datenverbindungs-Assistenten ein unbekanntes Element im Schema des Webdienstes entdeckt wird, werden Sie möglicherweise auf der nächsten Seite des Assistenten darum gebeten, Beispielwerte für jeden Parameter anzugeben, um zu bestimmen, welche Felder oder Gruppen zur Hauptdatenquelle hinzugefügt werden sollen.

    So wird's gemacht

    1. Wählen Sie in der Tabelle Parameter einen Parameter aus, und klicken Sie auf Beispielwert festlegen.

    2. Geben Sie in das Feld Sample value einen Wert ein, den Ihr Benutzer für dieses Feld möglicherweise verwenden kann, und klicken Sie dann auf OK.

    3. Wiederholen Sie diese Schritte für jeden Parameter in der Tabelle Parameter, und klicken Sie dann auf Weiter.

    Technische details

    Wenn Sie im Datenverbindungs-Assistenten eine Datenverbindung zu einem Web-Dienst konfigurieren, stellt Microsoft Office InfoPath eine Verbindung zu diesem Web-Dienst her und fordert die WSDL-Datei (Web Service Description Language) an. Die WSDL-Datei enthält das vom Web-Dienst verwendete Schema. Der Web-Dienst reagiert auf die Anforderung, indem er die betreffende Datei an InfoPath sendet. InfoPath verwendet die Informationen in dieser Datei, um der sekundären Datenquelle in der Formularvorlage die entsprechenden Felder und Gruppen hinzuzufügen. Falls InfoPath einen unbekannten Elementtyp in der WSDL-Datei findet, verwendet InfoPath Beispieldaten, um die Definition des unbekannten Elementtyps zu ermitteln, und fügt der sekundären Datenquelle dann die entsprechenden Felder und Gruppen hinzu.

  7. Akzeptiert der Webdienst Änderungsinformationen, müssen Sie auf der nächsten Seite des Assistenten angeben, ob Sie Änderungsinformationen in die Abfragedaten aufnehmen möchten. In den meisten Fällen können Sie das Kontrollkästchen Änderungsinformationen beim Senden von Daten einschließen aktiviert lassen. Klicken Sie dann auf Weiter. Wenn Sie keine Änderungsinformationen einschließen möchten, deaktivieren Sie das Kontrollkästchen Änderungsinformationen beim Senden von Daten einschließen, und klicken Sie dann auf Weiter.

    Technische details

    Diese Seite des Assistenten wird nur angezeigt, wenn in der WSDL-Datei (Web Service Description Language) für den Webdienst angegeben ist, dass der Webdienst ein Microsoft ADO.NET DataSet zurückgibt.

  8. Geben Sie auf der nächsten Seite des Assistenten einen Namen für die Datenverbindung ein, und klicken Sie dann auf Fertig stellen.

  9. Klicken Sie zum Testen Ihrer Änderungen auf der Symbolleiste Standard auf Vorschau, oder drücken Sie STRG+UMSCHALT+B.

  10. Klicken Sie zum Veröffentlichen der Formularvorlage im Menü Datei auf Veröffentlichen.

  11. Testen Sie die Formularvorlage gründlich, indem Sie ein auf dieser Formularvorlage basierendes Formular öffnen und dieses ausfüllen. Überprüfen Sie, ob das Formular ordnungsgemäß funktioniert.

Seitenanfang

Ändern der Absendedatenverbindung

  1. Klicken Sie im Menü Extras auf Sekundäre Datenquelle.

  2. Klicken Sie in der Liste Datenverbindungen für die Formularvorlage auf die Absendedatenverbindung in der primären Datenverbindung, und klicken Sie anschließend auf Ändern.

  3. Geben Sie im Datenverbindungs-Assistenten den Speicherort des neuen Webdienstes ein, an den Benutzer ihre Formulare absenden, und klicken Sie dann auf Weiter.

    Hinweis : Wenn Sie einem Webdienst mithilfe eines Servers Universal Description Discovery and Integration (UDDI) suchen möchten, klicken Sie auf UDDI durchsuchen, geben Sie die URL des UDDI-Servers ein, die Sie suchen, angeben, ob Sie nach Anbieter oder nach einem Dienst, der bereitgestellt wird, suchen möchten, geben Sie ein Suchschlüsselwort ein, und klicken Sie dann auf Suchen möchten. Webdienste, die das Stichwort entsprechen werden in der Liste Suchergebnis angezeigt. Wählen Sie den Webdienst, den Sie verwenden möchten, und klicken Sie dann auf OK.

  4. Klicken Sie auf der nächsten Seite des Assistenten in der Liste Vorgang auswählen auf den Webdienstvorgang, der die Daten übersendet hat, und klicken Sie dann auf Weiter.

  5. Gehen Sie auf der nächsten Seite des Assistenten folgendermaßen vor, um zu bestimmen, welche Daten im Formular für jeden Parameter im Webdienst abgesendet werden sollen:

    Übermitteln Sie die Daten in einem Feld oder Gruppe

    1. Klicken Sie in der Liste Parameter auf den Webdienstparameter, der die Daten aus dem Formular empfängt.

    2. Klicken Sie unter Parameteroptionen auf Feld oder Gruppe.

    3. Klicken Sie auf Ändern Schaltfläche (Symbol) .

    4. Klicken Sie im Dialogfeld Feld oder Gruppe auswählen auf das Feld oder die Gruppe, deren Daten Sie absenden möchten, und klicken Sie dann auf OK.

    5. Klicken Sie im Feld Einschließen auf Nur Text und untergeordnete Elemente, um nur die Daten in diesem Feld und die untergeordneten Elemente des Felds oder der Gruppe abzusenden, oder klicken Sie auf Untergeordneter XML-Baum, einschließlich ausgewähltem Element, um einen Feldnamen, die Daten im Feld und die untergeordneten Elemente in der ausgewählten Gruppe oder im ausgewählten Feld abzusenden.

    Senden Sie alle Daten im Formular

    1. Klicken Sie in der Liste Parameter auf den Webdienstparameter, der die Daten aus dem Formular empfängt.

    2. Klicken Sie unter Parameteroptionen auf Gesamtes Formular (XML-Dokument einschließlich Verarbeitungsanweisungen).

    Senden Sie die Daten als Zeichenfolge

    1. Klicken Sie in der Liste Parameter auf den Webdienstparameter, der die Daten aus dem Formular empfängt.

    2. Klicken Sie unter Parameteroptionen auf Gesamtes Formular (XML-Dokument einschließlich Verarbeitungsanweisungen).

    3. Aktivieren Sie das Kontrollkästchen Daten als Zeichenfolge absenden.

      Hinweis : Normalerweise aktivieren Sie dieses Kontrollkästchen, um digital signierte Daten abzusenden. Deaktivieren Sie in den meisten Fällen dieses Kontrollkästchen.

    Technische Details zu ADO.NET DataSet-Objekte

    Falls der Webdienst ein ADO.NET DataSet-Objekt erfordert, wählen Sie beim Konfigurieren dieser Datenverbindung einen DataSet-Knoten aus. Sollten Sie einen anderen Knotentyp für eine Datenverbindung zu einem Webdienst verwenden, der ein ADO.NET DataSet benötigt, schlägt der Absendvorgang fehl.

  6. Klicken Sie auf Weiter.

  7. Geben Sie auf der nächsten Seite des Assistenten einen Namen für die Verbindung zum Absenden von Daten ein, und klicken Sie dann auf Fertig stellen.

Seitenanfang

Hinweis : Haftungsausschluss für maschinelle Übersetzungen: Dieser Artikel wurde mithilfe eines Computersystems und ohne jegliche Bearbeitung durch Personen übersetzt. Microsoft bietet solche maschinellen Übersetzungen als Hilfestellung für Benutzer ohne Englischkenntnisse an, damit Sie von den Informationen zu Produkten, Diensten und Technologien von Microsoft profitieren können. Da es sich bei diesem Artikel um eine maschinelle Übersetzung handelt, enthält er möglicherweise Fehler in Bezug auf (Fach-)Terminologie, Syntax und/oder Grammatik.

Ihre Fähigkeiten erweitern
Schulung erkunden
Neue Funktionen als Erster erhalten
An Office Insider teilnehmen

War diese Information hilfreich?

Vielen Dank für Ihr Feedback!

Vielen Dank für Ihr Feedback. Es klingt, als ob es hilfreich sein könnte, Sie mit einem unserer Office-Supportmitarbeiter zu verbinden.

×