Sådan retter du #VÆRDI!-fejlen i funktionen SAMMENKÆDE

Bemærk!: Vi vil gerne give dig den mest opdaterede hjælp, så hurtigt vi kan, på dit eget sprog. Denne side er oversat ved hjælp af automatisering og kan indeholde grammatiske fejl og unøjagtigheder. Det er vores hensigt, at dette indhold skal være nyttigt for dig. Vil du fortælle os, om oplysningerne var nyttige for dig, nederst på denne side? Her er artiklen på engelsk så du kan sammenligne.

Vigtigt!: I Excel 2016, Excel Mobile og Excel Online er SAMMENKÆDE blevet erstattet med funktionen SAMMENKÆDNING. Selvom funktionen SAMMENKÆDE stadig er tilgængelig af hensyn til bagudkompatibilitet, bør du overveje at bruge SAMMENKÆDNING, da det er en mere robust funktion.

Et af de mest almindelige scenarier, hvor du støder på fejlen #VÆRDI! med SAMMENKÆDE, er, når du forsøger at opbygge en streng, der indeholder en cellereference, der har en fejl, f.eks. #VÆRDI!.

I følgende eksempel vil vi gerne sammenkæde D2, E2 og F2, hvor E2 har fejlen #VÆRDI!.

#VÆRDI!-fejl i SAMMENKÆDNING

Funktionen til at få vist #VALUE Hvis der opstår fejl i E2! fejl. I rækkefølge, så det fungerer korrekt, skal du erstatte fejlen med en anden værdi end fejlen. Du kan oprette en formel, der kontrollerer, om der er fejl i cellereferencen, og hvis det er tilfældet, vises den tekststreng, hvor en 0 vises i stedet for fejlen (eller du kan erstatte din egen tekst til 0, men skal du ombryde teksten i anførselstegn – "Din tekst").

En formel som denne ville fungere:

=HVIS(ER.FEJL(E2);SAMMENKÆDNING(D2;" ";0;" ";F2))

HVIS- og ER.FEJL-funktioner, der bruges som en løsning til at sammenkæde en streng med #VÆRDI!-fejlen

Hvordan fungerer? Funktionen Hvis bruger funktionen Hvis til at bestemme, om der er en fejl i E2, og hvis der er funktionen sammenkædning kombinerer værdierne i D2, E2 og F2 (funktionen erstatter fejlen med 0), og viser den resulterende tekststreng. Bemærk formlen også bruger mellemrum ("") til at adskille værdierne.

Ret fejlen #VÆRDI! med SAMMENKÆDE i Excel 2003 og ældre versioner

Hvis du får #VALUE! fejl i Office Excel 2003 eller ældre versioner, skal du fjerne markeringen af indstillingen overgang formel evaluering (TFE) i Excel. Følg trinnene beskrevet i #VALUE! fejl, når du sammenkæde celler at løse problemet.

Har du et bestemt spørgsmål til en funktion?

Stil et spørgsmål i Excel-communityforummet

Hjælp os med at forbedre Excel

Har du forslag til, hvordan vi kan forbedre den næste version af Excel? Hvis det er tilfældet, skal du gå til emner i Excel User Voice.

Se også

Rette fejlen #VÆRDI!

Funktionen SAMMENKÆDNING

Funktionen SAMMENKÆDNING

Oversigt over formler i Excel

Sådan undgår du ødelagte formler

Find fejl i formler

Alle Excel-funktioner (alfabetisk)

Alle Excel-funktioner (efter kategori)

Udvid dine Office-færdigheder
Gå på opdagelse i kurser
Få nye funktioner først
Bliv Office Insider

Var disse oplysninger nyttige?

Tak for din feedback!

Tak for din feedback! Det lyder, som om det vil kunne hjælpe, hvis du bliver sat i forbindelse med en af vores Office-supportteknikere.

×