Sådan retter du fejlen #VÆRDI! fejl i funktionen SUM/sum

Bemærk!: Vi vil gerne give dig den mest opdaterede hjælp, så hurtigt vi kan, på dit eget sprog. Denne side er oversat ved hjælp af automatisering og kan indeholde grammatiske fejl og unøjagtigheder. Det er vores hensigt, at dette indhold skal være nyttigt for dig. Vil du fortælle os, om oplysningerne var nyttige for dig, nederst på denne side? Her er artiklen på engelsk så du kan sammenligne.

I dette emne beskrives de mest almindelige årsager til, at fejlen #VÆRDI! opstår i funktionerne SUM.HVIS og SUM.HVISER, og hvordan du kan rette dem.

Problem: Formlen henviser til celler i en lukket projektmappe

SUM/sum-funktioner, der refererer til en celle eller et område i en lukket projektmappe, resulterer i et #VALUE! -fejlen.

Bemærk: Dette er et kendt problem med flere andre Excel-funktioner som Tæl, Tæl, blanke, for at nævne nogle få. Se Sum-, Tæl-og blanke-funktionerne returnerer "#VALUE!" Fejl artikel for at få flere oplysninger.

Løsning: Åbn projektmappen, der er angivet i formlen, og tryk på F9 for at opdatere formlen.

Du kan også løse dette problem ved at bruge funktionerne SUM og hvis sammen i en matrixformel. Se Sum-, Tæl-og blanke-funktionerne returnerer #VALUE! fejl artikel for at få flere oplysninger.

Problem: Kriteriestrengen er på mere end 255 tegn

Funktionen SUM.HVIS/SUM.HVISER returnerer forkerte resultater, når du bruger den til at matche strenge på mere end 255 tegn.

Løsning: Afkort strengen, hvis det er muligt. Hvis du ikke kan forkorte strengen, skal du bruge funktionen SAMMENKÆDE eller og-tegnet (&) til at opdele værdi i flere strenge. For eksempel:

=SUM.HVIS(B2:B12,"lang streng"&"en anden lang streng")

Problem: I SUM.HVISER er argumentet kriterieområde ikke i overensstemmelse med argumentet sumområde.

Områdeargumenterne skal altid være ens i SUM.HVISER. Det betyder, at argumenterne kriterieområde og sumområde skal indeholde samme antal rækker og kolonner.

I følgende eksempel forventes formlen at returnere summen af dagligt salg af æbler i Vejle. Argumentet Sum_område (C2: C10) svarer dog ikke til det samme antal rækker og kolonner i kriterieområde (a2: A12 _AMP_ B2: B12)- argumenter. Hvis du bruger syntaksen = sum (C2: C10,a2: A12, A14,B2: B12, B14), vil det resultere i #VALUE! -fejlen.

Den forkerte formel er =SUM.HVIS(C2:C10,A2:A12,A14,B2:B12,B14), hvor C2:C10 skal være C2:C12

Løsning: I dette eksempel skal du ændre sumområde til C2:C12 og prøve formlen igen.

Bemærk!:  SUM.HVIS kan bruge forskellige størrelsesintervaller.

Har du et bestemt spørgsmål til en funktion?

Stil et spørgsmål i Excel-communityforummet

Hjælp os med at forbedre Excel

Har du forslag til, hvordan vi kan forbedre den næste version af Excel? Hvis det er tilfældet, skal du gå til emner i Excel User Voice.

Se også

Rette fejlen #VÆRDI! fejl

Funktionen SUM.HVIS

Funktionen SUM.HVISER

Avancerede hvis-funktions videoer

Oversigt over formler i Excel

Sådan undgår du ødelagte formler

Find fejl i formler

Alle Excel-funktioner (alfabetisk)

Alle Excel-funktioner (efter kategori)

Udvid dine Office-færdigheder
Gå på opdagelse i kurser
Få nye funktioner først
Bliv Office Insider

Var disse oplysninger nyttige?

Tak for din feedback!

Tak for din feedback! Det lyder, som om det vil kunne hjælpe, hvis du bliver sat i forbindelse med en af vores Office-supportteknikere.

×