Ret #VÆRDI!-fejlen i funktionen TÆL.HVIS/TÆL.HVISER

Bemærk!: Vi vil gerne give dig den mest opdaterede hjælp, så hurtigt vi kan, på dit eget sprog. Denne side er oversat ved hjælp af automatisering og kan indeholde grammatiske fejl og unøjagtigheder. Det er vores hensigt, at dette indhold skal være nyttigt for dig. Vil du fortælle os, om oplysningerne var nyttige for dig, nederst på denne side? Her er artiklen på engelsk så du kan sammenligne.

I dette emne beskrives de mest almindelige årsager til, at fejlen #VÆRDI! opstår i funktionerne TÆL.HVIS og TÆL.HVISER.

Problem: Formlen henviser til celler i en lukket projektmappe

Hvis funktionerne TÆL.HVIS/TÆL.HVISER henviser til en celle eller et område i en lukket projektmappe, medfører det fejlen #VÆRDI!.

Bemærk: Dette er et kendt problem i flere andre Excel-funktioner som f.eks. SUM.HVIS, SUM.HVISER, ANTAL.BLANKE. Du kan få mere at vide i Funktionerne SUM.HVIS, TÆL.HVIS, ANTAL.BLANKE returnerer fejlen #VÆRDI!.

Løsning: Åbn den sammenkædede projektmappe, der er angivet i formlen, og tryk på F9 for at opdatere formlen.

Du kan løse dette problem ved at bruge funktionerne SUM og HVIS sammen i en matrixformel. Du kan få mere at vide i Funktionerne SUM.HVIS, TÆL.HVIS og ANTAL.BLANKE returnerer fejlen #VÆRDI!.

Problem: Strengen er på mere end 255 tegn

Løsning: Afkort strengen, hvis det er muligt. Hvis du ikke kan forkorte strengen, skal du bruge funktionen SAMMENKÆDE eller og-tegnet (&) til at opdele værdi i flere strenge. For eksempel

  • =TÆL.HVIS(B2:B12,"lang streng"&"en anden lang streng")

Har du et bestemt spørgsmål til en funktion?

Stil et spørgsmål i Excel-communityforummet

Hjælp os med at forbedre Excel

Har du forslag til, hvordan vi kan forbedre den næste version af Excel? Hvis det er tilfældet, skal du gå til emner i Excel User Voice.

Se også

Rette fejlen #VÆRDI!

Funktionen TÆL.HVIS

Funktionen TÆL.HVISER

Funktionen HVIS – indlejrede formler og undgåelse af fejl

Se en video om avancerede Hvis-funktioner

Oversigt over formler i Excel

Sådan undgår du ødelagte formler

Find fejl i formler

Alle Excel-funktioner (alfabetisk)

Alle Excel-funktioner (efter kategori)

Udvid dine Office-færdigheder
Gå på opdagelse i kurser
Få nye funktioner først
Bliv Office Insider

Var disse oplysninger nyttige?

Tak for din feedback!

Tak for din feedback! Det lyder, som om det vil kunne hjælpe, hvis du bliver sat i forbindelse med en af vores Office-supportteknikere.

×