Office
Log på

Opret et pivotdiagram

Nogle gange kan det være svært at se det store billede, når du har rå data, der ikke er opsummeret, som i eksemplet nedenfor. Mange gange kan det første trin være at oprette en pivottabel for at opsummere og analysere data i et struktureret format, hvilket er fint, men ikke alle kan se på tal og hurtigt se, hvad der sker. Pivotdiagrammer er en god måde at føje datavisualiseringer til dine data.

Data over husholdningsudgifter

Tilsvarende pivotdiagram

Eksempeldata på husholdningsudgifter til at oprette en pivottabel med måneder, kategorier og beløb

Eksempel på et pivotdiagram i Excel

Hvis du kun har almindelige regnearksdata og ingen eksisterende pivottabel, kan du vælge et pivotdiagram, der anbefales til dine data, og derefter opretter Excel automatisk en sammenkædet pivottabel. Sådan gør du:

  1. Klik et vilkårligt sted i dataene.

  2. På fanen Indsæt i gruppen Diagrammer skal du vælge Anbefalede diagrammer.

    Knappen Anbefalede diagrammer på fanen Indsæt

  3. Under fanen Anbefalede diagrammer kan du vælge et hvilket som helst diagram med pivotdiagramikonet Pivotdiagramknap i det øverste hjørne. Der vises et eksempel på pivotdiagrammet i eksempelruden.

    Dialogboksen Indsæt diagram med de anbefalede pivotdiagrammer

  4. Klik på OK, når du har fundet et pivotdiagram, du vil bruge. Excel opretter et nyt regneark til dig med både en pivottabel og et pivotdiagram.

  5. Du kan arrangere pivotdiagrammet til at være ved siden af pivottabellen for at få vist både pivoterede data og diagrammet, eller du kan placere pivotdiagrammet oven på dataene, hvis du kun vil have vist diagrammet.

  6. Du kan derefter formatere pivotdiagrammet.

Hvis du har prøvet indstillingen Anbefalede diagrammer uden at finde et, du kunne lide, kan du prøve at lave et selv.

  1. Markér en celle i dine regnearksdata, og gå til Indsæt > Pivotdiagram > Pivotdiagram.

  2. Excel viser en dialogboks, der spørger, hvor du vil placere pivotdiagrammet. Det er generelt en god ide at vælge indstillingen Nyt regneark, så du kan eksperimentere med at få dit diagram til at se ud som ønsket, uden at påvirke andet i regnearket.

    Excel Indsæt > Indstillinger for pivotdiagram
  3. Tryk på OK, hvorefter der tilføjes et nyt regneark i Excel med en tom pivottabel og et tomt pivotdiagram.

    Der vises et tomt pivotdiagram, og feltlisten vises, så du kan tilføje eller omarrangere felterne i dit pivotdiagram.

  4. Vælg de felter på feltlisten, som du vil vise i pivotdiagrammet.

    Feltliste, der viser en feltsektion og en områdesektion

  5. Du kan derefter formatere pivotdiagrammet.

Hvis du allerede har oprettet en pivottabel og konfigureret den på den måde, du ønsker, opretter denne metode det mest komplette pivotdiagram for dig.

  1. Vælg en vilkårlig celle i pivottabelområdet.

  2. Gå til Pivottabelværktøjer > Analysér > Pivotdiagram.

  3. Vælg den ønskede diagramtype, og tryk på OK.

    Excel indsætter et nyt pivotdiagram på samme ark med den pivottabel, du baserede det på. I dette eksempel valgte vi et standardkolonnediagram. Hvis du ikke er sikker på, hvilken diagramtype du vil have, kan du vælge dem én ad gangen, og Excel vil angive en direkte eksempelvisning af dem i ruden Indsæt diagram.

    Eksempel på pivotdiagram med direkte eksempelvisning af diagramtype og et søjlediagram, der er markeret

    Visse diagrammer understøttes ikke af pivottabeldata, så hvis du vælger en af dem, fortæller Excel dig det.

  4. Du kan derefter formatere pivotdiagrammet.

  1. Klik på Data > Fra andre kilder, og vælg derefter den datakilde, du vil bruge. Du kan f.eks. vælge Fra Analysis Services for at oprette forbindelse til en OLAP-kubefil (Online Analytical Processing).

    Knappen Fra andre kilder på fanen Data

  2. Følg trinnene i guiden Dataforbindelse, og klik på Udfør.

  3. I dialogboksen Importér data skal du vælge Pivotdiagram og den placering,hvor du vil anbringe dataene. Klik derefter på OK.

    Der vises et tomt pivotdiagram, og feltlisten vises, så du kan tilføje eller omarrangere felterne i dit pivotdiagram.

  4. Vælg de felter på feltlisten, som du vil vise i pivotdiagrammet.

    Feltliste, der viser en feltsektion og en områdesektion

  5. Du kan derefter formatere pivotdiagrammet.

  1. Klik på Indsæt > Pivotdiagram.

    Knappen Pivotdiagram på fanen Indsæt

  2. I dialogboksen Opret et pivotdiagram skal du klikke på Brug en ekstern datakilde og derefter klikke på Vælg forbindelse.

  3. I dialogboksen Eksisterende forbindelser skal du på fanen Forbindelser dobbeltklikke på den forbindelse, du vil bruge.

  4. Klik på OK.

    Der vises et tomt pivotdiagram, og feltlisten vises, så du kan tilføje eller omarrangere felterne i dit pivotdiagram.

  5. Vælg de felter på feltlisten, som du vil vise i pivotdiagrammet.

Feltliste, der viser en feltsektion og en områdesektion

Når du har oprettet et pivotdiagram, kan du tilpasse det stort set på samme måde som andre diagrammer. Når du markerer pivotdiagrammet:

  1. Der vises to knapper ud for diagrammet, så du hurtigt kan tilføje eller ændre diagramelementer, f.eks. titler eller datanavne, eller du kan ændre diagramtypografien og farverne i dit pivotdiagram på samme måde som i et almindeligt diagram.

    Pivotdiagram med navne, der peger på Feltknapper og Diagramværktøjer

  2. Feltknapper – Excel viser automatisk pivottabelfelter som knapper på pivotdiagrammet. Dette giver dig mulighed for at filtrere et enkelt pivotdiagram for kun at få vist de oplysninger, du vil se. Du kan også bruge Udsnitsværktøjer til pivottabeller til at filtrere flere pivottabeller og pivotdiagrammer på én gang i stedet for feltknapperne. Hvis du vil fjerne dem, skal du klikke på enten pivottabellen eller pivotdiagrammet, og derefter skal du i fanen Analysér på båndet fjerne markeringen i knappen Feltliste.

  3. Værktøjer til pivotdiagram vises på båndet. Under fanerne Analysér, Design og Formatér kan du vælge de indstillinger, du vil arbejde med, eller du kan tilpasse dit pivotdiagram.

    Værktøjer til pivotdiagram på båndet

  4. Et pivotdiagram behøver ikke at være i samme regneark som dets underliggende pivottabel, så når pivotdiagrammet ser ud som ønsket, kan du klippe og indsætte det på en anden placering.

  5. Hvis du vil fjerne et pivotdiagram, du ikke længere bruger, skal du markere det og trykke på Slet.

Hvis du vil oprette et pivotdiagram på Mac, skal du først oprette en pivottabel og derefter indsætte et diagram. Når det er gjort, vil diagrammet fungere som et pivotdiagram, hvis du ændrer felterne på listen Pivottabelfelter. 

  1. Opret en pivottabel, hvis du ikke allerede har én. 

  2. Vælg en vilkårlig celle i pivottabellen.

  3. På fanen Indsæt skal du klikke på en knap for at indsætte enten en kolonne, en linje, et cirkeldiagram eller et radardiagram. Bemærk, at andre typer diagrammer på nuværende tidspunkt ikke virker med pivottabeller. F.eks. virker træstrukturdiagrammer, statistiske diagrammer og kombinationsdiagrammer ikke med pivottabeller endnu.

  4. Når du indsætter et søjle-, kurve-, cirkel- eller et radardiagram, kan du dreje det ved at ændre eller flytte felter ved hjælp af listen Pivottabelfelter.

  5. Du kan også filtrere data i en pivottabel og anvende Udsnitsværktøj. Når du gør det, filtreres diagrammet også.

Har du brug for mere hjælp?

Du kan altid spørge en ekspert i Excel Tech Community, få support i Answers community eller foreslå en ny funktion eller forbedring i Excel User Voice.

Relaterede emner

Opret en pivottabel
Brug feltlisten til at arrangere felter i en pivottabel
Brug udsnitsværktøjer til at filtrere data
Opret en pivottabeltidslinje for at filtrere datoer

Udvid dine Office-færdigheder
Gå på opdagelse i kurser
Få nye funktioner først
Bliv Office Insider

Var disse oplysninger nyttige?

Tak for din feedback!

Tak for din feedback! Det lyder, som om det vil kunne hjælpe, hvis du bliver sat i forbindelse med en af vores Office-supportteknikere.

×