HVIS.FEJL, funktionen

Du kan bruge funktionen hvis. fejl til at diffusere og håndtere fejl i en formel. Hvis. fejl returnerer en værdi, du angiver, hvis en formel evalueres til en fejl. ellers returneres resultatet af formlen.

Syntaks

HVIS.FEJL(værdi;værdi_hvis_fejl)

Syntaksen for funktionen HVIS.FEJL har følgende argumenter:

  • value    Påkrævet. Det argument, der kontrolleres for fejl.

  • value_if_error    Påkrævet. Værdien, der skal returneres, hvis formlen evalueres som en fejl. Følgende fejltyper evalueres: #I/T, #VÆRDI!, #REFERENCE!, #Division/0!, #NUM!, #NAVN? eller #NULL!

Bemærkninger

  • Hvis værdi eller value_if_error er en tom celle, behandler hvis. fejl den som en tom strengværdi ("").

  • Hvis værdi er en matrixformel, returnerer hvis. fejl en matrix af resultater for hver celle i det område, der er angivet i værdi. Se det andet eksempel nedenfor.

Eksempler

Kopiér eksempeldataene i følgende tabel, og sæt dem ind i celle A1 i et nyt Excel-regneark. For at få formlerne til at vise resultater skal du markere dem, trykke på F2 og derefter trykke på Enter.

Kvote

Solgte enheder

210

35

55

0

s

Formel

Beskrivelse

Resultat

=HVIS.FEJL(A2/B2; "Fejl i beregning")

Kontrollerer, om der er fejl i formlens første argument (divider 210 med 35), finder ingen fejl, og returnerer derefter resultatet af formlen.

6

=HVIS.FEJL(A3/B3; "Fejl i beregning")

Kontrollerer, om der er fejl i formlens første argument (divider 55 med 0), finder en "division med 0"-fejl og returnerer derefter værdi_hvis_fejl.

Der opstod fejl i beregningen

=HVIS.FEJL(A4/B4; "Fejl i beregning")

Kontrollerer, om der er fejl i formlens første argument (divider "" med 23), finder ingen fejl, og returnerer derefter resultatet af formlen.

0

Eksempel 2

Kvote

Solgte enheder

Forhold

210

35

6

55

0

Der opstod fejl i beregningen

s

0

Formel

Beskrivelse

Resultat

=C2

Kontrollerer, om der er fejl i formlens første argument i det første element i matrixen (A2/B2 eller divider 210 med 35), finder ingen fejl, og returnerer derefter resultatet af formlen.

6

=C3

Kontrollerer, om der er fejl i formlens første argument i det andet element i matrixen (A3/B3 eller divider 55 med 0), finder en "division med 0"-fejl og returnerer derefter værdi_hvis_fejl.

Der opstod fejl i beregningen

=C4

Kontrollerer, om der er fejl i formlens første argument i det tredje element i matrixen (A4/B4 eller divider "" med 23), finder ingen fejl, og returnerer derefter resultatet af formlen.

0

Bemærk! Hvis du har en aktuel version af Office 365, kan du angive formlen i øverste venstre celle i outputområdet og derefter trykke på ENTER for at bekræfte formlen som en dynamisk matrixformel. Ellers skal formlen angives som en ældre matrixformel ved først at markere outputområdet, angive formlen øverst til venstre i outputområdet og derefter trykke på CTRL + SKIFT + ENTER for at bekræfte det. Excel indsætter klammeparenteser for dig i begyndelsen og slutningen af formlen. Se Retningslinjer for og eksempler på matrixformler for at få mere at vide om matrixformler.

Har du brug for mere hjælp?

Du kan altid spørge en ekspert i Excel Tech Community, få support i Answers community eller foreslå en ny funktion eller forbedring i Excel User Voice.

Bemærk!:  Denne side er oversat ved hjælp af automatisering og kan indeholde grammatiske fejl og unøjagtigheder. Det er vores hensigt, at dette indhold skal være nyttigt for dig. Var disse oplysninger nyttige? Her er artiklen på engelsk, så du kan sammenligne.

Udvid dine Office-færdigheder
Gå på opdagelse i kurser
Få nye funktioner først
Bliv Office Insider

Var disse oplysninger nyttige?

Tak for din feedback!

Tak for din feedback! Det lyder, som om det vil kunne hjælpe, hvis du bliver sat i forbindelse med en af vores Office-supportteknikere.

×