Funktionen IKKE

Bemærk!: Vi vil gerne give dig den mest opdaterede hjælp, så hurtigt vi kan, på dit eget sprog. Denne side er oversat ved hjælp af automatisering og kan indeholde grammatiske fejl og unøjagtigheder. Det er vores hensigt, at dette indhold skal være nyttigt for dig. Vil du fortælle os, om oplysningerne var nyttige for dig, nederst på denne side? Her er artiklen på engelsk så du kan sammenligne.

Brug funktionen IKKE, en af de logiske funktioner, når du vil sikre dig, at en værdi ikke er lig med en anden.

Eksempel

Eksempler på, at funktionen IKKE vender om på argumenter.  Eksempel  =IKKE(1+1=2)

Funktionen IKKE vender værdien af dets argument om.

En almindelig brug funktionen ikke er at udvide mailfunktionen mere nyttig på andre funktioner, der udfører logiske test. Eksempelvis Hvis -funktionen udfører en logisk test, og derefter returnerer én værdi, hvis testen evalueres til sand, og en anden værdi, hvis testen evalueres til falsk. Du kan teste mange forskellige betingelser i stedet for kun ved hjælp af funktionen ikke som argumentet logisk_test til funktionen Hvis .

Syntaks

IKKE(logisk)

Syntaksen for funktionen IKKE har følgende argumenter:

  • Logisk    Påkrævet. En værdi eller et udtryk, der kan evalueres som SAND eller FALSK.

Bemærkninger

Hvis logisk er FALSK, returnerer IKKE SAND, og hvis logisk er SAND, returnerer IKKE FALSK.

Eksempler

Her er nogle generelle eksempler på brug af IKKE alene og sammen med HVIS, OG og ELLER.

Eksempler på IKKE med funktionerne HVIS, OG og ELLER

Formel

Beskrivelse

= IKKE (A2>100)

A2 er IKKE større end 100

=HVIS(OG(IKKE(A2>1),IKKE(A2<100)),A2,"Værdien er uden for området")

50 er større end 1 (SAND), OG 50 er mindre end 100 (SAND), så IKKE vender begge argumenter til FALSK. OG kræver, at begge argumenter er SAND, så resultatet returneres i tilfælde af FALSK.

=HVIS(ELLER(IKKE(A3<0);IKKE(A3>50));A3;"Værdien er uden for området")

100 er ikke mindre end 0 (FALSK), og 100 er større end 50 (SAND), så IKKE vender argumenterne til SAND/FALSK. ELLER kræver kun ét argument for at være SAND, så resultatet returneres i tilfælde af SAND.

Beregning af salgsprovision

Her er et ret almindeligt scenarie, hvor vi har brug for at beregne, om sælgere er berettiget en provision ved hjælp af IKKE med HVIS og OG.

Eksempel på beregning af salgsbonus med funktionerne HVIS, OG og IKKE.  Formlen i celle E14 er =HVIS(OG(IKKE(B14<$B$7),IKKE(C14<$B$5)),B14*$B$8,0)
  • =HVIS(OG(IKKE(B14<$B$7),IKKE(C14<$B$5)),B14*$B$8,0)- HVIS samlet salg IKKE er mindre end salgsmålet, OG konti IKKE er mindre end kontomålet, så ganges det samlede salg med provision i procent, ellers returneres 0.

Har du brug for mere hjælp?

Du kan altid spørge en ekspert i Excel Tech Community, få support i Answers community eller foreslå en ny funktion eller forbedring i Excel User Voice.

Relaterede emner

Video: Avancerede Hvis-funktioner
Lær at bruge indlejrede funktioner i en formel
funktionen Hvis
og funktionen
funktionen eller
Oversigt over formler i Excel
Sådan undgår du ødelagte formler
Brug fejlkontrol til at registrere fejl i formler
tastaturgenveje i Excel til Windows
tastaturgenveje i Excel 2016 til Mac
Logiske funktioner (reference)
Excel-funktioner (alfabetisk)
Excel-funktioner (efter kategori)

Udvid dine Office-færdigheder
Gå på opdagelse i kurser
Få nye funktioner først
Bliv Office Insider

Var disse oplysninger nyttige?

Tak for din feedback!

Tak for din feedback! Det lyder, som om det vil kunne hjælpe, hvis du bliver sat i forbindelse med en af vores Office-supportteknikere.

×