Formler og funktioner

Funktionen HVIS

Funktionen HVIS

Bemærk!: Vi vil gerne give dig den mest opdaterede hjælp, så hurtigt vi kan, på dit eget sprog. Denne side er oversat ved hjælp af automatisering og kan indeholde grammatiske fejl og unøjagtigheder. Det er vores hensigt, at dette indhold skal være nyttigt for dig. Vil du fortælle os, om oplysningerne var nyttige for dig, nederst på denne side? Her er artiklen på engelsk så du kan sammenligne.

Hvis-funktionen er en af de mest populære funktioner i Excel, og det gør det muligt at foretage logiske sammenligninger mellem en værdi, og hvad du forvente.

Så en HVIS-sætning kan have to resultater. Det første resultat er, hvis din sammenligning er Sand, det andet hvis din sammenligning er Falsk.

For eksempel =HVIS(C2=”Ja”,1,2) bliver HVIS(C2 = Ja, så returneres a 1, ellers returneres a 2).

Din browser understøtter ikke video. Installer Microsoft Silverlight, Adobe Flash Player eller Internet Explorer 9.

Brug funktionen HVIS, som er en af de logiske funktioner, til at få returneret én værdi, hvis en betingelse er sand, og en anden værdi, hvis den er falsk.

HVIS(logisk_test, værdi_hvis_sand, [værdi_hvis_falsk])

Det kunne f.eks. være:

  • =HVIS(A2>B2;"Overskredet budget";"OK")

  • =HVIS(A2=B2,B4-A4,"")

Argumentnavn

Beskrivelse

logisk_test    (påkrævet)

Den betingelse, du vil teste.

værdi_hvis_sand    (påkrævet)

Den værdi, der skal returneres, hvis resultatet af logisk_test er SAND.

værdi_hvis_falsk    (valgfri)

Den værdi, der skal returneres, hvis resultatet af logisk_test er FALSK.

Simple HVIS-eksempler

Celle D2 indeholder en formel =HVIS(C2="Ja",1,2)
  • =HVIS(C2=”Ja”,1,2)

I eksemplet ovenfor står der i celle D2: HVIS(C2 = Ja, så returneres 1, ellers returneres 2)

Celle D2 indeholder formlen =HVIS(C2=1,"JA","NEJ")
  • =HVIS(C2=1,”Ja”,”Nej”)

I dette eksempel står der formlen i celle D2: IF(C2 = 1, then return Yes, otherwise return No)som du kan se, hvis-funktionen kan bruges til at evaluere både tekst og værdier. Det kan også bruges til at evaluere fejl. Du er ikke begrænset til kun kontrol af, om én ting er lig med en anden og returnere et enkelt resultat, du kan også bruge matematiske operatorer og udføre andre beregninger afhængigt af dine kriterier. Du kan også indlejre flere Hvis-funktioner sammen for at udføre flere sammenligninger.

Formlen i celle D2 er =HVIS(C2>B2,”Overskredet Budget”,”Inden for Budget”)
  • =HVIS(C2>B2,”Overskredet Budget”,”Inden for Budget”)

I eksemplet ovenfor siger funktionen HVIS i D2 HVIS (C2 er større end B2, returneres derefter "Overskredet Budget", ellers returneres "Inden for Budget")

Formlen i celle E2 er =HVIS(C2>B2,C2-B2,"")
  • = HVIS(C2>B2,C2-B2,0)

I den ovenstående illustration vil vi i stedet for at returnere et tekstresultat returnere en matematisk beregning. Så formlen i E2 siger HVIS(Faktisk er større end Budgetteret, så træk det budgetterede beløb fra det faktiske beløb, ellers returneres ingenting).

Formlen i celle F7 er HVIS(E7="Ja",F5*0,0825,0)
  • =HVIS(E7="Ja",F5*0.0825,0)

I dette eksempel står der i formlen i F7, at HVIS(E7 = "Ja", så beregn det samlede beløb i F5 * 8,25 %, ellers opkræves der ingen afgift, så der returneres 0)

Bemærk!: Hvis du vil bruge tekst i formler, skal du pakke teksten ind i anførselstegn (f.eks. "Tekst"). Den eneste undtagelse til dette er anvendelsen af SAND eller FALSK, som Excel automatisk forstår.

Almindelige problemer

Problem

Hvad der gik galt

0 (nul) i celle

Der var ikke noget argument for hverken værdi_hvis_sand eller værdi_hvis_falsk. For at få returneret den rigtige værdi skal du føje argumenttekst til de to argumenter eller føje SAND eller FALSK til argumentet.

#NAVN? i en celle

Dette betyder som regel, at formlen er stavet forkert.

Har du brug for mere hjælp?

Du kan altid spørge en ekspert i Excel Tech Community, få support i Answers community eller foreslå en ny funktion eller forbedring i Excel User Voice.

Se også

Beregningsoperatorer og operatorer i Excel

Brug af indlejrede funktioner i en formel

Brug af Hvis at kontrollere, om en celle er tom

Brug af Hvis at kontrollere, om en celle er tom

Video: avancerede Hvis-funktioner

IFS funktionen (Office 365, Excel 2016 eller nyere)

Avancerede Hvis funktionerne - arbejde med indlejrede formler og undgå faldgruber

Kursus videoer: avancerede Hvis-funktioner

Feltet Tæl vil sammentælle værdier ud fra et enkelt kriterium

Feltet Tæl.HVISER vil tælle værdier baseret på flere kriterier

Funktionen feltet sum.Hvis kan lægge værdier baseret på et enkelt kriterium

Funktionen feltet sum.HVISER kan lægge værdier baseret på flere kriterier

Funktionen og

Funktionen eller

Funktionen LOPSLAG

Oversigt over formler i Excel

Sådan undgår du ødelagte formler

Brug af fejlkontrol til at registrere fejl i formler

Logiske funktioner

Excel-funktioner (alfabetisk)

Excel-funktioner (efter kategori)

Udvid dine Office-færdigheder
Gå på opdagelse i kurser
Få nye funktioner først
Bliv Office Insider

Var disse oplysninger nyttige?

Tak for din feedback!

Tak for din feedback! Det lyder, som om det vil kunne hjælpe, hvis du bliver sat i forbindelse med en af vores Office-supportteknikere.

×