FELTVÆRDI-funktionen

Du kan bruge FELTVÆRDI-funktionen til at hente feltdata fra sammenkædede datatyper som f.eks. datatyperne Aktier og Geografi. Der findes nemmere måder at skrive formler på, der henviser til datatyper, så funktionen FELTVÆRDI bør primært bruges til at oprette betingede beregninger baseret på sammenkædede datatyper.

Bemærk!: 27. november 2018. Datatyper er blevet udgivet til alle Windows-Office 365-abonnenter med undtagelse af et par geopolitiske placeringer (kommer snart). Hvis du er Office 365-abonnent, skal du sørge for, at du har den seneste version af Office.

Tekniske detaljer

Syntaks

=FELTVÆRDI(værdi, felt_navn)

FELTVÆRDI-funktionens syntaks har de følgende argumenter:

Argument

Beskrivelse

værdi

Funktionen returnerer alle matchende felter fra den sammenkædede datatype, der er angivet i værdiargumentet.

feltnavn

Navnet eller navnene på de felter, du vil trække ud fra den sammenkædede datatype.

Beskrivelse

  • Funktionen FELTVÆRDI returnerer alle matchende felter fra den sammenkædede datatype, der er angivet i værdiargumentet.

  • Funktionen FELTVÆRDI hører til Opslag og reference-funktionsserien.

Eksempler

I det følgende grundlæggende eksempel udtrækker formlen =FELTVÆDI(A2,"Kurs") feltet Kurs fra aktiedatatypen fra JM Smucker Co.

Hent en virksomheds aktiekurs med =FELTVÆRDI(A2,"Kurs")

Det næste eksempel er mere typisk for FELTVÆRDI-funktionen. Her bruger vi funktionen HVIS.FEJL for at kontrollere for fejl. Hvis der ikke er et firmanavn i celle A2, så returnerer formlen FELTVÆRDI en fejl, og i dette tilfælde skal der ikke vises noget (""). Men hvis der er et firmanavn, skal Kursen hentes fra datatypen i A2 med =HVIS.FEJL(FELTVÆRDI($A2,B$1),"").

Hent en virksomheds aktiekurs, og ignorer fejl med =HVISFEJL(FELTVÆRDI($A2,B$1),"")

Bemærk, at FELTVÆRDI-funktionen giver dig adgang til at henvise til regnearkets celler for argumentet felt_navn, således at den ovenstående formel henviser til celle B1 for Kurs i stedet for manuelt at indtaste "Kurs" i formlen. 

Bemærkninger

Hvis du forsøger at hente data fra et ikke-eksisterende datatypefelt, returnerer funktionen FELTVÆRDIfejlen #FELT!. Du kan f.eks. have indtastet "Kurser" i stedet for det faktiske navn på datatypefeltet – "Kurs". Dobbelttjek din formel for at sørge for, at du bruger et gyldigt feltnavn. Hvis du vil have vist en liste over feltnavne i en post, skal du markere cellen for posten og trykke på Alt+Skift+F10.

Har du brug for mere hjælp?

Du kan altid spørge en ekspert i Excel Tech Community, få support i Answers community eller foreslå en ny funktion eller forbedring i Excel User Voice.

Se også

Datatyperne Aktiekurser og Geografiske data

Sådan skrives formler, der henviser til datatyper

#FELT!-fejl

Udvid dine Office-færdigheder
Gå på opdagelse i kurser
Få nye funktioner først
Bliv Office Insider

Var disse oplysninger nyttige?

Tak for din feedback!

Tak for din feedback! Det lyder, som om det vil kunne hjælpe, hvis du bliver sat i forbindelse med en af vores Office-supportteknikere.

×