Brug af SUMPRODUKT til at returnere summen af produkterne af tilsvarende værdier i ét eller flere matrixer

Bemærk!:  Vi vil gerne give dig den mest opdaterede hjælp, så hurtigt vi kan, på dit eget sprog. Denne side er oversat ved hjælp af automatisering og kan indeholde grammatiske fejl og unøjagtigheder. Det er vores hensigt, at dette indhold skal være nyttigt for dig. Vil du fortælle os, om oplysningerne var nyttige for dig, nederst på denne side? Her er artiklen på engelsk så du kan sammenligne.

SUMPRODUKT bruger celleområder (eller matrixer) som argumenterne (den del af formlen, som gør det arbejde). Den multiplicerer sammen elementerne i matrixer og derefter summerer resultatet.

Dette eksempel er en indkøbsliste, hvor én matrix opstiller prisen på hver vare, og den anden matrix opstiller antallet af varer, der skal købes.

Liste over indkøbsvarer i kolonne A. I kolonne B (matrix 1) vises prisen pr. enhed. I kolonne C (matrix 2) vises den mængde, der købes

  1. For at oprette formlen, skal du skrive =SUMPRODUKT(B3:B6;C3:C6) og tryk på Enter.

Hver celle i kolonne B ganges med den tilsvarende celle i samme række i kolonne C, og resultaterne lægges sammen. Det samlede beløb for varerne er 21,60.

  1. Du kan skrive en længere formel, der giver dig det samme resultat, type = B3 * C3 + B4 * C4 + B5 * C5 + B6 * C6 og trykke på Enter.

Når du har trykket Enter, er resultatet det samme: $ 21,60. Celle B3 ganges med C3, og resultatet lægges til resultatet fra celle B4, som så ganges med celle C4 osv. Forestil dig, hvor meget nemmere det er at bruge SUMPRODUKT, hvis du har tusindvis (eller endda bare hundredvis) af rækker.

Bemærkninger!: 

  • Kolonnerne eller rækkerne (matrixer) skal være lige lange.

  • Hvis der i et felt står tekst i stedet for tal, fortolkes det som nuller.

Eksempel

Hvis du vil lege lidt med SUMPRODUKT og matrixer, er her en Excel Online-projektmappe med nogle andre data end bruges i denne artikel.

Kopiér eksempeldataene i følgende tabel, og sæt dem ind i celle A1 i et nyt Excel-regneark. For at få formlerne til at vise resultater skal du markere dem, trykke på F2 og derefter trykke på Enter. Hvis der er brug for det, kan du justere bredden på kolonnerne, så du kan se alle dataene.

A

B

D

E

3

4

2

7

8

6

6

7

1

9

5

3

Formel

Resultat

'=SUMPRODUKT(A2:B4;D2:E4)

=SUMPRODUKT(A2:B4;D2:E4)

Multiplicerer alle komponenter i de to matrixer (A2:B4 og D2:E4) og lægger derefter produkterne sammen, dvs. 3*2 + 4*7 + 8*6 + 6*7 + 1*5 + 9*3 (156).

Du kan også åbne projektmappen i Excel for at få en fulde oplevelse. Klik på Excel-ikonet i nederste højre hjørne af projektmappen Excel-ikon i Excel Online , gemme filen et praktisk sted på computeren og derefter åbne den.

Toppen af siden

Udvid dine Office-færdigheder
Gå på opdagelse i kurser
Få nye funktioner først
Bliv Office Insider

Var disse oplysninger nyttige?

Tak for din feedback!

Tak for din feedback! Det lyder, som om det vil kunne hjælpe, hvis du bliver sat i forbindelse med en af vores Office-supportteknikere.

×