Brug af HVIS med funktionerne OG, ELLER og IKKE

Bemærk!: Vi vil gerne give dig den mest opdaterede hjælp, så hurtigt vi kan, på dit eget sprog. Denne side er oversat ved hjælp af automatisering og kan indeholde grammatiske fejl og unøjagtigheder. Det er vores hensigt, at dette indhold skal være nyttigt for dig. Vil du fortælle os, om oplysningerne var nyttige for dig, nederst på denne side? Her er artiklen på engelsk så du kan sammenligne.

HVIS-funktionen gør det muligt at foretage en logisk sammenligning mellem en værdi, og hvad du forventer, ved at teste for en betingelse og returnere et resultat, hvis den betingelse er Sand eller Falsk.

  • =HVIS(Noget er sandt, så gør noget, ellers gør noget andet)

Men hvad hvis du har brug at teste flere betingelser, hvor Antag, at alle betingelser skal være sandt eller FALSK (og), eller kun én betingelse skal være sandt eller FALSK (eller), eller hvis du vil kontrollere, hvis en betingelse betyder ikke opfylder dine kriterier? Alle 3 funktioner kan bruges på egen hånd, men det er meget mere almindeligt at se dem sammen med Hvis-funktioner.

Brug HVIS-funktionen sammen med OG, ELLER og IKKE til at udføre flere evalueringer, hvis betingelser er Sand eller Falsk.

Syntaks

  • HVIS(OG()) - HVIS(OG(logisk1, [logisk2], ...), værdi_hvis_sand, [værdi_hvis_falsk]))

  • HVIS(ELLER()) - HVIS(ELLER(logisk1, [logisk2], ...), værdi_hvis_sand, [værdi_hvis_falsk]))

  • HVIS(IKKE()) - HVIS(IKKE(logisk1), værdi_hvis_sand, [værdi_hvis_falsk]))

Argumentnavn

Beskrivelse

logisk_test (påkrævet)

Den betingelse, du vil teste.

værdi_hvis_sand (påkrævet)

Den værdi, der skal returneres, hvis resultatet af logisk_test er SAND.

værdi_hvis_falsk (valgfri)

Den værdi, der skal returneres, hvis resultatet af logisk_test er FALSK.

Her er en oversigt over hvordan skal struktureres og, eller og ikke funktioner enkeltvis. Når du kombinerer hver enkelt af dem med en IF-sætning, læse de således:

  • OG – =HVIS(OG(noget er sandt, noget andet er sandt), værdi hvis Sand, værdi hvis Falsk)

  • ELLER – =HVIS(ELLER(noget er sandt, noget andet er sandt), værdi hvis Sand, værdi hvis Falsk)

  • IKKE – = Hvis (IKKE(noget er sandt), værdi hvis Sand, værdi hvis Falsk)

Eksempler

Følgende er nogle eksempler på nogle almindelige indlejrede IF(AND()), IF(OR()) og IF(NOT()) sætninger. Funktionerne og og eller funktioner kan understøtte op til 255 individuelle betingelser, men ikke er god praksis at bruge mere end et par, fordi komplekse, indlejrede formler kan få meget svært at opbygge, teste og vedligeholde. Funktionen ikke tager kun en enkelt betingelse.

Eksempler på brug af HVIS med OG, ELLER og IKKE til evaluering af numeriske værdier og tekst

Her er de formler, der er skrevet helt ud i henhold til deres logik:

Formel

Beskrivelse

=HVIS(OG(A2>0,B2<100),SAND, FALSK)

Hvis A2 (25) er større end 0, og B2 (75) er mindre end 100, og derefter returnere SAND, ellers returnerede falsk. I dette tilfælde er begge betingelser opfyldt, så der returneres SAND.

=HVIS(OG(A3="Rød",B3="Grøn"),SAND,FALSK)

Hvis A3 ("blå") = "Rød", og B3 ("grøn") er lig med "Grøn" derefter returnerer TRUE, ellers returneres falsk. I dette tilfælde er kun den første betingelse SAND, så returneres falsk.

=HVIS(ELLER(A4>0,B4<50),SAND, FALSK)

Hvis A4 (25) er større end 0, eller B4 (75) er mindre end 50, og derefter returnere SAND, ellers returnerede falsk. I dette tilfælde kun den første betingelse er sand, men siden eller kun kræver ét argument er sand, returnerer SAND, formlen.

=HVIS(ELLER(A5="Rød",B5="Grøn"),SAND,FALSK)

Hvis A5 ("blå") er lig med "Rød", eller B5 ("grøn") er lig med "Grøn" derefter returnerer TRUE, ellers returneres falsk. I dette tilfælde skal er det andet argument SAND, så formlen returnerer SAND.

= HVIS(IKKE(A6>50),SAND,FALSK)

Hvis A6 (25) ikke er større end 50, og derefter ENTER SAND, ellers returneres falsk. I dette tilfælde er 25 ikke større end 50, så formlen returnerer SAND.

=HVIS(IKKE(A7="Rød"),SAND,FALSK)

HVIS A7 ("blå") IKKE er lig med "Rød", returneres SAND, ellers returneres FALSK.

Bemærk, at alle eksemplerne har en højreparentes, når deres respektive betingelser er angivet. De resterende argumenter sand/falsk bevares derefter som en del af den ydre IF-sætning. Du kan også erstatte tekst eller numeriske værdier til TRUE/FALSE-værdier skal returneres i eksemplerne.

Her er nogle eksempler på brug af OG, ELLER og IKKE til evaluering af datoer

Eksempler på brug af HVIS med OG, ELLER og IKKE til evaluering af datoer

Her er de formler, der er skrevet helt ud i henhold til deres logik:

Formel

Beskrivelse

=HVIS(A2>B2,SAND,FALSK)

Hvis A2 er større end B2, returnerede TRUE, ellers returnere falsk. 12-03/14 er større end 01/01/14, så formlen returnerer SAND.

=HVIS(OG(A3>B2,A3<C2),SAND,FALSK)

Hvis A3 er større end B2 og A3 er mindre end C2, returnerer SAND, returnerer ellers FALSE. I dette tilfælde er begge argumenter SAND, så formlen returnerer SAND.

=HVIS(ELLER(A4>B2,A4<B2+60),SAND,FALSK)

Hvis A4 er større end B2 eller A4 er mindre end B2 + 60, returnere SAND, ellers returnerede falsk. I dette tilfælde det første argument er sand, men andet er falsk. Siden eller kun har brug for et af argumenterne er sand, returnerer SAND, formlen. Hvis du bruger guiden Evaluer formel fra fanen formel skal du se, hvordan Excel evaluerer formlen.

=HVIS(IKKE(A5>B2),SAND,FALSK)

Hvis A5 ikke er større end B2, returneres SAND, ellers returnerede falsk. I dette tilfælde er A5 større end B2, så formlen returnerer falsk.

Eksempel på guiden Evaluer formel

Brug af OG, ELLER og IKKE med betinget formatering

Du kan også bruge AND, OR og ikke til at angive kriterier for betinget formatering med indstillingen formel. Når du gør dette kan du udelader funktionen Hvis og bruge AND, OR og ikke på deres egne.

Klik på betinget formatering > ny regelpå fanen Startside . Derefter skal du vælge indstillingen "Brug en formel til at bestemme, hvilke celler der skal formateres", Angiv formlen og anvende formatet efter eget valg.

Betinget formatering > Rediger regel-dialogboks, der viser metoden Formel

Med brug af det tidligere datoeksempel kan du se her, hvad formlerne ville være.

Eksempel på brug af OG, ELLER og IKKE som test af betinget formatering

Formel

Beskrivelse

=A2>B2

Hvis A2 er større end B2, skal du formatere cellen, ellers skal du ikke gøre noget.

=OG(A3>B2,A3<C2)

Hvis A3 er større end B2, OG A3 er mindre end C2, skal du formatere cellen, ellers skal du ikke gøre noget.

=ELLER(A4>B2,A4<B2+60)

Hvis A4 er større end B2, ELLER A4 er mindre end B2 plus 60 (dage), skal du formatere cellen, ellers skal du ikke gøre noget.

=IKKE(A5>B2)

Hvis A5 ikke er større end B2, skal du formatere cellen, ellers ikke gør noget. I dette tilfælde er A5 større end B2, så resultatet vil returnere falsk. Hvis du skulle ændre formlen til =NOT(B2>A5) det vil returnere SAND, og cellen skal formateres.

Bemærk!: En almindelig fejl er at angive formlen i betinget formatering uden lighedstegnet (=). Hvis du gør det får du vist, at dialogboksen betinget formatering føjes lighedstegn og tilbud til formlen - = "OR(A4>B2,A4<B2+60)", så du skal fjerne anførselstegn, før formlen reagerer korrekt.

Toppen af siden

Har du brug for mere hjælp?

Du kan altid spørge en ekspert i Excel Tech Community, få support i Answers community eller foreslå en ny funktion eller forbedring i Excel User Voice.

Se også

Se en video om hvordan du bruger funktionen Hvis

Lær at bruge indlejrede funktioner i en formel

Funktionen HVIS

Funktionen OG

Funktionen OR

Funktionen NOT

Oversigt over formler i Excel

Sådan undgår du ødelagte formler

Find fejl i formler

Tastaturgenveje i Excel til Windows

Tastaturgenveje i Excel til Mac

Logiske funktioner (reference)

Excel-funktioner (alfabetisk)

Excel-funktioner (efter kategori)

Udvid dine Office-færdigheder
Gå på opdagelse i kurser
Få nye funktioner først
Bliv Office Insider

Var disse oplysninger nyttige?

Tak for din feedback!

Tak for din feedback! Det lyder, som om det vil kunne hjælpe, hvis du bliver sat i forbindelse med en af vores Office-supportteknikere.

×