TÆL.HVIS, funktionen

I denne artikel beskrives formelsyntaksen for og brugen af funktionenTÆL.HVIS i Microsoft Excel.

Beskrivelse

Funktionen TÆL.HVIS tæller det antal celler i et område, der opfylder et enkelt kriterium, du angiver. Du kan f.eks. tælle alle de celler, der starter med et bestemt bogstav, eller du kan tælle alle de celler, der indeholder et tal, der er større eller mindre end et tal, du angiver. Antag f.eks., at du har et regneark, der indeholder en liste over opgaver i kolonne A, og fornavnet på de personer, der er tildelt til de enkelte opgaver, i kolonne B. Du kan bruge funktionen TÆL.HVIS til at tælle, hvor mange gange en persons navn vises i kolonne B, og på den måde bestemme, hvor mange opgaver der er tildelt til den pågældende person, f.eks.:

=TÆL.HVIS(B2:B25;"Nancy")

Bemærk   Hvis du vil tælle celler på basis af flere kriterier, skal du se Funktionen TÆL.HVISER.

Syntaks

TÆL.HVIS(område; kriterier)

Syntaksen for funktionen TÆL.HVIS har følgende argument:

  • område    Påkrævet. En eller flere celler, der skal tælles, herunder tal eller navne, matrixer eller referencer, der indeholder tal. Tomme celler og tekstværdier ignoreres

  • kriterier    Påkrævet. Et tal, et udtryk, en cellereference eller en tekststreng, som definerer, hvilke celler der skal tælles. Kriterier kan f.eks. udtrykkes som 32, ">32", B4, "æbler" eller "32".

    Bemærk   

    • Du kan bruge jokertegnene – spørgsmålstegn (?) og stjerne (*) – i kriterier. Et spørgsmålstegn repræsenterer et vilkårligt enkelttegn, og en stjerne repræsenterer en vilkårlig tegnsekvens. Hvis du vil søge efter et spørgsmålstegn eller en stjerne i selve teksten, skal du angive en tilde (~) foran tegnet.

    • Der skelnes ikke mellem store og små bogstaver i kriterier. Strengen "æbler" og strengen "ÆBLER" matcher f.eks. de samme celler.

Bemærkninger

  • Funktionen TÆL.HVIS returnerer forkerte resultater, når du bruger den til at matche strenge på mere end 255 tegn med strengen #VÆRDI!.

Eksempler

I den integrerede projektmappe nedenfor kan du se eksempler på denne funktion. Du kan undersøge og ændre eksisterende formler eller angive dine egne formler for at lære, hvordan funktionen fungerer.

Kopiér eksempeldataene i følgende tabel, og sæt dem ind i celle A1 i et nyt Excel-regneark. For at få formlerne til at vise resultater skal du markere dem, trykke på F2 og derefter trykke på Enter. Hvis der er brug for det, kan du justere bredden på kolonnerne, så du kan se alle dataene.

Data

Data

æbler

32

appelsiner

54

ferskner

75

æbler

86

Formel

Beskrivelse

Resultat

=TÆL.HVIS(A2:A5;"æbler")

Antal celler med æbler i cellerne A2 til og med A5.

2

=TÆL.HVIS(A2:A5;A4)

Antal celler med ferskner i cellerne A2 til og med A5.

1

=TÆL.HVIS(A2:A5;A3)+TÆL.HVIS(A2:A5;A2)

Antal celler med appelsiner og æbler i cellerne A2 til og med A5.

3

=TÆL.HVIS(B2:B5;">55")

Antal celler med en højere værdi end 55 i cellerne B2 til og med B5.

2

=TÆL.HVIS(B2:B5;"<>"&B4)

Antal celler med en værdi, der er forskellig fra 75, i cellerne B2 til og med B5.

3

=TÆL.HVIS(B2:B5;">=32")-TÆL.HVIS(B2:B5;">85")

Antal celler med en værdi, der er større end eller lig med 32 og mindre end eller lig med 85 i cellerne B2 til og med B5.

3

Hvis du vil arbejde mere i dybden med eksempeldataene i Excel, kan du hente den integrerede projektmappe til computeren og åbne den i Excel.

Eksempel 2

Data

æbler

Ja

appelsiner

NEJ

ferskner

Nej

æbler

ja

Formel

Beskrivelse

Resultat

=TÆL.HVIS(A2:A7,"*er")

Antal celler, der slutter med bogstaverne "er" i cellerne A2 til og med A7.

4

=TÆL.HVIS(A2:A7;"?????er")=

Antal celler, der slutter med bogstaverne "er" og har nøjagtigt syv bogstaver i cellerne A2 til og med A7.

2

=TÆL.HVIS(A2:A7;"*")=

Antal celler, der ikke indeholder tekst i cellerne A2 til og med A7.

4

=TÆL.HVIS(A2:A7;"<>"&"*")

Antal celler, der indeholder tekst i cellerne A2 til og med A7.

2

=TÆL.HVIS(B2:B7;"Nej") / RÆKKER(B2:B7)

Det gennemsnitlige antal Nej-stemmer inklusive tomme celler i cellerne B2 til og med B7.

0,33333333

=TÆL.HVIS(B2:B7;"Ja") / (RÆKKER(B2:B7) -TÆL.HVIS(B2:B7;"<>"&"*"))

Det gennemsnitlige antal Ja-stemmer eksklusive tomme celler i cellerne B2 til og med B7.

0,5

Gælder: Excel 2013, Excel Online



Var disse oplysninger nyttige?

Ja Nej

Hvordan kan vi forbedre det?

255 tegn tilbage

Inkluder ikke kontaktoplysninger i din feedback for at beskytte dine personlige oplysninger. Gennemse vores erklæring om beskyttelse af personlige oplysninger.

Tak for din feedback!

Supportressourcer

Skift sprog