Tælle tal eller datoer ud fra en test

Vigtigt: Denne artikel er maskinoversat. Se ansvarsfraskrivelsen. Du kan finde den engelske version af denne artikel her til din orientering.

Vigtig meddelelse til brugere af Office 2003    Hvis du fortsat vil modtage sikkerhedsopdateringer til Office, skal du sikre dig, at du kører Office 2003 Service Pack 3 (SP3). Support til Office 2003 ophører den 8. april 2014. Hvis du kører Office 2003, efter at supporten ophører, og du vil modtage alle vigtige sikkerhedsopdateringer til Office, skal du opgradere til en nyere version som f.eks. Office 365 eller Office 2013. Du finder flere oplysninger under Support til Office 2003 ophører.

Tælle tal eller datoer, der opfylder et enkelt test (f.eks som lig med, større end, mindre end, større end eller lig med eller mindre end eller lig med), skal du bruge funktionen TÆL.HVIS . I Excel 2007 eller nyere, hvis du vil tælle tal eller datoer, der falder inden for et interval (såsom større end mindre end 22500 9000 og på samme tid), kan du bruge funktionen TÆL.HVISER . Hvis du bruger Excel 2003 eller tidligere, kan du bruge funktionen SUMPRODUKT til at tælle de tal, der falder inden for et område (TÆL.HVISER blev introduceret i Excel 2007).

Eksempel

Hvis du kopierer eksemplet til et tomt regneark, er det måske nemmere at forstå.

Sådan kopieres et eksempel

  1. Opret en tom projektmappe eller et tomt regneark.

  2. Markér eksemplet i emnet i Hjælp.
    Vigtigt    Markér ikke række- eller kolonneoverskrifter.
    Markere et eksempel i Hjælp

  3. Tryk på Ctrl+C.

  4. Marker celle A1 i regnearket, og tryk på CTRL+V.

Hvis du vil skifte mellem visning af resultaterne og visning af de formler, der returnerer resultaterne, skal du trykke på Ctrl + ` (accent grave) eller klikke på knappen Vis formler i gruppen Formelrevision under fanen Formler.

1

2

3

4

5

6%

7

8

9

10

11

12

13

14

15

16

17

A

B

Sælger

Faktura

Buchanan

15.000

Buchanan

9.000

Suyama

8.000

Suyama

20.000

Buchanan

5.000

Dodsworth

22.500

Formel

Beskrivelse (resultat)

=TÆLHVIS(B2:B7;">9000")

Funktionen TÆL.HVIS tæller det antal celler i området B2:B7, der indeholder tal, som er større end 9000 (4)

=TÆLHVIS(B2:B7;"<=9000")

Funktionen TÆL.HVIS tæller det antal celler i området B2:B7, der indeholder tal, som er mindre end 9000 (4)

=TÆL:HVIS(B2:B7,">=9000",B2:B7,"<=22500")

Funktionen TÆL.HVIS (tilgængelig i Excel 2007 og senere versioner) tæller det antal celler i området B2:B7, som er større end eller lig med 9000, og som er mindre end eller lig med 22.500 (4)

=SUMPRODUKT((B2:B7>=9000)*(B2:B7<=22500))

Funktionen SUMPRODUKT tæller antallet af celler i området B2:B7, der indeholder tal, der er større end eller lig med 9.000 eller mindre end eller lig med 22.500 (4). Du kan bruge denne funktion i Excel 2003 og tidligere versioner, hvor TÆL.HVIS ikke er tilgængelig.

Dato

11.03.2011

01.01.2010

31.12.2010

30.06.2010

Formel

Beskrivelse (resultat)

=TÆL.HVIS(B14:B17,">01.03.2010")

Tæller antal af celler i området B14:B17, som har en dato der ligger efter 01.03.2010 (3)

=TÆL.HVIS(B14:B17,"31.12.2010")

Tæller antal af celler i området B14:B17, der er lig med 31.12.2010 (1). Lighedstegnet er ikke nødvendigt i kriterierne, så det medtages ikke (formlen fungerer med et lighedstegn, hvis du medtager det ("=31.12.2010").

=TÆL.HVIS(B14:B17,">=01.01.2010",B14:B17,"<=31.12.2010")

Tæller antallet af celler i områder B14:B17, der ligger mellem (begge inklusive) 01.01.2010 og 31.12.2010 (3).

=SUMPRODUKT((B14:B17>=DATOVÆRDI("01.01.2010"))*(B14:B17<=DATOVÆRDI("31.12.2010")))

Tæller antallet af celler i området B14:B17, der ligger mellem (begge inklusive) 01.01.2010 og 31.12.2010 (3). Dette eksempel fungerer som en erstatning for funktionen TÆL:HVIS, der blev introduceret i Excel 2007. Funktionen DATOVÆRDI konverterer datoerne til en numerisk værdi, som derefter kan bruges i funktionen SUMPRODUKT.

Funktionsoplysninger

Funktionen TÆL.HVIS tæller antallet af celler i et område, der opfylder et enkelt kriterium (betingelse), du angiver.

TÆL.HVIS(område; kriterier)

Funktionen TÆL.HVIS anvender flere kriterier på celler på tværs af flere områder og tæller derefter det antal gange, alle kriterierne overholdes. Du kan bruge funktionen TÆL:HVIS til at finde flere kriterier i samme område, de samme kriterier på flere områder eller flere kriterier på flere områder.

=TÆL.HVIS(kriterieområde1, kriterie1, kriterieområde2, kriterie2,…)

I eksemplet med TÆL.HVIS er kriterieområde1 B2:B7, kriterie1 er ">=9000", kriterieområde2 er igen B2:B7 og kriterie2 er "<=22500". Det samme talområde testes to gange, men du kan også teste et antal forskellige områder, hvor der anvendes forskellige kriterier til de enkelte områder.

Som vist i eksemplet kan funktionen SUMPRODUKT anvendes i Excel 2003 og tidligere, hvor TÆL.HVIS ikke er tilgængelig. I eksemplet med SUMPRODUKT fungerer B2:B7>=9000 som parret af kriterieområde1 og kriterie1, og B2:B7<=22500 fungerer som parret af kriterieområde2 og kriterie2, der anvendes i eksemplet med TÆL.HVIS.

Se funktionen TÆL.HVIS, funktionen TÆL.HVISERog funktionen SUMPRODUKTkan finde flere oplysninger.

Bemærk: Ansvarsfraskrivelse for maskinoversættelse: Denne artikel er blevet oversat af et computersystem uden menneskelig indgriben. Microsoft tilbyder disse maskinoversættelse for at hjælpe ikke-engelsktalende brugere til at kunne nyde indhold om Microsofts produkter, tjenester og teknologier. Da artiklen er maskinoversat, kan den indeholde forkerte ord eller syntaks- eller grammatikfejl.

Del Facebook Facebook Twitter Twitter Mail Mail

Var disse oplysninger nyttige?

Fantastisk! Har du mere feedback?

Hvordan kan vi forbedre det?

Tak for din feedback!

×