Tælle tal eller datoer, der er baseret på en betingelse

Vigtigt: Denne artikel er maskinoversat. Se ansvarsfraskrivelsen. Du kan finde den engelske version af denne artikel her til din orientering.

Brug funktionen Tæl.Hvis til at tælle tal eller datoer, der opfylder en enkelt betingelse (f.eks som lig med, større end mindre end større end eller lig med eller mindre end eller lig med). Hvis du vil tælle tal eller datoer, der falder inden for et interval (såsom større end mindre end 22500 9000 og på samme tid), kan du bruge funktionen Tæl.HVISER . Alternativt kan du bruge SUMPRODUKT for.

Eksempel

1

2

3

4

5

6%

7

8

9

10

11

12

13

14

15

16

17

A

B

Sælger

Faktura

Buchanan

15.000

Buchanan

9.000

Suyama

8.000

Suyama

20.000

Buchanan

5.000

Dodsworth

22.500

Formel

Beskrivelse (resultat)

=TÆLHVIS(B2:B7;">9000")

Funktionen TÆL.HVIS tæller det antal celler i området B2:B7, der indeholder tal, som er større end 9000 (4)

=TÆLHVIS(B2:B7;"<=9000")

Funktionen TÆL.HVIS tæller det antal celler i området B2:B7, der indeholder tal, som er mindre end 9000 (4)

=TÆL:HVIS(B2:B7,">=9000",B2:B7,"<=22500")

Funktionen TÆL.HVIS (tilgængelig i Excel 2007 og senere versioner) tæller det antal celler i området B2:B7, som er større end eller lig med 9000, og som er mindre end eller lig med 22.500 (4)

=SUMPRODUKT((B2:B7>=9000)*(B2:B7<=22500))

Funktionen SUMPRODUKT tæller antallet af celler i området B2:B7, der indeholder tal, der er større end eller lig med 9.000 eller mindre end eller lig med 22.500 (4). Du kan bruge denne funktion i Excel 2003 og tidligere versioner, hvor TÆL.HVIS ikke er tilgængelig.

Dato

11.03.2011

01.01.2010

31.12.2010

30.06.2010

Formel

Beskrivelse (resultat)

=TÆL.HVIS(B14:B17,">01.03.2010")

Tæller antal af celler i området B14:B17, som har en dato der ligger efter 01.03.2010 (3)

=TÆL.HVIS(B14:B17,"31.12.2010")

Tæller antal af celler i området B14:B17, der er lig med 31.12.2010 (1). Lighedstegnet er ikke nødvendigt i kriterierne, så det medtages ikke (formlen fungerer med et lighedstegn, hvis du medtager det ("=31.12.2010").

=TÆL.HVIS(B14:B17,">=01.01.2010",B14:B17,"<=31.12.2010")

Tæller antallet af celler i områder B14:B17, der ligger mellem (begge inklusive) 01.01.2010 og 31.12.2010 (3).

=SUMPRODUKT((B14:B17>=DATOVÆRDI("01.01.2010"))*(B14:B17<=DATOVÆRDI("31.12.2010")))

Tæller antallet af celler i området B14:B17, der ligger mellem (begge inklusive) 01.01.2010 og 31.12.2010 (3). Dette eksempel fungerer som en erstatning for funktionen TÆL:HVIS, der blev introduceret i Excel 2007. Funktionen DATOVÆRDI konverterer datoerne til en numerisk værdi, som derefter kan bruges i funktionen SUMPRODUKT.

Bemærk: Ansvarsfraskrivelse for maskinoversættelse: Denne artikel er blevet oversat af et computersystem uden menneskelig indgriben. Microsoft tilbyder disse maskinoversættelse for at hjælpe ikke-engelsktalende brugere til at kunne nyde indhold om Microsofts produkter, tjenester og teknologier. Da artiklen er maskinoversat, kan den indeholde forkerte ord eller syntaks- eller grammatikfejl.

Udvid dine færdigheder
Gå på opdagelse i kurser
Få nye funktioner først
Bliv Office Insider

Var disse oplysninger nyttige?

Tak for din feedback!

Tak for din feedback! Det lyder, som om det vil kunne hjælpe, hvis du bliver sat i forbindelse med en af vores Office-supportteknikere.

×