Tælle, hvor ofte en værdi forekommer i Excel

Vigtigt: Denne artikel er maskinoversat. Se ansvarsfraskrivelsen. Du kan finde den engelske version af denne artikel her til din orientering.

Antag, at du vil finde ud af, hvor mange gange en bestemt tekst eller en talværdi forekommer i en række celler. Eksempel:

  • Hvis et område, f.eks. A2:D20, indeholder tallene 5, 6, 7 og 6, forekommer tallet 6 to gange.

  • Hvis en kolonne indeholder "Henriksen", "Sørensen", "Sørensen" og "Sørensen", forekommer "Sørensen" tre gange.

Hvor mange gange en værdi forekommer, kan tælles på flere forskellige måder.

Hvad vil du foretage dig?

Tælle, hvor ofte en enkelt værdi forekommer, ved hjælp af en funktion

Tælling, der er baseret på flere kriterier, ved brug af funktionen TÆL.HVISER

Tælle baseret på flere kriterier, ved brug af funktionen TÆL og HVIS sammen

Tælle, hvor ofte flere tekst- eller talværdier forekommer ved at bruge funktionerne SUM og HVIS sammen

Tælle, hvor ofte flere værdier forekommer, ved hjælp af en pivottabel

Tælle, hvor ofte en enkelt værdi forekommer, ved hjælp af en funktion

Brug funktionen TÆL.HVIS til at udføre denne opgave.

Eksempel

Kopiér eksempeldataene i følgende tabel, og sæt dem ind i celle A1 i et nyt Excel-regneark. For at få formlerne til at vise resultater skal du markere dem, trykke på F2 og derefter trykke på Enter. Juster bredden på kolonnerne efter behov, så du kan se alle dataene.

Sælger

Faktura

Henriksen

15.000

Henriksen

9.000

Nielsen

8.000

Nielsen

20.000

Henriksen

5.000

Sørensen

22.500

Formel

Beskrivelse

Resultat

=TÆL.HVIS(A2:A7;"Henriksen")

Antal elementer for Henriksen (3)

=TÆL.HVIS(A2:A7;"Henriksen")

=TÆL.HVIS(A2:A7;A4)

Antal elementer for Nielsen (2)

=TÆL.HVIS(A2:A7;A4)

'=TÆL.HVIS(B2:B7,"< 20000")

Antal fakturabeløb, der er mindre end 20.000 (4)

=TÆL.HVIS(B2:B7;"< 20000")

'=TÆL.HVIS(B2:B7,">="&B5)

Antal fakturabeløb, der er større end eller lig med 20.000 (2)

=TÆL.HVIS(B2:B7;">="&B5)

Du kan få mere at vide om at bruge denne funktion ved at se Funktionen TÆL.HVIS.

Toppen af siden

Tælling, der er baseret på flere kriterier, ved brug af funktionen TÆL.HVISER

Funktionen TÆL.HVISER, som blev introduceret i Excel 2007, svarer lidt til funktionen TÆL.HVIS med en vigtig undtagelse: TÆL.HVISER gør det muligt at anvende kriterier på celler på tværs af flere områder og tæller antallet af gange, at alle kriterier er opfyldt. Du kan bruge op til 127 område-/kriteriepar sammen med funktionen TÆL.HVISER. Syntaksen for funktionen ser ud som følger:

TÆL.HVISER(kriterieområde1, kriterium1, [kriterieområde2, kriterium2],…)

Eksempel

Medarbejder-id

Områdenr.

Afdeling

20552

2

Salg

21268

2

Økonomi

23949

1

Administrator

24522

4

Administrator

28010

3

It

29546

4

Salg

31634

3

It

32131

1

It

35106

4

Økonomi

40499

1

HR

42051

1

Salg

43068

2

HR

45382

2

Økonomi

47971

1

It

Hvor mange medarbejdere er der i område 2 og i økonomiafdelingen?

'=TÆL.HVISER(B2:B15,"2",C2:C15,"Økonomi")

=TÆL.HVISER(B2:B15,"2",C2:C15,"Økonomi")

Det første kriterieområde er områdenumrene, og det andet kriterieområde er afdelingsnavnet. De kriterier, der er anvendt til det første kriterieområde, er "2", og de kriterier, der ar anvendt til det andet område, er "Økonomi". TÆL.HVISER kontrollerer, om begge kriterier er opfyldt.

Du kan få mere at vide om at bruge denne funktion til at tælle med flere områder og kriterier ved at se funktionen TÆL.HVISER.

Toppen af siden

Tælling, der er baseret på flere kriterier, ved brug af funktionen TÆL og HVIS sammen

Antag, at du skal finde ud af, hvor mange sælgere der har solgt en bestemt ting i et bestemt område, eller at du vil vide, hvor mange salg over et givet beløb en given sælger har gennemført. Du kan bruge funktionerne HVIS og TÆL sammen. Det vil sige, at du først bruger funktionen HVIS til at teste en betingelse, og derefter, og kun hvis resultatet af funktionen HVIS er Sand, bruger du funktionen TÆL til at tælle celler.

Eksempler

Region

Sælger

Type

Salg

Syd

Henriksen

Drikkevarer

3571

Vest

Davolio

Mejeriprodukter

3338

Øst

Nielsen

Drikkevarer

5122

Nord

Nielsen

Mejeriprodukter

6239

Syd

Sørensen

Landbrugsprodukter

8677

Syd

Davolio

Kød

450

Syd

Davolio

Kød

7673

Øst

Nielsen

Landbrugsprodukter

664

Nord

Davolio

Landbrugsprodukter

1500

Syd

Sørensen

Kød

6596

Formel

Beskrivelse

Resultat

=TÆL(HVIS((A2:A11="Syd")*(C2:C11="Kød");D2:D11))

Tal for salg af kød i område Syd. (3)

=TÆL(HVIS((A2:A11="Syd")*(C2:C11="Kød");D2:D11))

=TÆL(HVIS((B2:B11="Nielsen")*(D2:D11>=1000);D2:D11))

Antal salg over $ 1.000 af Nielsen. (2)

=TÆL(HVIS((B2:B11="Nielsen")*(D2:D11>=1000);D2:D11))

Bemærk: 

  • Formlerne i dette eksempel skal angives som matrixformler. Hvis du har åbnet denne projektmappe i Excel-skrivebordsprogrammet og vil ændre formlen eller oprette en lignende formel, skal du trykke på F2 og derefter trykke på Ctrl+Skift+Enter for at få formlen til at returnere de forventede resultater.

  • Hvis disse formler skal fungere, skal det andet argument til funktionen HVIS være et tal.

Funktionen TÆL tæller det antal celler, der indeholder tal, samt tal på dens liste over argumenter. Funktionen HVIS returnerer én værdi, hvis en betingelse, som du angiver, evalueres til SAND, og til en anden værdi, hvis den pågældende betingelse evalueres til FALSK

Du kan få mere at vide om disse funktioner ved at se Funktionen TÆL og Funktionen HVIS.

Toppen af siden

Tælle, hvor ofte flere tekst- eller talværdier forekommer ved at bruge funktionerne SUM og HVIS sammen

I de følgende eksempler bruges funktionerne HVIS og SUM sammen. Funktionen HVIS tester først værdierne i nogle celler, og derefter, hvis resultatet af testen er Sand, opsummerer SUM de værdier, der består testen.

Eksempler

Sælger

Faktura

Henriksen

15000

Henriksen

9000

Nielsen

8000

Nielsen

20000

Henriksen

5000

Sørensen

22500

Formel

Beskrivelse

Resultat

=SUM(HVIS((A2:A7="Henriksen")+(A2:A7="Sørensen");1;0))

Antal fakturaer for Henriksen og Sørensen.

=SUM(HVIS((A2:A7="Henriksen")+(A2:A7="Sørensen");1;0))

=SUM(HVIS((B2:B7<9000)+(B2:B7>19000);1;0))

Antal fakturaer med værdier, der er mindre end $ 9.000 eller større end $ 19.000.

=SUM(HVIS((B2:B7<9000)+(B2:B7>19000);1;0))

=SUM(HVIS(A2:A7="Henriksen";HVIS(B2:B7<9000;1;0)))

Antal fakturaer for Henriksen med en værdi, der er mindre end $ 9.000.

=SUM(HVIS(A2:A7="Henriksen";HVIS(B2:B7<9000;1;0)))

Bemærk: Formlerne i dette eksempel skal angives som matrixformler. Hvis du har åbnet denne projektmappe i Excel-skrivebordsprogrammet og vil ændre formlen eller oprette en lignende formel, skal du trykke på F2 og derefter trykke på Ctrl+Skift+Enter for at få formlen til at returnere de forventede resultater.

Toppen af siden

Tælle, hvor ofte flere værdier forekommer, ved hjælp af en pivottabel

Du kan bruge en pivottabel til at vise totaler og tælle forekomster af unikke værdier. En pivottabel er en interaktiv tabel, som hurtigt kan opsummere et stort antal data. Du kan bruge en pivottabel til at udvide og skjule niveauer af data for at fokusere på dine resultater og indskrænke detaljeringsniveauet ud fra opsummeringsdataene for områder, der særligt interesserer dig. Desuden kan du flytte rækker til kolonner eller kolonner til rækker (kaldes "pivotering") for at få vist forskellige opsummeringer af kildedataene.

Eksempel på kildedata og den deraf følgende pivottabel

1   Kildedata – i dette tilfælde fra et regneark

2   Kildeværdierne for opsummeringen af 3. kvartals salg af golfudstyr i pivottabellen

3   Hele pivottabellen

4   Opsummeringen af kildeværdierne i C2 og C8 fra kildedataene

Sådan opretter du en pivottabel

  1. Markér den kolonne, der indeholder dataene.
    Kontrollér, at kolonnen har en kolonneoverskrift.

  2. På fanen Indsæt i gruppen Tabeller skal du klikke på Pivottabel.
    Dialogboksen Opret pivottabel vises.

  3. Klik på Vælg en tabel eller et område.

  4. Klik på Nyt regneark, hvis du vil placere pivottabellen i et nyt regneark med start i celle A1.

  5. Klik på OK.
    Der tilføjes en tom pivottabel på den angivne placering, og pivottabelfeltlisten vises.

  6. Klik på et feltnavn i sektionen med felter øverst i pivottabelfeltlisten, hold museknappen nede, og træk feltet til feltet Rækkenavne i layoutsektionen nederst på pivottabelfeltlisten.

  7. Klik på det samme feltnavn i sektionen med felter øverst på pivottabelfeltlisten, hold museknappen nede, og træk feltet til feltet Værdier i layoutsektionen nederst i pivottabelfeltlisten.

Bemærk: Hvis dataene indeholder tal, lægger pivottabellen indtastningerne sammen i stedet for at tælle dem. Hvis du vil ændre sumfunktionen Sum til sumfunktionen Tæl, skal du gøre følgende: Markér en celle i kolonnen, klik på fanen Analysér i gruppen Aktivt felt, klik på Feltindstillinger, klik på fanen Summér med, klik på Antal, og klik på OK.

Toppen af siden

Bemærk: Ansvarsfraskrivelse for maskinoversættelse: Denne artikel er blevet oversat af et computersystem uden menneskelig indgriben. Microsoft tilbyder disse maskinoversættelse for at hjælpe ikke-engelsktalende brugere til at kunne nyde indhold om Microsofts produkter, tjenester og teknologier. Da artiklen er maskinoversat, kan den indeholde forkerte ord eller syntaks- eller grammatikfejl.

Udvid dine færdigheder
Gå på opdagelse i kurser
Få nye funktioner først
Bliv Office Insider

Var disse oplysninger nyttige?

Tak for din feedback!

Tak for din feedback! Det lyder, som om det vil kunne hjælpe, hvis du bliver sat i forbindelse med en af vores Office-supportteknikere.

×