Slå værdier op ved hjælp af LOPSLAG, INDEKS OG SAMMENLIGN

Hvis du vil finde en værdi i en stor liste, kan du bruge en opslagsfunktion. Funktionen LOPSLAG anvendes vidt og bredt, men funktionen VOPSLAG sammen med funktionerne INDEKS og SAMMENLIGN kan også fungere for dig.

Her er lidt nyttige oplysninger om LOPSLAG og de argumenter, det anvender:

=LOPSLAG(<søgeværdi>,<opslagsområde>,<kolonne>,<Omtrentligt match>)

Eksempel: =LOPSLAG(21500;C2:E7;3;FALSK)

  • Det første argument – et datastykke, som funktionen skal bruge for at fungere – er den værdi, du vil søge efter. Det kan være en cellereference som f.eks. B2 eller en værdi som f.eks. "jensen" eller 21500.

  • Det andet argument er det celleområde, du tror indeholder den værdi, du ønsker at finde.

    Vigtigt: Med LOPSLAG, skal den kolonne, der indeholder den værdi eller cellereference, du søger efter, være kolonnen længst til venstre i området.

  • Det tredje argument er den kolonne i celleområdet, der indeholder den værdi, du vil have vist.

Selvom det fjerde argument er valgfrit, skriver de fleste personer FALSK (eller 0). Hvorfor? Fordi det tvinger funktionen til at finde et nøjagtigt match til søgningen. Du kan undlade at angive et argument, eller du kan angive SAND. Hvis der ikke findes et nøjagtigt match, returnerer funktionen dog det nærmesteomtrentlige match – og ofte har man ikke noget at bruge et sådant unøjagtigt match til.

Et eksempel på, hvordan et unøjagtigt match kan være et problem, kunne være, hvis vi forestiller os, at du leder efter prisen på en vare med varenummeret 2345768, men du bytter om på to tal og skriver det i formlen på følgende måde: =LOPSLAG(2345678;A1:E7;5). Formlen returnerer prisen på den forkerte del, fordi LOPSLAG finder de nærmeste tal, som er mindre end eller lig med det tal, du angav (2345678). Du kan ende med at fakturere en kunde forkert pga. denne fejl.

Hvis du angiver FALSK eller 0 for argumentet Omtrentligt match, og der ikke er noget nøjagtigt match, returnerer formlen #I/T i cellen i stedet for den forkerte værdi – et meget bedre scenarie. I dette tilfælde, betyder #I/T ikke, at du har angivet din formel forkert (med undtagelse af det forkert angivne tal); det betyder, at 2345678 ikke blev fundet – og du ønskede 2345768.

Dette eksempel viser, hvordan funktionen virker. Når du skriver en værdi i celle B2 (det første argument), søger LOPSLAG i cellerne C2:E7 (det andet argument) og returnerer det nærmeste match fra den tredje kolonne i området, kolonne E (det tredje argument).

En typisk anvendelse af funktionen LOPSLAG

I dette eksempel står det fjerde argument tomt, så funktionen returnerer et omtrentligt match.

Brug af funktionen VOPSLAG

Når du er blevet fortrolig med funktionen LOPSLAG, er det også nemt nok at bruge funktionen VOPSLAG. Du skriver de samme argumenter, men VOPSLAG finder værdier i rækker i stedet for kolonner.

Brug af INDEKS sammen med SAMMENLIGN

Hvis du ikke vil begrænse søgningen til kolonnen længst til venstre, kan du bruge en kombination af funktionerne INDEKS og SAMMENLIGN. En formel, der bruger disse sammen, er lidt mere kompleks end en formel med funktionen LOPSLAG, men den kan være mere effektiv – og der er nogle, der sværger til at bruge kombinationen af INDEKS/SAMMENLIGN frem for LOPSLAG.

I dette eksempel vises en lille liste, hvor den værdi, vi vil søge på, Chicago, ikke findes i kolonnen længst til venstre. Derfor kan vi ikke bruge LOPSLAG. I stedet bruger vi funktionen SAMMENLIGN til at finde Chicago i området B1:B11. Den blev fundet i række 4. Derefter anvendes denne værdi af INDEKS som opslagsargument, og Chicagos indbyggertal findes i den fjerde kolonne (kolonne D). Den anvendte formel vises i celle A14.

Brug af INDEKS og SAMMENLIGN til at slå en værdi op

Mere om opslagsfunktioner

Toppen af siden

Udvid dine færdigheder
Gå på opdagelse i kurser
Få nye funktioner først
Bliv Office Insider

Var disse oplysninger nyttige?

Tak for din feedback!

Tak for din feedback! Det lyder, som om det vil kunne hjælpe, hvis du bliver sat i forbindelse med en af vores Office-supportteknikere.

×