Slå værdier op ved hjælp af LOPSLAG, INDEKS OG SAMMENLIGN

Bemærk!:  Vi vil gerne give dig den mest opdaterede hjælp, så hurtigt vi kan, på dit eget sprog. Denne side er oversat ved hjælp af automatisering og kan indeholde grammatiske fejl og unøjagtigheder. Det er vores hensigt, at dette indhold skal være nyttigt for dig. Vil du fortælle os, om oplysningerne var nyttige for dig, nederst på denne side? Her er artiklen på engelsk så du kan sammenligne.

Antag, at du har en liste over kontornumre placering, og du bør vide, hvilke medarbejdere er i de enkelte office. Regnearket er stort, så du kan synes, det svært opgave. Det er faktisk ret nemt at gøre med en opslagsfunktion.

Funktionerne LOPSLAG og VOPSLAG sammen med indeks og Sammenlign,er nogle af de mest nyttige funktioner i Excel.

Bemærk!: Funktionen guiden Opslag er ikke længere tilgængelig i Excel.

Her er et eksempel på, hvordan du bruger LOPSLAG.

=LOPSLAG(B2,C2:E7,3,SAND)

I dette eksempel B2 er det første argument– et element med data, som funktionen skal arbejde. For LOPSLAG er dette første argument den værdi, du vil finde. Dette argument kan være en cellereference eller en fast værdi som "Sørensen" eller 21.000. Det andet argument er det område af celler, C2-:E7, hvor du kan søge efter den værdi, du vil finde. Det tredje argument er kolonnen i området af celler, der indeholder den værdi, som du søge efter.

Det fjerde argument er valgfrit. Skriv enten SAND eller FALSK. Hvis du angiver TRUE eller lade argumentet være tomt, returnerer funktionen en tilnærmet værdi af den værdi, du angiver i det første argument. Hvis du angiver FALSE, funktionen matcher værdien, der giver ved det første argument. Det vil sige, så det fjerde argument tomt – eller ved at indtaste TRUE – giver dig større fleksibilitet.

I dette eksempel vises, hvordan funktionen virker. Når du angiver en værdi i celle B2 (det første argument), LOPSLAG søger cellerne i området C2:E7 (2. argument) og returnerer den nærmeste omtrentlig værdi fra den tredje kolonne i området, kolonne E (3 argument).

En typisk anvendelse af funktionen LOPSLAG

Det fjerde argument er tomt, så funktionen returnerer et Omtrentligt match. Hvis det ikke, vil du have til at angive en af værdierne i kolonne C eller D for at få et resultat på alle.

Når du er tryg ved LOPSLAG, er funktionen VOPSLAG lige så nem at bruge. Du angive de samme argumenter, men der søges i rækker i stedet for kolonner. "

Prøv det

Hvis du vil eksperimentere med opslagsfunktioner, før du bruger dem med dine egne data, er her nogle eksempeldata. Nogle Excel brugere som ved hjælp af LOPSLAG og VOPSLAG; andre foretrækker at bruge indeks og Sammenlign sammen. Prøv hver enkelt metode, og se, hvilke af dem du bedst kan lide.

Eksempel på LOPSLAG i brug

Kopiere følgende data til et tomt regneark.

TIP:    Før du indsætter dataene i Excel, angive kolonnebredderne for kolonnerne A til og med C til 250 pixel og klikke på Ombryd tekst (fanenStartside, gruppen Justering ).

Tæthed

Viskositet

Temperatur

0,457

3,55

500

0,525

3,25

400

0,606

2,93

300

0,675

2,75

250

0,746

2,57

200

0,835

2,38

150

0,946

2,17

100

1,09

1,95

50

1,29

1,71

0

Formel

Beskrivelse

Resultat

=LOPSLAG(1;A2:C10;2)

Søger efter den omtrentlige værdi 1 i kolonne A, finder den største værdi, der er mindre end eller lig med 1 i kolonne A, som er 0,946, og returnerer derefter værdien fra kolonne B i samme række.

2,17

=LOPSLAG(1;A2:C10;3;SAND)

Søger efter den omtrentlige værdi 1 i kolonne A, finder den største værdi, der er mindre end eller lig med 1 i kolonne A, som er 0,946, og returnerer derefter værdien fra kolonne C i samme række.

100

=LOPSLAG(0,7;A2:C10;3;FALSK)

Søger efter den præcise værdi 0,7 i kolonne A. Da der ikke findes en tilsvarende værdi i kolonne A, returneres en fejl.

#I/T

=LOPSLAG(0,1;A2:C10;2;SAND)

Søger efter den præcise værdi 0,1 i kolonne A. Da 0,1 er mindre end den mindste værdi i kolonne A, returneres en fejl.

#I/T

=LOPSLAG(2;A2:C10;2;SAND)

Søger efter den omtrentlige værdi 2 i kolonne A, finder den største værdi, der er mindre end eller lig med 2 i kolonne A, som er 1,29, og returnerer derefter værdien fra kolonne B i samme række.

1,71

Eksempel på VOPSLAG

Kopiér alle cellerne i denne tabel, og indsæt det kopierede i celle A1 i et tomt regneark i Excel.

TIP:    Før du indsætter dataene i Excel, angive kolonnebredderne for kolonnerne A til og med C til 250 pixel og klikke på Ombryd tekst (fanenStartside, gruppen Justering ).

Aksler

Lejer

Bolte

4

4

9

5

7

10

6

8

11

Formel

Beskrivelse

Resultat

=VOPSLAG("Aksler";A1:C4; 2; SAND)

Søger efter "Aksler" i række 1 og returnerer den værdi fra række 2, der er i den samme kolonne (kolonne A).

4

=VOPSLAG("Lejer";A1:C4; 3; FALSK)

Søger efter "Lejer" i række 1 og returnerer den værdi fra række 3, der er i den samme kolonne (kolonne B).

7

=VOPSLAG(";B";A1:C4;3;SAND)

Søger efter "B" i række 1 og returnerer den værdi fra række 3, der er i den samme kolonne. Fordi der ikke blev fundet en nøjagtig match for "B", bruges den største værdi i række 1, der er mindre end "B": "Aksler" i kolonne A.

5

=VOPSLAG("Bolte";A1:C4;4)

Søger efter "Bolte" i række 1 og returnerer den værdi fra række 4, der er i den samme kolonne (kolonne C).

11

=VOPSLAG(3; {1;2;3;"a";"b";"c";"d";"e";"f"}; 2; SAND)

Søger efter tallet 3 i matrixkonstanten med tre rækker og returnerer værdien fra række 2 i den samme (i dette tilfælde den tredje) kolonne. Der findes tre rækker af værdier i matrixkonstanten, og rækkerne er adskilt med semikolon (;). Fordi "c" findes i række 2 og i den samme kolonne som 3, returneres "c".

c

INDEKS og Sammenlign eksempler

I denne sidste eksempel anvender funktionerne indeks og Sammenlign sammen til at returnere nummeret på den tidligste faktura og dens tilsvarende dato for hver af de fem byer. Da datoen, returneres som et tal, bruge vi funktionen tekst til at formatere den som en dato. Funktionen indeks bruger faktisk resultatet af funktionen Sammenlign som argument. Kombination af funktionerne indeks og Sammenlign er bruges to gange i hver formel – først, til at returnere nummeret på den faktura, og gå derefter til at returnere datoen.

Kopiér alle cellerne i denne tabel, og indsæt det kopierede i celle A1 i et tomt regneark i Excel.

TIP:    Før du indsætter dataene i Excel, angive kolonnebredderne for kolonnerne A til og med D til 250 pixel og klikke på Ombryd tekst (fanenStartside, gruppen Justering ).

Faktura

By

Fakturadato

Tidligste faktura efter by med dato

med 3115

Atlanta

07-04-2012

="Atlanta = "&INDEKS($A$2:$C$33;SAMMENLIGN("Atlanta";$B$2:$B$33;0);1)& "; Fakturadato: " & TEKST(INDEKS($A$2:$C$33;SAMMENLIGN("Atlanta";$B$2:$B$33;0);3);"d/m/åå")

3137

Atlanta

09-04-2012

="Austin= "&INDEKS($A$2:$C$33;SAMMENLIGN("Austin";$B$2:$B$33;0);1)& "; Fakturadato: " & TEKST(INDEKS($A$2:$C$33;SAMMENLIGN("Austin";$B$2:$B$33;0);3);"d/m/åå")

3154

Atlanta

11-04-2012

="Dallas= "&INDEKS($A$2:$C$33;SAMMENLIGN("Dallas";$B$2:$B$33;0);1)& "; Fakturadato: " & TEKST(INDEKS($A$2:$C$33;SAMMENLIGN("Dallas";$B$2:$B$33;0);3);"d/m/åå")

3191

Atlanta

21-04-2012

="New Orleans = "&INDEKS($A$2:$C$33;SAMMENLIGN("New Orleans";$B$2:$B$33;0);1)& "; Fakturadato: " & TEKST(INDEKS($A$2:$C$33;SAMMENLIGN("New Orleans";$B$2:$B$33;0);3);"d/m/åå")

3293

Atlanta

25-04-2012

="Tampa = "&INDEKS($A$2:$C$33;SAMMENLIGN("Tampa";$B$2:$B$33;0);1)& "; Fakturadato: " & TEKST(INDEKS($A$2:$C$33;SAMMENLIGN("Tampa";$B$2:$B$33;0);3);"d/m/åå")

3331

Atlanta

27-04-2012

3350

Atlanta

28-04-2012

3390

Atlanta

01-05-2012

3441

Atlanta

02-05-2012

3517

Atlanta

08-05-2012

3124

Austin

09-04-2012

3155

Austin

11-04-2012

3177

Austin

19-04-2012

3357

Austin

28-04-2012

3492

Austin

06-05-2012

3316

Dallas

25-04-2012

3346

Dallas

28-04-2012

3372

Dallas

01-05-2012

3414

Dallas

01-05-2012

3451

Dallas

02-05-2012

3467

Dallas

02-05-2012

3474

Dallas

04-05-2012

3490

Dallas

05-05-2012

3503

Dallas

08-05-2012

3151

New Orleans

09-04-2012

3438

New Orleans

02-05-2012

3471

New Orleans

04-05-2012

3160

Tampa

18-04-2012

3328

Tampa

26-04-2012

3368

Tampa

29-04-2012

3420

Tampa

01-05-2012

3501

Tampa

06-05-2012

Få mere at vide mere om opslagsfunktioner

Udvid dine Office-færdigheder
Gå på opdagelse i kurser
Få nye funktioner først
Bliv Office Insider

Var disse oplysninger nyttige?

Tak for din feedback!

Tak for din feedback! Det lyder, som om det vil kunne hjælpe, hvis du bliver sat i forbindelse med en af vores Office-supportteknikere.

×