SUMPRODUKT, funktionen

Vigtigt: Denne artikel er maskinoversat. Se ansvarsfraskrivelsen. Du kan finde den engelske version af denne artikel her til din orientering.

I denne artikel beskrives formelsyntaksen for og brugen af funktionen SUMPRODUKT i Microsoft Excel.

Beskrivelse

Ganger ens komponenter i de givne matrixer og returnerer summen af disse produkter.

Syntaks

SUMPRODUKT(matrix1;[matrix2];[matrix3];...)

Syntaksen for funktionen SUMPRODUKT har følgende argumenter:

  • Matrix1     Påkrævet. Det første matrixargument, hvis komponenter du vil multiplicere og derefter addere.

  • Matrix2; matrix3; ...     Valgfrit. Matrixargumenterne 2-55, hvis komponenter du vil multiplicere og derefter addere.

Bemærkninger

  • Matrixargumenterne skal have samme dimensioner. Hvis det ikke er tilfældet, returnerer SUMPRODUKT fejlværdien #VÆRDI!.

  • SUMPRODUKT fortolker matrixindtastninger, der er ikke-numeriske, som nuller.

Eksempel

Kopiér eksempeldataene i følgende tabel, og sæt dem ind i celle A1 i et nyt Excel-regneark. For at få formlerne til at vise resultater skal du markere dem, trykke på F2 og derefter trykke på Enter. Hvis der er brug for det, kan du justere bredden på kolonnerne, så du kan se alle dataene.

Matrix 1

Matrix 2

3

4

2

7

8

6

6

7

1

9

5

3

Formel

Beskrivelse

Resultat

=SUMPRODUKT(A2:B4; D2:E4)

Ganger alle komponenterne i de to matrixer og lægger derefter produkterne sammen, dvs. 3*2 + 4*7 + 8*6 + 6*7 + 1*5 + 9*3. (156)

156

Bemærk: Ansvarsfraskrivelse for maskinoversættelse: Denne artikel er blevet oversat af et computersystem uden menneskelig indgriben. Microsoft tilbyder disse maskinoversættelse for at hjælpe ikke-engelsktalende brugere til at kunne nyde indhold om Microsofts produkter, tjenester og teknologier. Da artiklen er maskinoversat, kan den indeholde forkerte ord eller syntaks- eller grammatikfejl.

Del Facebook Facebook Twitter Twitter Mail Mail

Var disse oplysninger nyttige?

Fantastisk! Har du mere feedback?

Hvordan kan vi forbedre det?

Tak for din feedback!

×