SUM.HVIS, funktionen

Du kan bruge funktionen SUM.HVIS til at summere værdierne i et område, der opfylder kriterier, du angiver. Antag f.eks, at du kun vil summere de værdier, der er større end 5, i en kolonne, der indeholder tal. Du kan bruge følgende formel: =SUM.HVIS(B2:B25,">5")

Din browser understøtter ikke video. Installer Microsoft Silverlight, Adobe Flash Player eller Internet Explorer 9.

Denne video er en del af et kursus med titlen Lægge tal sammen i Excel 2013.

Tip!: Hvis du vil, kan du anvende kriteriet på ét område og summere de tilhørende værdier i et andet område. Formlen = SUM.HVIS (B2: B5 "John", C2:C5) summerer f.eks. kun de værdier i området C2:C5, hvor de tilsvarende celler i området B2:B5 er lig med "John".

Hvis du vil sammentælle celler på basis af flere kriterier, skal du se Funktionen SUM.HVISER.

Syntaks

SUM.HVIS(område, kriterium, [sumområde])

Syntaksen for funktionen SUM.HVIS har følgende argumenter:

  • område   Påkrævet. Det område af celler, der skal evalueres af kriterier. Cellerne i hvert område skal være tal eller navne, matrixer eller referencer, der indeholder tal. Tomme værdier og tekstværdier ignoreres. Det valgte område kan indeholde datoer i Excels standardformat (eksempler nedenfor).

  • kriterier    Påkrævet. Kriterier i form af et tal, et udtryk, en cellereference, tekst eller en funktion, der definerer, hvilke celler der skal tilføjes. F.eks. kan kriterier udtrykkes som 32, ">32", B5, "32", "æbler" eller IDAG().

    Vigtigt: Alle tekstkriterier eller alle kriterier, som indeholder logiske eller matematiske symboler, skal være omsluttet af dobbelte anførselstegn ("). Hvis kriterierne er numeriske, er dobbelte anførselstegn ikke påkrævet.

  • sumområde    Valgfrit. De faktiske celler, der skal tilføjes, hvis du vil tilføje andre celler end dem, der er angivet i argumentet område . Hvis argumentet sumområde er udeladt, tilføjer Excel de celler, der er angivet i argumentet område (de samme celler, som kriteriet er anvendt på).

  • Du kan bruge jokertegnene – spørgsmålstegn (?) og stjerne (*) – som argumentet kriterier. Et spørgsmålstegn svarer til alle enkelttegn, en stjerne svarer til enhver sekvens af tegn. Hvis du ønsker at søge efter et reelt spørgsmålstegn eller en stjerne, skal du skrive en tilde (~) foran tegnet.

Bemærkninger

  • Funktionen SUM.HVIS returnerer forkerte resultater, når du bruger den til at matche strenge på mere end 255 tegn eller med strengen #VÆRDI!.

  • Argumentet sumområde behøver ikke at have den samme størrelse og form som argumentet område. De faktiske celler, der tilføjes, bestemmes ved hjælp af cellen øverst og yderst til venstre i argumentet sum_område som begyndelsescellen, og medtager derefter celler, der svarer i størrelse og form til argumentet område. Eksempel:

Hvis område er

Og sumområde er

Så er de faktiske celler

A1:A5

B1:B5

B1:B5

A1:A5

B1:B3

B1:B5

A1:B4

C1:D4

C1:D4

A1:B4

C1:C2

C1:D4

Når argumenterne område og sumområde i funktionen SUM.HVIS ikke indeholder det samme antal celler, kan beregninger i regnearket tage længere tid end forventet.

Eksempler

Eksempel 1

Kopiér eksempeldataene i følgende tabel, og sæt dem ind i celle A1 i et nyt Excel-regneark. For at få formlerne til at vise resultater skal du markere dem, trykke på F2 og derefter trykke på Enter. Hvis der er brug for det, kan du justere bredden på kolonnerne, så du kan se alle dataene.

Egenskabsværdi

Provision

Data

DKK 100.000,00

DKK 7.000,00

DKK 250.000,00

DKK 200.000,00

DKK 14.000,00

DKK 300.000,00

DKK 21.000,00

DKK 400.000,00

DKK 28.000,00

Formel

Beskrivelse

Resultat

=SUM.HVIS(A2:A5;">160000";B2:B5)

Summen af provisioner for egenskabsværdier over 160.000

DKK 63.000,00

=SUM.HVIS(A2:A5;">160000")

Summen af egenskabsværdier over 160.000.

DKK 900.000,00

=SUM.HVIS(A2:A5,300000,B2:B5)

Summen af provisioner for egenskabsværdier lig med 300.000

DKK 21.000,00

=SUM.HVIS(A2:A5;">" & C2,B2:B5)

Summen af provisioner for egenskabsværdier større end værdien i C2.

DKK 49.000,00

Eksempel 2

Kopiér eksempeldataene i følgende tabel, og sæt dem ind i celle A1 i et nyt Excel-regneark. For at få formlerne til at vise resultater skal du markere dem, trykke på F2 og derefter trykke på Enter. Hvis der er brug for det, kan du justere bredden på kolonnerne, så du kan se alle dataene.

Kategori

Fødevarer

Salg

Grøntsager

Tomater

DKK 2.300,00

Grøntsager

Selleri

DKK 5.500,00

Frugt

Appelsiner

DKK 800,00

Smør

DKK 400,00

Grøntsager

Gulerødder

DKK 4.200,00

Frugt

æbler

DKK 1.200,00

Formel

Beskrivelse

Resultat

=SUM.HVIS(A2:A7,"Frugt",C2:C7)

Summen af salget af alle fødevarer i kategorien "Frugt".

DKK 2.000,00

=SUM.HVIS(A2:A7,"Grøntsager",C2:C7)

Summen af salget af alle fødevarer i kategorien "Grøntsager".

DKK 12.000,00

=SUM.HVIS(B2:B7,"*er",C2:C7)

Summen af salget af alle fødevarer, der slutter med "er" (tomater, appelsiner og æbler).

DKK 4.300,00

=SUM.HVIS(A2:A7,"",C2:C7)

Summen af salget af alle fødevarer, der ikke har en kategori angivet.

DKK 400,00

Toppen af siden

Har du et bestemt spørgsmål til en funktion?

Stil et spørgsmål i Excel-communityforummet

Hjælp os med at forbedre Excel

Har du forslag til, hvordan vi kan forbedre den næste version af Excel? Hvis det er tilfældet, skal du gå til emner i Excel User Voice.

Se også

Funktionen SUM.HVIS tilføjer kun værdier, der opfylder et enkelt kriterium

Funktionen SUMKV summerer flere værdier, efter at have udført en matematisk kvadratfunktion på hver af dem

Funktionen TÆL.HVIS tæller kun de værdier, der opfylder et enkelt kriterium

Funktionen TÆL.HVISER tæller kun de værdier, der opfylder flere kriterier

Funktionen HVIS.ER (Office 365, Excel 2016 og nyere)

Oversigt over formler i Excel

Sådan undgår du ødelagte formler

Brug fejlkontrol til at registrere fejl i formler

Matematiske og trigonometriske funktioner

Excel-funktioner (alfabetisk)

Excel-funktioner (efter kategori)

Del Facebook Facebook Twitter Twitter Mail Mail

Var disse oplysninger nyttige?

Fantastisk! Har du mere feedback?

Hvordan kan vi forbedre det?

Tak for din feedback!

×