Sådan retter du fejlen #VÆRDI! fejl i funktionen sammenkædning

Vigtigt!: I Excel 2016, Excel Mobileog Excel til internetteter sammenkædning blevet tilsidesat af funktionen sammenkædning. Selvom funktionen SAMMENKÆDE stadig er tilgængelig af hensyn til bagudkompatibilitet, bør du overveje at bruge SAMMENKÆDNING, da det er en mere robust funktion.

Et af de mest almindelige scenarier, hvor du støder på #VALUE! fejl med sammenkædning er, når du forsøger at oprette en streng, der indeholder en cellereference, der indeholder en fejl, såsom #VALUE!.

I følgende eksempel ønsker vi at sammenkæde D2, E2 og F2, hvor E2 har et #VALUE! fejl.

#VÆRDI! fejl i sammenkædning

Fejlen i E2 medfører, at funktionen viser #VALUE! fejl. Hvis det skal fungere korrekt, skal du erstatte fejlen med en anden værdi end fejlen. Du kan oprette en formel, der kontrollerer, om der er fejl i cellereferencen, og hvis den gør, kan du få vist den tekststreng, hvor der vises et 0 i stedet for fejlen (eller du kan erstatte din egen tekst for 0, men du skal ombryde teksten i anførselstegn – "din tekst").

En formel som denne ville fungere:

=HVIS(ER.FEJL(E2);SAMMENKÆDNING(D2;" ";0;" ";F2))

Hvis og fejl-funktioner, der bruges som en løsning til at sammenkæde en streng med #VALUE! fejl

Hvordan fungerer det? Funktionen HVIS bruger funktionen HVIS.FEJL til at afgøre, om der er en fejl i E2, og hvis det er tilfældet, kombinerer funktionen SAMMENKÆDE værdierne i D2, E2 og F2 (funktionen erstatter fejlen med et 0) og viser den resulterende tekststreng. Bemærk, at formlen også bruger mellemrum (" ") til at adskille værdierne.

Ret fejlen #VÆRDI! med SAMMENKÆDE i Excel 2003 og ældre versioner

Hvis du får fejlen #VÆRDI! i Office Excel 2003 eller ældre versioner, skal du fjerne markeringen af indstillingen Overgangsformelevaluering i Excel. Følg de trin, der er angivet i #VALUE! fejl ved sammenkædning af celler for at løse problemet.

Har du et bestemt spørgsmål til en funktion?

Stil et spørgsmål i Excel-communityforummet

Hjælp os med at forbedre Excel

Har du forslag til, hvordan vi kan forbedre den næste version af Excel? Hvis det er tilfældet, skal du gå til emner i Excel User Voice.

Læs også

Rette fejlen #VÆRDI! fejl

Funktionen SAMMENKÆDNING

Funktionen SAMMENKÆDNING

Oversigt over formler i Excel

Sådan undgår du ødelagte formler

Find fejl i formler

Alle Excel-funktioner (alfabetisk)

Alle Excel-funktioner (efter kategori)

Bemærk!:  Denne side er oversat ved hjælp af automatisering og kan indeholde grammatiske fejl og unøjagtigheder. Det er vores hensigt, at dette indhold skal være nyttigt for dig. Var disse oplysninger nyttige? Her er artiklen på engelsk, så du kan sammenligne.

Udvid dine Office-færdigheder
Gå på opdagelse i kurser
Få nye funktioner først
Bliv Office Insider

Var disse oplysninger nyttige?

Tak for din feedback!

Tak for din feedback! Det lyder, som om det vil kunne hjælpe, hvis du bliver sat i forbindelse med en af vores Office-supportteknikere.

×