Sådan retter du fejlen #REFERENCE!

Sådan retter du fejlen #REFERENCE!

Fejlen #REFERENCE! vises, når en formel refererer til en celle, der ikke er gyldig. Dette sker oftest, når celler, der er refereres til i formler, bliver slettet eller overskrevet.

Eksempel – fejlen #REFERENCE, som er forårsaget af at slette en kolonne

Det følgende eksempel anvender formlen =SUM(B2,C2,D2) i kolonne E.

En formel, der bruger eksplicitte cellereferencer såsom =SUM(B2,C2,D2) kan forårsage fejlen #REFERENCE, hvis en kolonne slettes.

Hvis du slettede kolonne B, C eller D, ville det medfører fejlen #REFERENCE!. I dette tilfælde vil vi slette kolonne C (2007 Salg), og formlen læser nu =SUM(B2,#REFERENCE!,C2). Når du bruger eksplicitte cellereferencer på denne måde (hvor du individuelt henviser til hver celle, adskilt af et komma) og sletter en refereret række eller kolonne, kan Excel ikke løse problemet, så den returnerer fejlen #REFERENCE!. Dette er den primære årsag til, hvorfor det ikke anbefales at bruge eksplicitte cellereferencer i funktioner.

Eksempel på fejlen #REFERENCE, der er opstået ved at slette en kolonne.

Løsning

  • Hvis du ved et uheld sletter rækker eller kolonner, kan du straks klikke på knappen Fortryd på Værktøjslinjen Hurtig adgang (eller trykke på CTRL+Z) for at gendanne dem.

  • Justér formlen, så den bruger et områdereference i stedet for individuelle celler, såsom =SUM(B2:D2). Nu kan du slette enhver kolonne inden for området sum, og så vil Excel justere automatisk formlen. Du kan også bruge =SUM(B2:B5) til en sum af rækker.

Eksempel – VOPSLAG med forkerte områdereferencer

I det følgende eksempel =VOPSLAG(A8,A2:D5,5,FALSK) returnerer fejlen #REFERENCE!, fordi den leder efter en værdi til at returnere fra kolonne 5, men referenceområdet er A:D, som kun er 4 kolonner.

Eksempel på en LOPSLAG-formel med et forkert område.  Formlen er = LOPSLAG(A8,A2:D5,5,FALSK).  Der er ingen femte kolonne i området LOPSLAG, så 5 medfører fejlen #REFERENCE!.

Løsning

Justér området til at være større, eller reducer opslagsværdien for kolonnen for at matche referenceområdet. =VOPSLAG(A8,A2:E5,5,FALSK) ville være et gyldigt referenceområde, ligesom = VOPSLAG(A8,A2:D5,4,FALSK) også ville.

Eksempel – INDEKS med forkert række- eller kolonnereference

I dette eksempel returnerer formlen =INDEKS(B2:E5,5,5) fejlen #REFERENCE!, da indeksområdet er 4 rækker med 4 kolonner, men formlen beder om at returnere, hvad der er i kolonnen over 5. række og 5. kolonne.

Eksempel på en INDEKS-formel med en ugyldig områdereference.  Formlen er = INDEKS(B2:E5,5,5), men området er kun 4 rækker med 4 kolonner.

Løsning

Justér referencerne række eller kolonne, så de er inden for INDEKS-opslagsområde. =INDEKS(B2:E5,4,4) ville returnere et gyldigt resultat.

Eksempel – Referering af en lukket projektmappe med INDIREKTE

I følgende det eksempel forsøger en indirekte funktion at referere til en projektmappe, der er lukket, hvilket medfører fejlen #REFERENCE!.

Eksempel på fejlen #REFERENCE, der er opstået ved indirekte at henvise til en lukket projektmappe.

Løsning

Åbn den projektmappe, der henvises til

Problemer med OLE/DDE

Hvis du har brugt en Objektsammenkædning og indlejring (OLE), som returnerer fejlen #REFERENCE!, og start derefter det program, som linket efterspørger.

Bemærk: OLE er en teknologi, som du kan bruge til at dele oplysninger mellem programmer.

Hvis du har brugt et Dynamic Data Exchange (DDE)-emne, der returnerer fejlen #REFERENCE!, skal du kontrollere, at du refererer til det korrekte emne.

Bemærk: DDE er en etableret protokol til at udveksle data mellem Microsoft Windows-baserede programmer.

Makroproblemer

Hvis en makro indsætter en funktion i et regneark, der refererer til en celle oven over funktionen, og den celle, der indeholder funktionen, står i række 1, returnerer funktionen #REFERENCE!, fordi der ikke er nogen celler oven over række 1. Kontrollér funktionen for at få vist, om et argument refererer til en celle eller et celleområde, som ikke er gyldigt. Dette kræver muligvis, at du redigerer makroen i Visual Basic Editor (VBE) for at tage højde for denne situation.

Har du brug for mere hjælp?

Du kan altid spørge en ekspert i Excel Tech Community, få support i Answers community eller foreslå en ny funktion eller forbedring i Excel User Voice.

Se også

Oversigt over formler i Excel

Sådan undgår du ødelagte formler

Brug fejlkontrol til at registrere fejl i formler

Excel-funktioner (alfabetisk)

Excel-funktioner (efter kategori)

Udvid dine færdigheder
Gå på opdagelse i kurser
Få nye funktioner først
Bliv Office Insider

Var disse oplysninger nyttige?

Tak for din feedback!

Tak for din feedback! Det lyder, som om det vil kunne hjælpe, hvis du bliver sat i forbindelse med en af vores Office-supportteknikere.

×