Sådan retter du en #VÆRDI!-fejl i funktionen SUM.HVIS/SUM.HVISER

I dette emne beskrives de mest almindelige årsager til, at fejlen #VÆRDI! opstår i funktionerne SUM.HVIS og SUM.HVISER, og hvordan du kan rette dem.

Problem: Formlen henviser til celler i en lukket projektmappe

Hvis funktionerne SUM.HVIS/SUM.HVISER henviser til en celle eller et område i en lukket projektmappe, medfører det fejlen #VÆRDI!.

Bemærk: Dette er et kendt problem i flere andre Excel-funktioner som f.eks. TÆL.HVIS, TÆL.HVISER, ANTAL.BLANKE. Du kan få mere at vide i Funktionerne SUM.HVIS, TÆL.HVIS og ANTAL.BLANKE returnerer fejlen #VÆRDI!.

Løsning: Åbn projektmappen, der er angivet i formlen, og tryk på F9 for at opdatere formlen.

Du kan løse dette problem ved at bruge funktionerne SUM og HVIS sammen i en matrixformel. Du kan få mere at vide i artiklen Funktionerne SUM.HVIS, TÆL.HVIS og ANTAL.BLANKE returnerer fejlen #VÆRDI!.

Problem: Kriteriestrengen er på mere end 255 tegn

Funktionen SUM.HVIS/SUM.HVISER returnerer forkerte resultater, når du bruger den til at matche strenge på mere end 255 tegn.

Løsning: Afkort strengen, hvis det er muligt. Hvis du ikke kan forkorte strengen, skal du bruge funktionen SAMMENKÆDE eller og-tegnet (&) til at opdele værdi i flere strenge. For eksempel:

=SUM.HVIS(B2:B12,"lang streng"&"en anden lang streng")

Problem: I SUM.HVISER er argumentet kriterieområde ikke i overensstemmelse med argumentet sumområde.

Områdeargumenterne skal altid være ens i SUM.HVISER. Det betyder, at argumenterne kriterieområde og sumområde skal indeholde samme antal rækker og kolonner.

I følgende eksempel skal formlen returnere summen af det daglige salg for Æbler i Storeby. Argumentet sumområde (C2:C10) svarer dog ikke til det samme antal rækker og kolonner i argumenterne kriterieområde (A2:A12 & B2:B12). Hvis syntaksen =SUM.HVISER(C2:C10,A2:A12,A14,B2:B12,B14) bruges, medfører det fejlen #VÆRDI!.

Den forkerte formel er =SUM.HVIS(C2:C10,A2:A12,A14,B2:B12,B14), hvor C2:C10 skal være C2:C12
I funktionen SUM.HVISER skal kriterieområde stemme overens med sumområde

Løsning: I dette eksempel skal du ændre sumområde til C2:C12 og prøve formlen igen.

Note:  SUM.HVIS kan bruge forskellige størrelsesintervaller.

Har du et bestemt spørgsmål til en funktion?

Stil et spørgsmål i Excel-communityforummet

Hjælp os med at forbedre Excel

Har du forslag til, hvordan vi kan forbedre den næste version af Excel? Hvis det er tilfældet, skal du gå til emner i Excel User Voice.

See Also

Ret fejlen #VÆRDI!

Funktionen SUM.HVIS

Funktionen SUM.HVISER

Videoer om avanceret HVIS-funktion

Oversigt over formler i Excel

Sådan undgår du ødelagte formler

Brug fejlkontrol til at registrere fejl i formler

Alle Excel-funktioner (alfabetisk)

Alle Excel-funktioner (efter kategori)

Udvid dine færdigheder
Gå på opdagelse i kurser
Få nye funktioner først
Bliv Office Insider

Var disse oplysninger nyttige?

Tak for din feedback!

Tak for din feedback! Det lyder, som om det vil kunne hjælpe, hvis du bliver sat i forbindelse med en af vores Office-supportteknikere.

×