Sådan retter du en #VÆRDI-fejl i funktionen INDEKS/SAMMENLIGN

I dette emne beskrives de almindelige scenarier, hvor du støder på fejlen #VÆRDI!, når du bruger funktionerne INDEKS og SAMMENLIGN sammen i en formel. En af de mest almindelige årsager til at bruge kombinationen af INDEKS og SAMMENLIGN er, når du vil slå en værdi op i et scenarie, hvor LOPSLAG ikke fungerer for dig – f.eks. hvis din opslagsværdi er længere end 255 tegn.

Problem: Formlen er ikke angivet som en matrix

Hvis du bruger INDEKS som matrixformel sammen med SAMMENLIGN for at kunne hente en værdi, skal du konvertere din formel til en matrixformel. Ellers vises en #VÆRDI!-fejl.

Løsning: INDEKS og SAMMENLIGN skal bruges som en matrixformel. Det betyder, at du skal trykke på CTRL+SKIFT+ENTER. Formlen ombrydes derefter automatisk i klammeparenteser {}. Hvis du forsøger at angive dem selv, viser Excel formlen som tekst.

Hvis du bruger INDEKS/SAMMENLIGN, når du har en opslagsværdi, der er større end 255 tegn, skal den angives som en matrixformel.  Formlen i celle F3 er =INDEKS(B2:B4,SAMMENLIGN(SAND,A2:A4=F2,0),0), og angives ved at trykke på Ctrl+Skift+Enter
INDEKS og SAMMENLIGN skal bruges som en matrixformel

Har du et bestemt spørgsmål til en funktion?

Stil et spørgsmål i Excel-communityforummet

Hjælp os med at forbedre Excel

Har du forslag til, hvordan vi kan forbedre den næste version af Excel? Hvis det er tilfældet, skal du gå til emner i Excel User Voice.

Se også

Ret fejlen #VÆRDI!

Funktionen INDEKS

Funktionen SAMMENLIGN

Slå værdier op med LOPSLAG, INDEKS eller SAMMENLIGN

Oversigt over formler i Excel

Sådan undgår du ødelagte formler

Brug fejlkontrol til at registrere fejl i formler

Alle Excel-funktioner (alfabetisk)

Alle Excel-funktioner (efter kategori)

Udvid dine færdigheder
Gå på opdagelse i kurser
Få nye funktioner først
Bliv Office Insider

Var disse oplysninger nyttige?

Tak for din feedback!

Tak for din feedback! Det lyder, som om det vil kunne hjælpe, hvis du bliver sat i forbindelse med en af vores Office-supportteknikere.

×