Sådan retter du #VÆRDI!-fejlen i funktionen SUMPRODUKT

I dette emne beskrives de almindelige scenarier for fejlen #VÆRDI!, når du arbejder med SUMPRODUKT.

Problem: Matrixargumenterne har ikke den samme dimension

Alle matrixargumenterne skal være den samme dimension. Hvis de ikke er det, får du fejlen #VÆRDI!. Hvis f.eks. Matrix 1 refererer til et område på 3 rækker og 2 kolonner, så skal Matrix 2 også svare til det samme område.

Formlen SUMPRODUKT, der medfører en fejl, er =SUMPRODUKT(D2:D13;E2:E10) – E10 skal ændres til E13 for at matche det første område.
  • =SUMPRODUKT(D2:D13;E2:E10)

Mislykkes, fordi de refererede områder ikke har det samme antal rækker (13 i det første område, men kun 10 i det andet).

Løsning: Rediger formlen til:

  • =SUMPRODUKT(D2:D13;E2:E13)

Så begge områder har samme nummer for start- og slutrække, og prøv formlen igen.

Løs #VÆRDI!-fejlen i dataene for at løse SUMPRODUKT-fejlen

Problem: En eller flere celler i området indeholder tekst

Hvis en eller flere celler i det refererede område indeholder tekst eller er formateret som datatypen Tekst, får du fejlen #VÆRDI!. Teksten kan være resultatet af en beregning fra en anden formel, eller måske er cellen blot ikke formateret korrekt.

Formlen i celle E15 viser en #VÆRDI!-fejl, fordi der er en #VÆRDI!-fejl i kolonne E.

Løsning: Kontrollér, om en celle indeholder tekst eller er formateret som tekst, og indstil til den rette datatype.

Har du et bestemt spørgsmål til en funktion?

Stil et spørgsmål i Excel-communityforummet

Hjælp os med at forbedre Excel

Har du forslag til, hvordan vi kan forbedre den næste version af Excel? Hvis det er tilfældet, skal du gå til emner i Excel User Voice.

Se også

Ret fejlen #VÆRDI!

Funktionen SUMPRODUKT

Oversigt over formler i Excel

Sådan undgår du ødelagte formler

Brug fejlkontrol til at registrere fejl i formler

Alle Excel-funktioner (alfabetisk)

Alle Excel-funktioner (efter kategori)

Udvid dine færdigheder
Gå på opdagelse i kurser
Få nye funktioner først
Bliv Office Insider

Var disse oplysninger nyttige?

Tak for din feedback!

Tak for din feedback! Det lyder, som om det vil kunne hjælpe, hvis du bliver sat i forbindelse med en af vores Office-supportteknikere.

×