Sådan retter du #VÆRDI!-fejlen i funktionen SAMMENKÆDE

Vigtigt: I Excel 2016, Excel Mobile og Excel Online er SAMMENKÆDE blevet erstattet med funktionen SAMMENKÆDNING. Selvom funktionen SAMMENKÆDE stadig er tilgængelig af hensyn til bagudkompatibilitet, bør du overveje at bruge SAMMENKÆDNING, da det er en mere robust funktion.

Et af de mest almindelige scenarier, hvor du støder på fejlen #VÆRDI! med SAMMENKÆDE, er, når du forsøger at opbygge en streng, der indeholder en cellereference, der har en fejl, f.eks. #VÆRDI!.

I følgende eksempel vil vi gerne sammenkæde D2, E2 og F2, hvor E2 har fejlen #VÆRDI!.

#VÆRDI!-fejl i SAMMENKÆDNING

Fejlen i E2 medfører, at funktionen viser fejlen #VÆRDI!. For at den kan fungere korrekt skal du erstatte fejlen med en anden værdi end fejlen. Du kan oprette en formel, der kontrollerer, om der er fejl i cellereferencen, og hvis det er tilfældet, vise tekststrengen, hvor der vises et 0 i stedet for fejlen (eller du kan erstatte 0 med din egen tekst, men du skal omslutte teksten i anførselstegn – "Din tekst").

En formel som denne ville fungere:

=HVIS(ER.FEJL(E2);SAMMENKÆDNING(D2;" ";0;" ";F2))

HVIS- og ER.FEJL-funktioner, der bruges som en løsning til at sammenkæde en streng med #VÆRDI!-fejlen

Hvordan fungerer det? Funktionen HVIS bruger funktionen HVIS.FEJL til at afgøre, om der er en fejl i E2, og hvis det er tilfældet, kombinerer funktionen SAMMENKÆDE værdierne i D2, E2 og F2 (funktionen erstatter fejlen med et 0) og viser den resulterende tekststreng. Bemærk, at formlen også bruger mellemrum (" ") til at adskille værdierne.

Ret fejlen #VÆRDI! med SAMMENKÆDE i Excel 2003 og ældre versioner

Hvis du får fejlen #VÆRDI! i Office Excel 2003 eller ældre versioner, skal du fjerne markeringen af indstillingen Overgangsformelevaluering i Excel. Følg de trin, der er beskrevet i Fejlen #VÆRDI! ved sammenkædning af celler for at løse problemet.

Har du et bestemt spørgsmål til en funktion?

Stil et spørgsmål i Excel-communityforummet

Hjælp os med at forbedre Excel

Har du forslag til, hvordan vi kan forbedre den næste version af Excel? Hvis det er tilfældet, skal du gå til emner i Excel User Voice.

Se også

Ret fejlen #VÆRDI!

Funktionen SAMMENKÆDNING

Funktionen SAMMENKÆD

Oversigt over formler i Excel

Sådan undgår du ødelagte formler

Brug fejlkontrol til at registrere fejl i formler

Alle Excel-funktioner (alfabetisk)

Alle Excel-funktioner (efter kategori)

Udvid dine færdigheder
Gå på opdagelse i kurser
Få nye funktioner først
Bliv Office Insider

Var disse oplysninger nyttige?

Tak for din feedback!

Tak for din feedback! Det lyder, som om det vil kunne hjælpe, hvis du bliver sat i forbindelse med en af vores Office-supportteknikere.

×