Oprette, køre, redigere eller slette en makro

Vigtigt: Denne artikel er maskinoversat. Se ansvarsfraskrivelsen. Du kan finde den engelske version af denne artikel her til din orientering.

For at spare tid på opgaver, du ofte udfører, kan du optage trinnene i opgaverne som en makro. Når du så senere vil udføre en af disse optagede opgaver, kan du aktivere makroen, så den udfører trinnene for dig.

Word

I Word 2016 til Mac, kan du oprette en makro, der er en tastaturgenvej, afspille en makro og slette en makro, du ikke længere har brug for.

  1. Klik på Vis > Makroer > Indspil makro.

    Klik på Makro på fanen Vis, og klik derefter på Indspil makro for at begynde at oprette en makro.
  2. Skriv et navn til makroen, eller acceptér den standard, som Word giver.

    Angiv et navn på makroen i Makronavn, eller accepter det navn, der foreslås af Word.
  3. Hvis denne makro skal bruges i alle nye dokumenter, du opretter, skal du bekræfte, at Alle dokumenter (Normal) er valgt på listen Gem makro i.

  4. Klik på Tastatur for at tildele en tastekombination til makroen.

    Word viser dialogboksen Tilpas tastatur.

  5. Skriv en kombination af taster i feltet Tryk på ny tastaturgenvej.

    Word viser den kommando eller makro, der allerede er tildelt en tastekombination, hvis dette er relevant, når du trykker på kombinationen.

    Når du trykker på en tastekombination, viser Word den kommando eller handling, der aktuelt er tildelt den pågældende tastekombination, hvis der er nogen.

  6. Hvis den valgte tastekombination allerede er tildelt, skal du slette den fra feltet Tryk på ny tastaturgenvej og derefter vælge en ny tastekombination.

    Gå til næste trin, når du har fundet en ikke-tildelt tastekombination.

    Word identificerer, når du har trykket på en tastekombination, som endnu ikke er tildelt en kommando eller en makro.
  7. Hvis du vil bruge denne tastaturgenvej i nye dokumenter, skal du sørge for, at Normal.dotm, den globale skabelon, er valgt på listen Gem ændringer i.

    Vælg Normal.dotm for at gøre en makro tilgængelig til brug i nye dokumenter, du opretter.
  8. Klik på Tildel.

  9. Når du er klar til at optage makroen, skal du klikke på OK.

  10. Klik på kommandoerne, eller tryk på tasterne for hvert trin i opgaven.

    Word registrerer dine klik og tastetryk, men det registrerer ikke tekst, du markerer med musen. Hvis du vil markere tekst, mens du indspiller en makro, skal du bruge tastaturet.

  11. Når indspilningen skal stoppes, skal du klikke på Vis > Makroer > Stop indspilning.

    Klik på Stop indspilning i menuen Makroer for at stoppe indspilningen af en makro.

Afspille en makro, skal du trykke på den tastaturgenvej, der er tildelt eller køre makroen fra listen makroer.

  1. Klik på Vis > Makroer > Vis makroer.

    Klik på Vis makroer for at få vist og redigere makroer, der er knyttet til det aktuelle dokument.
  2. Vælg den makro, du vil køre, på listen under makronavn.

  3. Klik på Kør.

    Når du har valgt en makro under Makronavn, skal du klikke på Kør for at køre den.

  1. Klik på Vis > Makroer > Vis makroer.

    Klik på Vis makroer for at få vist og redigere makroer, der er knyttet til det aktuelle dokument.
  2. Kontrollér, at den placering, der angives af Makroer i, omfatter placeringen af den makro, du vil slette.

    Vælg placeringen af makroer, som du vil se via Makroer på listen .

    Listen indeholder det dokument, der er åbent i det aktuelle vindue, samt den globale skabelon og Word-kommandoer.

  3. Under Makronavn skal du vælge den makro, du vil slette, og derefter skal du klikke på minustegnet under listen.

    Vælg den makro, du vil slette, og klik derefter på minustegnet under listen.
  4. Når Word beder dig om at bekræfte, at du vil slette makroen, skal du klikke på Ja.

Excel

I Excel 2016 til Mac, kan du oprette en makro, der er en tastaturgenvej, afspille en makro og slette en makro, du ikke længere har brug for.

Når du indspiller en makro, makro optager poster alle trinnene for at fuldføre de handlinger, du vil have din makro til at udføre. Disse trin kan omfatte at skrive tekst eller tal, klikke på celler eller kommandoer på båndet eller menuer, formatering, markering af celler, rækker eller kolonner og trække musen til at markere celler i regnearket.

Bemærk: Kommandoerne for optagelse, oprette og slette makroer, samt andre avancerede funktioner, er også tilgængelige under fanen udvikler på båndet. Se Brug af fanen udvikler for at oprette eller slette en makro i Excel 2016 til Mackan finde flere oplysninger om brug af fanen udvikler.

  1. Vælg Funktioner > makro > ny post.

    Vælg værktøjer og derefter makro, og klik derefter Indspil ny makro

  2. Indtast et navn til makroen i feltet Makronavn.

    Angiv en makro navn, placering og genvej nøgle

  3. Hvis du vil oprette en tastaturgenvej til makroen, skal du skrive et bogstav i feltet alternativ + Cmd.

  4. Vælg en placering til makroen på rullelisten.

    Sådan gemmer du makroen

    Klik på

    I det dokument, du opretter makroen i

    Denne projektmappe

    I alle åbne dokumenter

    Ny projektmappe

    Så den er tilgængelig, hver gang du bruger Excel

    Personlig makroprojektmappe

  5. (Valgfrit) Tilføje en beskrivelse af makroen.

  6. Når du er klar til at optage, skal du klikke på OK.

  7. Klik på kommandoerne, eller tryk på tasterne for hvert trin i opgaven.

  8. Hvis du vil stoppe indspilningen, Vælg Funktioner > makro > Stop indspilning. (Dette trin ikke registreres i makroen.)

    Vælg Stop optagelse

Afspille en makro, skal du trykke på den tastaturgenvej, der er tildelt eller køre makroen fra dialogboksen makroer.

  1. Klik på Vis makroer på fanen Vis.

  2. Klik på makroer i pop op-menuen, og vælg Denne projektmappe.

  3. Vælg den ønskede makro på listen, og klik på Kør.

    Dialogboksen Makroer i Excel til Mac

  1. Vælg Funktioner > makro > makroer.

    Vælg makro og derefter vælge makroer

  2. Vælg makroen, slette, og derefter trykke på minustegnet.

    Vælg makroens navn og vælg derefter (minustegn)

  3. Der vises en bekræftelsesmeddelelse. Klik på Ja for at bekræfte sletningen.

    Bekræft sletning

Du kan også slette en makro fra fanen udvikler.

  1. Klik på Makroer under fanen Udvikler.

  2. Klik på den makro, du vil slette, på listen, og klik derefter på knappen Slet.

    Vælg en makro, og klik på minustegnet for at slette den

Word

For at automatisere tilbagevendende opgaver kan du hurtigt oprette en makro i Word. Du kan også bruge Visual Basic Editor i Microsoft Visual Basic for Applications til at skrive dit eget makroscript eller kopiere det hele eller dele af en makro til en ny makro.

Når du indspiller en makro, registreres alle de trin, som er nødvendige for at fuldføre de handlinger, du vil have din makro til at udføre. Navigation tilbage til fanen at stoppe optagelsen er ikke inkluderet i de optagede trin.

  1. Klik på Optag under Visual Basic under fanen Udvikler.

    Fanen Word Developer, gruppen Visual Basic

    Hvis fanen Udvikler ikke er tilgængelig

    1. I højre side af båndet skal du klikke på Pop op-menuen Handling og derefter klikke på Indstillinger for båndet.

    2. Markér afkrydsningsfeltet Udvikler under Tilpas.

  2. Indtast et navn til makroen i feltet Makronavn.

  3. Gør et af følgende i genvejsmenuen Gem makro i:

    Sådan gemmer du makroen

    Klik på

    I det dokument, du opretter makroen i

    [dokumentnavn] (dokument)

    I alle åbne dokumenter

    Alle dokumenter (Normal)

  4. Klik på OK, og udfør derefter de handlinger, du vil indspille.

  5. Klik på Stop under Visual Basic under fanen Udvikler.

Du kan bruge den indbyggede Visual Basic Editor til at oprette en makro.

  1. Klik på Editor under Visual Basic under fanen Udvikler.

    Fanen Word Developer, gruppen Visual Basic

    Hvis fanen Udvikler ikke er tilgængelig

    1. I højre side af båndet skal du klikke på Pop op-menuen Handling og derefter klikke på Indstillinger for båndet.

    2. Markér afkrydsningsfeltet Udvikler under Tilpas.

  2. Hvis du vil indsætte et modul, skal du klikke på Modul i menuen Indsæt i Visual Basic Editor.

  3. Skriv eller indsæt den makrokode, du vil bruge, i kodevinduet i modulet.

  4. Når du er færdig, skal du klikke på Luk og vend tilbage til Microsoft Word i Word-menuen.

  1. Klik på Makroer under Visual Basic under fanen Udvikler.

    Fanen Word Developer, gruppen Visual Basic

    Hvis fanen Udvikler ikke er tilgængelig

    1. I højre side af båndet skal du klikke på Pop op-menuen Handling og derefter klikke på Indstillinger for båndet.

    2. Markér afkrydsningsfeltet Udvikler under Tilpas.

  2. Klik på den makro, du vil køre, på listen, og klik derefter på Kør.

Hvis du vil redigere en makro, skal du bruge Visual Basic Editor.

  1. Klik på Makroer under Visual Basic under fanen Udvikler.

    Fanen Word Developer, gruppen Visual Basic

    Hvis fanen Udvikler ikke er tilgængelig

    1. I højre side af båndet skal du klikke på Pop op-menuen Handling og derefter klikke på Indstillinger for båndet.

    2. Markér afkrydsningsfeltet Udvikler under Tilpas.

  2. Klik på den makro, du vil redigere, på listen, og klik derefter på Rediger.

    Visual Basic Editor åbnes.

  3. Foretag de ønskede ændringer.

  4. Når du er færdig, skal du klikke på Luk og vend tilbage til Microsoft Word i Word-menuen.

  1. Klik på Makroer under Visual Basic under fanen Udvikler.

    Fanen Word Developer, gruppen Visual Basic

    Hvis fanen Udvikler ikke er tilgængelig

    1. I højre side af båndet skal du klikke på Pop op-menuen Handling og derefter klikke på Indstillinger for båndet.

    2. Markér afkrydsningsfeltet Udvikler under Tilpas.

  2. Klik på den makro, du vil kopiere, på listen, og klik derefter på Rediger.

    Visual Basic Editor åbnes.

  3. Markér de linjer, du vil kopiere, i kodevinduet i Visual Basic Editor.

    Tip: Medtag linjerne Sub og End Sub i det markerede, hvis du vil kopiere hele makroen.

  4. Klik på Kopiér i menuen Rediger.

  5. Klik på det modul, hvor koden skal indsættes, i feltet Projekt i kodevinduet.

  6. Klik på Sæt ind i menuen Rediger.

  1. Klik på Makroer under Visual Basic under fanen Udvikler.

    Fanen Word Developer, gruppen Visual Basic

    Hvis fanen Udvikler ikke er tilgængelig

    1. I højre side af båndet skal du klikke på Pop op-menuen Handling og derefter klikke på Indstillinger for båndet.

    2. Markér afkrydsningsfeltet Udvikler under Tilpas.

  2. Klik på den makro, du vil slette, på listen, og klik derefter på Slet.

PowerPoint

Hvis du vil automatisere en gentagen opgave, kan du bruge Visual Basic for Applications til at oprette en makro i PowerPoint.

Du kan bruge den indbyggede Visual Basic Editor til at oprette en makro.

  1. Klik på Editor under Visual Basic under fanen Udvikler.

    Fanen PowerPoint Developer, gruppen Visual Basic

    Hvis fanen Udvikler ikke er tilgængelig

    1. I højre side af båndet skal du klikke på Pop op-menuen Handling og derefter klikke på Indstillinger for båndet.

    2. Markér afkrydsningsfeltet Udvikler under Tilpas.

  2. Hvis du vil indsætte et modul, skal du klikke på Modul i menuen Indsæt i Visual Basic Editor.

  3. Skriv eller indsæt den makrokode, du vil bruge, i kodevinduet i modulet.

  4. Når du er færdig, skal du klikke på Luk og vend tilbage til Microsoft PowerPoint i menuen PowerPoint.

  1. Klik på Makroer under Visual Basic under fanen Udvikler.

    Fanen PowerPoint Developer, gruppen Visual Basic

    Hvis fanen Udvikler ikke er tilgængelig

    1. I højre side af båndet skal du klikke på Pop op-menuen Handling og derefter klikke på Indstillinger for båndet.

    2. Markér afkrydsningsfeltet Udvikler under Tilpas.

  2. Klik på den makro, du vil køre, på listen, og klik derefter på Kør.

Hvis du vil redigere en makro, skal du bruge Visual Basic Editor.

  1. Klik på Makroer under Visual Basic under fanen Udvikler.

    Fanen PowerPoint Developer, gruppen Visual Basic

    Hvis fanen Udvikler ikke er tilgængelig

    1. I højre side af båndet skal du klikke på Pop op-menuen Handling og derefter klikke på Indstillinger for båndet.

    2. Markér afkrydsningsfeltet Udvikler under Tilpas.

  2. Klik på den makro, du vil redigere, på listen, og klik derefter på Rediger.

    Visual Basic Editor åbnes.

  3. Foretag de ønskede ændringer.

  4. Når du er færdig, skal du klikke på Luk og vend tilbage til Microsoft PowerPoint i menuen PowerPoint.

  1. Klik på Makroer under Visual Basic under fanen Udvikler.

    Fanen PowerPoint Developer, gruppen Visual Basic

    Hvis fanen Udvikler ikke er tilgængelig

    1. I højre side af båndet skal du klikke på Pop op-menuen Handling og derefter klikke på Indstillinger for båndet.

    2. Markér afkrydsningsfeltet Udvikler under Tilpas.

  2. Klik på den makro, du vil kopiere, på listen, og klik derefter på Rediger.

    Visual Basic Editor åbnes.

  3. Markér de linjer, du vil kopiere, i kodevinduet i Visual Basic Editor.

    Tip: Medtag linjerne Sub og End Sub i det markerede, hvis du vil kopiere hele makroen.

  4. Klik på Kopiér i menuen Rediger.

  5. Klik på det modul, hvor koden skal indsættes, i feltet Projekt i kodevinduet.

  6. Klik på Sæt ind i menuen Rediger.

  1. Klik på Makroer under Visual Basic under fanen Udvikler.

    Fanen PowerPoint Developer, gruppen Visual Basic

    Hvis fanen Udvikler ikke er tilgængelig

    1. I højre side af båndet skal du klikke på Pop op-menuen Handling og derefter klikke på Indstillinger for båndet.

    2. Markér afkrydsningsfeltet Udvikler under Tilpas.

  2. Klik på den makro, du vil slette, på listen, og klik derefter på Slet.

Excel

Hvis du vil automatisere en tilbagevendende opgave, kan du hurtigt at oprette en makro i Excel. Du kan også bruge Visual Basic Editor i Microsoft Visual Basic for Applications til at skrive dit eget makroscript eller kopiere det hele eller dele af en makro til en ny makro.

Alle de trin, der kræves for at udføre de handlinger, du vil have, at makroen skal udføre, bliver registreret. Navigation tilbage til fanen for at stoppe indspilningen er ikke omfattet af de registrerede trin.

  1. Klik på Optag under Visual Basic under fanen Udvikler.

    Fanen Excel Developer, gruppen Visual Basic

    Hvis fanen Udvikler ikke er tilgængelig

    1. I højre side af båndet skal du klikke på Pop op-menuen Handling og derefter klikke på Indstillinger for båndet.

    2. Markér afkrydsningsfeltet Udvikler under Tilpas.

  2. Indtast et navn til makroen i feltet Makronavn.

    Tip: Hvis du vil oprette en tastaturgenvej til makroen, skal du skrive et bogstav i feltet Alternativ+Kommando+ .

  3. Gør et af følgende i genvejsmenuen Gem makro i:

    Sådan gemmer du makroen

    Klik på

    I det dokument, du opretter makroen i

    Denne projektmappe

    I alle åbne dokumenter

    Ny projektmappe

    Så den er tilgængelig, hver gang du bruger Excel

    Personlig makroprojektmappe

    Din personlige makroprojektmappe er placeret under brugere / brugernavn/Library/Application Support / Microsoft/Office/Excel.

  4. Klik på OK, og udfør derefter de handlinger, du vil indspille.

  5. Klik på Optag igen under Visual Basic under fanen Udvikler.

Du kan bruge den indbyggede Visual Basic Editor til at oprette en makro.

  1. Klik på Editor under Visual Basic under fanen Udvikler.

    Fanen Excel Developer, gruppen Visual Basic

    Hvis fanen Udvikler ikke er tilgængelig

    1. I højre side af båndet skal du klikke på Pop op-menuen Handling og derefter klikke på Indstillinger for båndet.

    2. Markér afkrydsningsfeltet Udvikler under Tilpas.

  2. Hvis du vil indsætte et modul, skal du klikke på Modul i menuen Indsæt i Visual Basic Editor.

  3. Skriv eller indsæt den makrokode, du vil bruge, i kodevinduet i modulet.

  4. Når du er færdig, skal du klikke på Luk og vend tilbage til Microsoft Excel i Excel-menuen.

  1. Klik på Makroer under Visual Basic under fanen Udvikler.

    Fanen Excel Developer, gruppen Visual Basic

    Hvis fanen Udvikler ikke er tilgængelig

    1. I højre side af båndet skal du klikke på Pop op-menuen Handling og derefter klikke på Indstillinger for båndet.

    2. Markér afkrydsningsfeltet Udvikler under Tilpas.

  2. Klik på den makro, du vil køre, på listen, og klik derefter på Kør.

    Tip: Hvis du vil køre en makro ved hjælp af en tastaturgenvej, skal du trykke på Alternativ + KOMMANDO + det bogstav, du skrev, da du oprettede tastaturgenvejen.

Hvis du vil redigere en makro, skal du bruge Visual Basic Editor.

  1. Klik på Makroer under Visual Basic under fanen Udvikler.

    Fanen Excel Developer, gruppen Visual Basic

    Hvis fanen Udvikler ikke er tilgængelig

    1. I højre side af båndet skal du klikke på Pop op-menuen Handling og derefter klikke på Indstillinger for båndet.

    2. Markér afkrydsningsfeltet Udvikler under Tilpas.

  2. Klik på den makro, du vil redigere, på listen, og klik derefter på Rediger.

    Visual Basic Editor åbnes.

  3. Foretag de ønskede ændringer.

  4. Når du er færdig, skal du klikke på Luk og vend tilbage til Microsoft Excel i Excel-menuen.

Når du har gennemført denne procedure, kører makroen, hver gang du åbner den projektmappe, der indeholder makroen.

  1. Klik på Optag under Visual Basic under fanen Udvikler.

    Fanen Excel Developer, gruppen Visual Basic

    Hvis fanen Udvikler ikke er tilgængelig

    1. I højre side af båndet skal du klikke på Pop op-menuen Handling og derefter klikke på Indstillinger for båndet.

    2. Markér afkrydsningsfeltet Udvikler under Tilpas.

  2. Skriv Auto_åbn i feltet Makronavn.

  3. Gør et af følgende i genvejsmenuen Gem makro i:

    Sådan gemmer du makroen

    Klik på

    I det dokument, du opretter makroen i

    Denne projektmappe

    I alle åbne dokumenter

    Ny projektmappe

    Så den er tilgængelig, hver gang du bruger Excel

    Personlig makroprojektmappe

  4. Klik på OK, og udfør derefter de handlinger, du vil indspille.

  5. Klik på Optag igen under Visual Basic under fanen Udvikler.

  6. Klik på Gem som i menuen Filer.

  7. Klik på Excel-projektmappe med aktive makroer (.xlsm) i genvejsmenuen Formatér, og klik derefter på Gem.

  1. Klik på Makroer under Visual Basic under fanen Udvikler.

    Fanen Excel Developer, gruppen Visual Basic

    Hvis fanen Udvikler ikke er tilgængelig

    1. I højre side af båndet skal du klikke på Pop op-menuen Handling og derefter klikke på Indstillinger for båndet.

    2. Markér afkrydsningsfeltet Udvikler under Tilpas.

  2. Klik på den makro, du vil kopiere, på listen, og klik derefter på Rediger.

    Visual Basic Editor åbnes.

  3. Markér de linjer, du vil kopiere, i kodevinduet i Visual Basic Editor.

    Tip: Medtag linjerne Sub og End Sub i det markerede, hvis du vil kopiere hele makroen.

  4. Klik på Kopiér i menuen Rediger.

  5. Klik på det modul, hvor koden skal indsættes, i feltet Projekt i kodevinduet.

  6. Klik på Sæt ind i menuen Rediger.

  1. Klik på Makroer under Visual Basic under fanen Udvikler.

    Fanen Excel Developer, gruppen Visual Basic

    Hvis fanen Udvikler ikke er tilgængelig

    1. I højre side af båndet skal du klikke på Pop op-menuen Handling og derefter klikke på Indstillinger for båndet.

    2. Markér afkrydsningsfeltet Udvikler under Tilpas.

  2. Klik på den makro, du vil slette, på listen, og klik derefter på Slet.

Bemærk: Ansvarsfraskrivelse for maskinoversættelse: Denne artikel er blevet oversat af et computersystem uden menneskelig indgriben. Microsoft tilbyder disse maskinoversættelse for at hjælpe ikke-engelsktalende brugere til at kunne nyde indhold om Microsofts produkter, tjenester og teknologier. Da artiklen er maskinoversat, kan den indeholde forkerte ord eller syntaks- eller grammatikfejl.

Udvid dine færdigheder
Gå på opdagelse i kurser
Få nye funktioner først
Bliv Office Insider

Var disse oplysninger nyttige?

Tak for din feedback!

Tak for din feedback! Det lyder, som om det vil kunne hjælpe, hvis du bliver sat i forbindelse med en af vores Office-supportteknikere.

×