Oprette en pivottabel med en ekstern datakilde

Vigtigt: Denne artikel er maskinoversat. Se ansvarsfraskrivelsen. Du kan finde den engelske version af denne artikel her til din orientering.

Når du er i stand til at analysere alle dataene, kan det hjælpe dig til at træffe bedre forretningsmæssige beslutninger. Men nogle gange er det svært at vide, hvor du skal starte, især når du har masser af data, der er gemt uden for Excel, f.eks. en Microsoft Access- eller Microsoft SQL Server-database eller en OLAP-kubefil (Online Analytical Processing). I dette tilfælde kan du oprette forbindelse til den eksterne datakilde og derefter oprette en pivottabel for at summere, analysere, udforske og vise de pågældende data.

Sådan oprettes en pivottabel vha. en eksisterende ekstern dataforbindelse:

  1. Klik på en celle i regnearket.

  2. Klik på Indsæt > Pivottabel.

    Knappen Pivottabel under fanen Indsæt

  3. Klik på Brug en ekstern datakilde under Vælg de data, du vil analysere i dialogboksen Opret pivottabel.

    dialogboksen opret pivottabel med brug og ekstern datakilde markeret

  4. Klik på Vælg forbindelse.

  5. Sørg for, at Alle forbindelser er markeret i feltet Vis under fanen Forbindelser, eller vælg den forbindelseskategori, der har den datakilde, du vil oprette forbindelse til.

Hvis du vil genbruge eller dele en eksisterende forbindelse, skal du bruge en forbindelse fra Forbindelser i denne projektmappe.

  1. Markér den ønskede forbindelse på listen over forbindelser, og klik derefter på Åbn.

  2. Vælg en placering under Vælg, hvor pivottabellen skal placeres.

    • Hvis du vil placere pivottabellen i et nyt regneark, der starter ved celle A1, skal du vælge Nyt regneark.

    • Hvis du vil placere pivottabellen i det aktive regneark, skal du vælge Eksisterende regneark og derefter angive den celle, hvor pivottabellen skal starte, i feltet Placering.

  3. Klik på OK.

    Excel tilføjer en tom pivottabel og viser feltlisten, så du kan få vist de ønskede felter og omarrangere dem for at oprette dit eget layout.

    Feltliste, der viser eksterne datafelter

  4. I feltlistesektionen skal du markere afkrydsningsfeltet ud for et feltnavn for at placere feltet i et standardområde i områdesektionen i Feltliste.

    Typisk føjes ikke-numeriske felter til området Rækker, numeriske felter føjes til området Værdier, og felter med dato og klokkeslæt føjes til området Kolonner. Du kan flytte felter til et andet område efter behov.

    Tip:  Du kan også højreklikke på et feltnavn og derefter markere Føj til Rapportfilter, Føj til Kolonnenavne, Føj til Rækkenavne eller Føj til Værdier for at placere feltet i det pågældende område i områdesektionen eller trække et felt fra feltsektionen til et område i områdesektionen.

    Brug Feltliste til at omarrangere dataene i pivottabellen yderligere ved at højreklikke på felterne i områdesektionen, og derefter vælge det ønskede område eller ved at trække felterne mellem områderne i områdesektionen.

Oprette forbindelse til en ny ekstern datakilde

Hvis du vil oprette en ny ekstern dataforbindelse til SQL Server og importere data i Excel som en tabel eller pivottabel, skal du gøre følgende:

  1. Klik på Data > Fra andre kilder.

Knappen Fra andre kilder under fanen Data

  1. Klik på den ønskede forbindelse.

    • Klik på Fra SQL Server for at oprette forbindelse til en SQL Server-tabel.

    • Klik på Fra Analysis Services for at oprette en forbindelse til en SQL Server Analysis-kube.

  2. Fuldfør trinnene for at oprette forbindelsen i Guiden Dataforbindelse.

    • Angiv databaseserveren på side 1, og angiv, hvordan du vil logge på serveren.

    • Angiv den database, tabel eller forespørgsel, der indeholder de ønskede data, på side 2.

    • Angiv den forbindelsesfil, du vil oprette, på side 3.

Hvis du vil oprette en ny forbindelse til en Access-database og importere data i Excel som en tabel eller pivottabel, skal du gøre følgende:

  1. Klik på Data > Fra Access.

Knappen Fra Access under fanen Data

  1. Find den database, du vil oprette forbindelse til, i dialogboksen Vælg datakilde, og klik på Åbn.

  2. Markér den ønskede tabel i dialogboksen Markér tabel, og klik derefter på OK.

Hvis der er flere tabeller, skal du markere feltet Giv mulighed for markering af flere tabeller, så du kan markere felterne for de ønskede tabeller og derefter klikke på OK.

  1. Vælg, hvordan du vil vise dataene i projektmappen, og hvor du vil placere dem, i dialogboksen Importér data, og klik derefter på OK.

Tabellerne bliver automatisk føjet til datamodellen, og Access-databasen er føjet til din projektmappeforbindelser.

Flere oplysninger om at pivottabeller

Bemærk: Ansvarsfraskrivelse for maskinoversættelse: Denne artikel er blevet oversat af et computersystem uden menneskelig indgriben. Microsoft tilbyder disse maskinoversættelse for at hjælpe ikke-engelsktalende brugere til at kunne nyde indhold om Microsofts produkter, tjenester og teknologier. Da artiklen er maskinoversat, kan den indeholde forkerte ord eller syntaks- eller grammatikfejl.

Del Facebook Facebook Twitter Twitter Mail Mail

Var disse oplysninger nyttige?

Fantastisk! Har du mere feedback?

Hvordan kan vi forbedre det?

Tak for din feedback!

×