Oprette en datamodel i Excel

Vigtigt: Denne artikel er maskinoversat. Se ansvarsfraskrivelsen. Du kan finde den engelske version af denne artikel her til din orientering.

En datamodel er en ny metode til integrering af data fra flere tabeller, effektivt opbygning af en relationel datakilde i en Excel-projektmappe. I Excel bruges-datamodeller transparent, give tabelformat data i pivottabeller, pivotdiagrammer og Power View-rapporter. Før dykning flere detaljer, du muligvis vil tage et skridt tilbage og se en video eller tage vores learning vejledning på Hent og Transformér og Power Pivot.

Bemærk: I denne artikel beskrives datamodeller i Excel 2013. Dog gælder de samme datamodellering og Power Pivot-funktioner, der blev introduceret i Excel 2013 også for Excel 2016. Der er effektivt lille forskel mellem disse versioner af Excel.

I de fleste tilfælde lægger du slet ikke mærke til, at modellen er der. I Excel visualiseres en datamodel som en tabelsamling på en feltliste. Hvis du vil arbejde med modellen direkte, skal du bruge tilføjelsesprogrammet Microsoft Office Power Pivot i Microsoft Excel 2013.

Når du importerer relationsdata, oprettes der automatisk en model, når du vælger flere tabeller:

  1. I Excel skal du bruge Data > Hent eksterne data til at importere data fra Access eller en anden relationsdatabase, der indeholder flere relaterede tabeller.

  2. Excel beder dig om at vælge en tabel. Markér Aktivér markering af flere tabeller.

    Vælge dialogboksen Tabel

  3. Vælg to eller flere tabeller, klik på Næste og Afslut.

  4. I Importér data skal du vælge den ønskede datavisualiseringsindstilling, f.eks. en pivottabel i et nyt ark, og oprette rapporten.

Du har nu en datamodel, der indeholder alle de tabeller, du har importeret. Da du har valgt indstillingen Pivottabel, vises modellen på den feltliste, du vil bruge til at oprette pivottabellen.

pivottabelfeltliste

Hvad kan du gøre med denne model? Du kan bruge den til at oprette pivottabeller, pivotdiagrammer og Power View-rapporter i den samme projektmappe. Du kan ændre den ved at tilføje eller fjerne tabeller, og hvis du bruger Power Pivot-tilføjelsesprogrammet, kan du udvide modellen ved at tilføje beregnede kolonner, beregnede felter, hierarkier og KPI'er.

Når du opretter en datamodel, er visualiseringsindstillingen vigtig. Du kan vælge Pivottabelrapport, Pivotdiagram eller Power View-rapport som datavisualisering. Disse indstillinger giver dig mulighed for at arbejde med alle tabellerne samlet. Hvis du havde valgt Tabel i stedet for, ville alle importerede tabeller være placeret i et særskilt regneark. På den måde kan tabellerne bruges enkeltvis, men hvis du vil bruge alle tabellerne sammen, kræves der en pivottabel-, pivotdiagram- eller Power View-rapport.

Bemærkninger: 

  • Modeller oprettes implicit, når du importerer to eller flere tabeller samtidig i Excel.

  • Modeller oprettes eksplicit, når du bruger tilføjelsesprogrammet Power Pivot til at importere data. I tilføjelsesprogrammet repræsenteres modellen i layoutet faner, hvor hver fane indeholder data i tabelformat. Se hente data ved brug af Power Pivot-tilføjelsesprogrammettil at vide om import af data ved hjælp af en SQL Server-database.

  • En model kan indeholde en enkelt tabel. Hvis du vil oprette en model på basis af en enkelt tabel, skal du vælge tabellen og klikke på Føj til datamodel i Power Pivot. Du gør muligvis dette, hvis du ønsker at bruge Power Pivot-funktioner, f.eks. filtrerede datasæt, beregnede kolonner, beregnede felter, KPI'er og hierarkier.

  • Tabelrelationer oprettes automatisk, hvis du importerer relaterede tabeller, der har relationer med primær eller fremmed nøgle. Excel kan normalt bruge de importerede relationsoplysninger som basis for tabelrelationer i datamodellen.

  • Tip til, hvordan du kan reducere størrelsen på en datamodel, kan du se oprette en hukommelseseffektiv datamodel ved hjælp af Excel 2013 og Power Pivot-tilføjelsesprogrammet.

  • Finde mere dybtgående Selvstudium: pivottabeldataanalyse med en datamodel i Excel 2013.

Tip: Projektmappen indeholder data, men ved du, om den indeholder en datamodel? Du kan hurtigt se status for model ved at åbne vinduet Power Pivot. Hvis data vises i faner, der findes en model. Mere om at finde ud af, hvilke datakilder der bruges i en projektmappedatamodel data.

Brug en datamodel i en anden pivottabel, et andet pivotdiagram eller en anden Power View-rapport.

En Excel-projektmappe kan kun indeholde én datamodel, men den model kan bruges flere gange i projektmappen.

  1. Klik på Indsæt > Pivottabel i Excel.

  2. I Opret pivottabel skal du klikke på Brug en ekstern datakilde og derefter klikke på Vælg forbindelse.

  3. Klik på Tabeller i Eksisterende forbindelse.

  4. Under Datamodel i denne projektmappe er Tabeller i datamodel i projektmappe valgt som standard. Klik på Åbn, og klik derefter på OK. Der vises en pivottabelfeltliste, der viser alle tabeller i modellen.

Tilføje eksisterende urelaterede data til en datamodel

Antag, at du har importeret eller kopieret en masse data, som du vil bruge i en model, men ikke har markeret afkrydsningsfeltet Føj disse data til datamodellen under importen. Det er nemmere, end du tror, at overføre nye data til en model.

  1. Start med de data, du vil føje til modellen. Det kan være ethvert dataområde, men det er bedst at benytte et navngivet område.

  2. Fremhæv de celler, du vil tilføje, eller placer markøren i en celle, hvis dataene er i en tabel eller et navngivet område.

  3. Benyt én af nedenstående fremgangsmåder for at tilføje dataene:

  4. Klik på Power Pivot > Føj til datamodel.

  5. Klik på Indsæt > Pivottabel, og markér derefter Føj disse data til datamodellen i dialogboksen Opret pivottabel.

Området eller tabellen er nu føjes til modellen som en sammenkædet tabel. Hvis du vil vide mere om at arbejde med sammenkædede tabeller i en model, skal du se Tilføje Data ved hjælp af Excel sammenkædede tabeller i Power Pivot.

Tilpasse og udvide datamodellen i Power Pivot-tilføjelsesprogrammet

Excel indeholder datamodeller, der forstærker og forbedrer rapporteringen, især når denne omfatter pivottabeller eller andre rapportformater, der er beregnet til at undersøge og analysere data. Selv om datamodeller er vigtige, holdes de med vilje i baggrunden, så du kan fokusere på, hvad du vil gøre med dem.

Men antag, at du gerne vil arbejde direkte med modellen. Hvis feltlisten er baseret på en model, vil du måske gerne fjerne tabeller eller felter fra listen, hvis du ikke har brug for dem. Du vil måske gerne have vist alle de underliggende data, som modellen indeholder, eller tilføje KPI'er, hierarkier og forretningslogik. Det er kun nogle af årsagerne til, at du gerne vil ændre datamodellen direkte.

Redigere eller administrere datamodellen skal du bruge tilføjelsesprogrammet Power Pivot. Tilføjelsesprogrammet er en del af Office Professional Plus udgave af Excel 2013, men aktiveret ikke som standard. Mere om at Starte Power Pivot i Microsoft Excel-tilføjelsesprogrammet.

Forskelle mellem en tabel i Power Pivot og en tabel i et regneark

I Power Pivot, kan du tilføje en række til en tabel ved at skrive direkte i en ny række, som du kan i et Excel-regneark. Men du kan tilføje rækker ved hjælp af Indsæt kommandoer og ved at opdatere data.

Data i et Excel-regneark er ofte variable og uensartede, dvs. én række kan f.eks. indeholde numeriske data, og den næste række kan indeholde grafik eller en tekststreng. En tabel i Power Pivot er derimod mere som i en relationsdatabase, hvor alle rækker har samme antal kolonner, og de fleste kolonner indeholder data.

Bruge datamodellen i Power View

En datamodel bruges som basis for en Power View-rapport. Hvis du bruger Power Pivot-tilføjelsesprogrammet, kan du føje optimeringer til modellen, der forbedrer Power View-rapporteringen. Optimeringerne medfører, at du kan: angive en standardfeltliste, vælge repræsentative felter eller billeder, der entydigt identificerer bestemte rækker, eller angive, hvordan rækker med gentagne værdier (f.eks. medarbejdere eller kunder med det samme navn) håndteres i et rapporteringsprogram.

  1. Opret en datamodel ved at importere flere relaterede tabeller.

  2. Klik på Power Pivot > Administrer for at åbnePower Pivot-vinduet.

  3. Vælg en tabel, og anvend optimeringer:

    1. Klik på Avanceret > Standardfeltsæt. Vælg de felter, der skal i automatisk vises på en Power View-rapport, når du klikker på den overordnede tabel. Se Konfigurere Standardfeltsæt til Power View-rapporter til detaljer.

    2. Klik på Avanceret > Tabelfunktionsmåde. Optimere til rapportlayout, der grupperer data. Gruppering er underlagt standardfunktioner, der nogle gange produceret utilsigtede resultater, som konsolidering rækker, der skal være angivet separat. Du kan finde oplysninger i Konfigurere egenskaber for Tabelfunktionsmåden for Power View-rapporter .

    3. Klik på Avanceret > Datakategori. Nogle rapportvisualiseringer er specifikke for datatyper. Hvis du f.eks. har en klokkeslæts- eller datobaseret tabel, kan du tildele en datokategori, der hjælper Power View med tidsbaserede visualiseringer.

  4. Gentag fremgangsmåden for andre tabeller.

  5. I Excel, skal du klikke på Indsæt > Power View for at starte en ny rapport. Se Power View: undersøge, visualisere og præsentere dine data kan finde flere oplysninger.

Bemærk: Ansvarsfraskrivelse for maskinoversættelse: Denne artikel er blevet oversat af et computersystem uden menneskelig indgriben. Microsoft tilbyder disse maskinoversættelse for at hjælpe ikke-engelsktalende brugere til at kunne nyde indhold om Microsofts produkter, tjenester og teknologier. Da artiklen er maskinoversat, kan den indeholde forkerte ord eller syntaks- eller grammatikfejl.

Udvid dine færdigheder
Gå på opdagelse i kurser
Få nye funktioner først
Bliv Office Insider

Var disse oplysninger nyttige?

Tak for din feedback!

Tak for din feedback! Det lyder, som om det vil kunne hjælpe, hvis du bliver sat i forbindelse med en af vores Office-supportteknikere.

×