Oprette betingede formler til at finde data eller anvende formatering

Hvis reglerne for indbyggede betingede formateringsregler i Excel ikke opfylder dine behov, kan du bruge en formel til at få de ønskede resultater. Du kan f.eks. bruge en betinget formel til at finde tomme celler og farve dem røde, så de er lettere at få øje på.

  1. Markér de celler, du vil formatere.

  2. Klik på Startside > Betinget formatering > Ny regel.

  3. Klik på Brug en formel til at bestemme, hvilke celler der skal formateres.

  4. Angiv formlen under Formatér værdier, hvor denne formel er sand.

  5. Klik på Formatér.

  6. Brug kontrolelementerne under fanerne Tal, Skrifttype, Kant og Udfyldning til at ændre dine data eller cellerne omkring dine data.

Du kan f.eks. ændre negative værdier til fed og rød, tilføje en lysegul udfyldning som baggrund i celler eller tilføje en stiplet rød kant.

Klik på OK for at lukke alle åbne dialogbokse.

Her er et eksempel:

  1. Markér alle cellerne i et regneark. Det gør du ved at markere vælgeren over række 1 og til venstre for kolonne A.

  2. Gentag trin 1 til 3, som står ovenfor.

  3. Når du kommer til trin 4, skal du angive =REST(RÆKKE(),2)=1. Du kan kopiere og indsætte formlen, hvis du vil.

  4. Klik på Formatér, og klik derefter på fanen Udfyldning, og vælg en nuance af blå fra farvepaletten.

  5. Klik på OK for at benytte reglen, og nu får hver anden række i regnearket den farve, du vælger.

Det er lidt af det, betingede formler kan bruges til i en formateringsregel.

Eksempler på betingede formler

  • Hvis du vil finde tomme celler, skal du først markere det celleområde (en række eller en kolonne), som indeholder dine resultater, derefter skal du gentage trinnene i første sektion for at oprette en formateringsregel, som bruger denne formel.

    =B2=""

    Husk, at du skal erstatte B2 i din formel med den første celle, du vil bruge.

  • Hvis du vil finde dubletter i et celleområde, så prøv denne her. Den anvender formatering på alle værdier, som ikke er entydige.

    =TÆL.HVIS($A$1:$D$11,D2)>1

  • Hvis du vil beregne et gennemsnit, skal du angive følgende:

    =A1>MIDDEL(A1:A14)

Når du er blevet fortrolig med betingede formularer, kan du prøve dem her. De anvender de logiske operatorer HVIS, OG og ELLER. Du skal skrive dem på formellinjen i Excel (de kan ikke bruges i en regel), men de kan spare dig for tid og besvær.

  • Find værdier, der opfylder to betingelser: Excel viser SAND, hvis værdien i celle A2 er større end værdien i A3, og den samtidig er mindre end værdien i A4. Men hvis værdien i A2 ikke opfylder begge betingelser, vises i stedet FALSK.

    =OG(A2>A3;A2<A4)

  • Find værdier, der opfylder én betingelse: I denne her, viser Excel kun SAND, hvis værdien i A2 opfylder én af betingelserne – den er større end værdien i A3 eller mindre end værdien i A4.

    =ELLER(A2>A3;A2<A4)

  • B rug formler, som ikke viser SAND eller FALSK som resultat : Dette eksempel viser "OK", hvis værdien i A2 ikke er lig med værdierne i A3 og A4. Ellers vises "IKKE OK".

    =HVIS(OG(A2<>A3;A2<>A4),"OK","IKKE OK") vises.

  • T ilføj karakterer med bogstaver , som er baseret på et resultat med tal : Denne formel tilføjer karakterer ud fra et hvilket som helst type resultat, f.eks. testresultater eller produktbedømmelser.

    =HVIS(D2>=80,"A", HVIS(D2>=75, "B+", HVIS(D2>=70, "B", HVIS(D2>=70,"B:, HVIS(D2>=65,"C+", HVIS(D2>=60, "C","D"))))))

  • E rstat bogstavkaraktererne med "Bestået" og "Dumpet" :

    =HVIS(D2>59,"Bestået","Dumpet")

Mere om betinget formatering

Få mere at vide om betinget formatering.

Del Facebook Facebook Twitter Twitter Mail Mail

Var disse oplysninger nyttige?

Fantastisk! Har du mere feedback?

Hvordan kan vi forbedre det?

Tak for din feedback!

×