Oprette betingede formler

Vigtigt: Denne artikel er maskinoversat. Se ansvarsfraskrivelsen. Du kan finde den engelske version af denne artikel her til din orientering.

At afprøve, om betingelser er SAND eller FALSK og foretage logiske sammenligninger mellem udtryk er fælles for mange opgaver. Du kan bruge den OG, ELLER, IKKE, og HVIS -funktioner til at oprette betingede formler.

Eksempelvis bruger HVIS -funktionen følgende argumenter.

formel med funktionen hvis

Formel, der bruger funktionen HVIS

Knapflade logisk_test: den betingelse, du vil kontrollere.

Billedtekst 2 værdi_hvis_sand: værdien, der skal returneres, hvis betingelsen er sand.

Knapflade værdi_hvis_falsk: værdien, der skal returneres, hvis betingelsen er falsk.

Du kan finde flere oplysninger om, hvordan du opretter formler, under oprette eller slette en formel.

Hvad vil du foretage dig?

Oprette en betinget formel, der resulterer i en logisk værdi (SAND eller FALSK)

Oprette en betinget formel, der resulterer i en anden beregning eller værdier andet end TRUE eller FALSE

Oprette en betinget formel, der resulterer i en logisk værdi (SAND eller FALSK)

Bruge og OGELLERog IKKE funktioner og operatorer som vist i følgende eksempel for at udføre denne opgave.

Eksempel

Hvis du kopierer eksemplet til et tomt regneark, er det måske nemmere at forstå.

Hvordan kan jeg kopiere et eksempel?

  1. Markér eksemplet i denne artikel.

    Vigtigt: Undlad at markere række‑ eller kolonneoverskrifter.

    vælge et eksempel fra Hjælp i Excel 2013 til Windows

    Markere et eksempel i Hjælp

  2. Tryk på Ctrl + C.

  3. Opret en tom projektmappe eller et tomt regneark i Excel.

  4. Markér celle A1 i regnearket, og tryk på Ctrl + V.

Vigtigt: For at eksemplet skal fungere korrekt, skal du indsætte det i celle A1 i regnearket.

  1. Hvis du vil skifte mellem visning af resultaterne og visning af de formler, der returnerer resultaterne, skal du trykke på Ctrl + ` (accent grave) eller klikke på knappen Vis formler i gruppen Formelrevision under fanen Formler.

Når du har kopieret eksemplet til et tomt regneark, kan du tilpasse det til dit behov.

1

2

3

4

5

6%

7



8



9


10


11



12

A

B

Data

15

9

8

Tandhjul

Knapper

Formel

Beskrivelse (resultat)

=OG(A2>A3; A2<A4)

Fastlægger, om værdien i celle A2 er større end værdien i A3, og også om værdien i A2 er mindre end værdien i A4 (FALSK).

=ELLER(A2>A3; A2<A4)

Fastlægger, om værdien i celle A2 er større end værdien i A3, eller om værdien i A2 er mindre end værdien i A4 (SAND).

=IKKE(A2+A3=24)

Fastlægger, om summen af værdierne i cellerne A2 og A3 ikke er lig med 24 (FALSK).

=IKKE(A5="Tandhjul")

Fastlægger, om værdierne i celle A5 ikke er lig med "Tandhjul" (FALSK).

=ELLER(A5<>"Tandhjul",A6 = "Knapper")

Fastlægger, om værdien i celle A5 ikke er lig med "Tandhjul", eller om værdien i A6 er lig med "Knapper" (SAND).

Se funktionen OG, funktionen ellerog funktionen IKKEkan finde flere oplysninger om, hvordan du bruger disse funktioner.

Toppen af siden

Oprette en betinget formel, der resulterer i en anden beregning eller i andre værdier end SAND eller FALSK

Brug funktionerne HVIS, OG og ELLER til at udføre denne opgave som vist i følgende eksempel.

Eksempel

Hvis du kopierer eksemplet til et tomt regneark, er det måske nemmere at forstå.

Hvordan kan jeg kopiere et eksempel?

  1. Markér eksemplet i denne artikel.

Vigtigt: Undlad at markere række‑ eller kolonneoverskrifter.

vælge et eksempel fra Hjælp i Excel 2013 til Windows

Markere et eksempel i Hjælp

  1. Tryk på Ctrl + C.

  2. Opret en tom projektmappe eller et tomt regneark i Excel.

  3. Markér celle A1 i regnearket, og tryk på Ctrl + V.

Vigtigt: For at eksemplet skal fungere korrekt, skal du indsætte det i celle A1 i regnearket.

  1. Hvis du vil skifte mellem visning af resultaterne og visning af de formler, der returnerer resultaterne, skal du trykke på Ctrl + ` (accent grave) eller klikke på knappen Vis formler i gruppen Formelrevision under fanen Formler.

Når du har kopieret eksemplet til et tomt regneark, kan du tilpasse det til dit behov.

1

2

3

4

5

6%

7


8



9



10



11




12



13



14




15



16

A

B

Data

15

9

8

Tandhjul

Knapper

Formel

Beskrivelse (resultat)

=HVIS(A2=15, "OK"; "Ikke OK")

Hvis værdien i celle A2 er lig med 15, returneres "OK." Ellers returneres "Ikke OK" (OK).

=HVIS(A2<>15, "OK"; "Ikke OK")

Hvis værdien i celle A2 ikke er lig med 15, returneres "OK". Ellers returneres "Ikke OK" (Ikke OK).

=HVIS(IKKE(A2<=15), "OK", "Ikke OK")

Hvis værdien i celle A2 ikke er mindre end eller lig med 15, returneres "OK". Ellers returneres "Ikke OK" (Ikke OK).

=HVIS(A5<>"TANDHJUL", "OK", "Ikke OK")

Hvis værdien i celle A5 ikke er lig med "TANDHJUL", returneres "OK". Ellers returneres (Ikke OK) (Ikke OK).

=HVIS(OG(A2>A3, A2<A4), "OK", "Ikke OK")

Hvis værdien i celle A2 er større end værdien i A3, og værdien i A2 samtidig er mindre end værdien i A4, returneres "OK". Ellers returneres "Ikke OK" (Ikke OK).

=HVIS(OG(A2<>A3, A2<>A4), "OK", "Ikke OK")

Hvis værdien i celle A2 ikke er lig med A3, og værdien i A2 desuden ikke er lig med værdien i A4, returneres "OK". Ellers returneres "Ikke OK" (OK).

=HVIS(ELLER(A2>A3; A2<A4); "OK"; "Ikke OK")

Hvis værdien i celle A2 er større end værdien i A3, eller værdien i A2 er mindre end værdien i A4, returneres "OK". Ellers returneres "Ikke OK" (OK).

=HVIS(ELLER(A5<>"Tandhjul", A6<>"Knapper"), "OK", "Ikke OK")

Hvis værdien i celle A5 ikke er lig med "Tandhjul", eller værdien i A6 ikke er lig med "Knapper", returneres "OK". Ellers returneres "Ikke OK" (Ikke OK).

=HVIS(ELLER(A2<>A3, A2<>A4), "OK", "Ikke OK")

Hvis værdien i celle A2 ikke er lig med værdien i A3, eller værdien i A2 ikke er lig med værdien i A4, returneres "OK". Ellers returneres "Ikke OK" (OK).

Du kan finde flere oplysninger om, hvordan du bruger disse funktioner, skal du se funktionen HVIS, funktionen OGog funktionen eller.

Toppen af siden

Bemærk: Ansvarsfraskrivelse for maskinoversættelse: Denne artikel er blevet oversat af et computersystem uden menneskelig indgriben. Microsoft tilbyder disse maskinoversættelse for at hjælpe ikke-engelsktalende brugere til at kunne nyde indhold om Microsofts produkter, tjenester og teknologier. Da artiklen er maskinoversat, kan den indeholde forkerte ord eller syntaks- eller grammatikfejl.

Del Facebook Facebook Twitter Twitter Mail Mail

Var disse oplysninger nyttige?

Fantastisk! Har du mere feedback?

Hvordan kan vi forbedre det?

Tak for din feedback!

×