Oprette betingede formler

Vigtigt: Denne artikel er maskinoversat. Se ansvarsfraskrivelsen. Du kan finde den engelske version af denne artikel her til din orientering.

Det er fælles for mange opgaver at afprøve, om betingelser er sande eller falske, og at foretage logiske sammenligninger mellem udtryk. Du kan bruge funktionerne OG, ELLER, IKKE og HVIS til at oprette betingede formler.

Eksempelvis bruger Hvis -funktionen følgende argumenter.

formel med Hvis funktionen

Formel, der bruger funktionen HVIS

Knapflade  logisk_test: Den betingelse, du vil kontrollere.

Billedtekst 2  værdi_hvis_sand: Den værdi, der skal returneres, hvis betingelsen er sand.

Knapflade  værdi_hvis_falsk: Den værdi, der skal returneres, hvis betingelsen er falsk.

Du kan finde flere oplysninger om, hvordan du opretter formler, skal du se Oversigt over formler.

Hvad vil du foretage dig?

Oprette en betinget formel, der resulterer i en logisk værdi (SAND eller FALSK)

Oprette en betinget formel, der resulterer i en anden beregning eller i andre værdier end SAND eller FALSK

Oprette en betinget formel, der resulterer i en logisk værdi (SAND eller FALSK)

Du kan udføre denne opgave ved hjælp af funktionerne OG, ELLER og IKKE samt operatorer som vist i følgende eksempel.

Eksempel

Hvis du kopierer eksemplet til et tomt regneark, er det måske nemmere at forstå.

Hvordan kan jeg kopiere et eksempel?

Markér eksemplet i denne artikel. Hvis du kopierer eksemplet i Excel Web App, skal du kopiere og indsætte én celle ad gangen.

Vigtigt: Undlad at markere række‑ eller kolonneoverskrifter.

vælge et eksempel fra Hjælp i Excel 2013 til Windows

Markere et eksempel i Hjælp

  1. Tryk på Ctrl+C.

  2. Opret en tom projektmappe eller et tomt regneark.

  3. Markér celle A1 i regnearket, og tryk på Ctrl+V. Hvis du arbejder i Excel Web App, skal du kopiere og indsætte hver enkelt celle i eksemplet.

Vigtigt: For at eksemplet skal fungere korrekt, skal du indsætte det i celle A1 i regnearket.

  1. Hvis du vil skifte mellem visning af resultaterne og visning af de formler, der returnerer resultaterne, skal du trykke på Ctrl + ` (accent grave) eller klikke på knappen Vis formler i gruppen Formelrevision under fanen Formler.

Når du har kopieret eksemplet til et tomt regneark, kan du tilpasse det til dit behov.

1

2

3

4

5

6%

7



8



9


10


11



12

A

B

Data

15

9

8

Tandhjul

Knapper

Formel

Beskrivelse (resultat)

=OG(A2>A3; A2<A4)

Fastlægger, om værdien i celle A2 er større end værdien i A3, og også om værdien i A2 er mindre end værdien i A4 (FALSK).

=ELLER(A2>A3; A2<A4)

Fastlægger, om værdien i celle A2 er større end værdien i A3, eller om værdien i A2 er mindre end værdien i A4 (SAND).

=IKKE(A2+A3=24)

Fastlægger, om summen af værdierne i cellerne A2 og A3 ikke er lig med 24 (FALSK).

=IKKE(A5="Tandhjul")

Fastlægger, om værdierne i celle A5 ikke er lig med "Tandhjul" (FALSK).

=ELLER(A5<>"Tandhjul",A6 = "Knapper")

Fastlægger, om værdien i celle A5 ikke er lig med "Tandhjul", eller om værdien i A6 er lig med "Knapper" (SAND).

Der er flere oplysninger om, hvordan du bruger disse funktioner, i Funktionen OG, Funktionen ELLER, og Funktionen IKKE.

Øverst på siden

Oprette en betinget formel, der resulterer i en anden beregning eller i andre værdier end SAND eller FALSK

Brug funktionerne HVIS, OG og ELLER til at udføre denne opgave som vist i følgende eksempel.

Eksempel

Hvis du kopierer eksemplet til et tomt regneark, er det måske nemmere at forstå.

Hvordan kan jeg kopiere et eksempel?

Markér eksemplet i denne artikel. Hvis du kopierer eksemplet i Excel Web App, skal du kopiere og indsætte én celle ad gangen.

Vigtigt: Undlad at markere række‑ eller kolonneoverskrifter.

vælge et eksempel fra Hjælp i Excel 2013 til Windows

Markere et eksempel i Hjælp

  1. Tryk på Ctrl+C.

  2. Opret en tom projektmappe eller et tomt regneark.

  3. Markér celle A1 i regnearket, og tryk på Ctrl+V. Hvis du arbejder i Excel Web App, skal du kopiere og indsætte hver enkelt celle i eksemplet.

Vigtigt: For at eksemplet skal fungere korrekt, skal du indsætte det i celle A1 i regnearket.

  1. Hvis du vil skifte mellem visning af resultaterne og visning af de formler, der returnerer resultaterne, skal du trykke på Ctrl + ` (accent grave) eller klikke på knappen Vis formler i gruppen Formelrevision under fanen Formler.

Når du har kopieret eksemplet til et tomt regneark, kan du tilpasse det til dit behov.

1

2

3

4

5

6%

7


8



9



10



11




12



13



14




15



16

A

B

Data

15

9

8

Tandhjul

Knapper

Formel

Beskrivelse (resultat)

=HVIS(A2=15, "OK"; "Ikke OK")

Hvis værdien i celle A2 er lig med 15, returneres "OK." Ellers returneres "Ikke OK" (OK).

=HVIS(A2<>15, "OK"; "Ikke OK")

Hvis værdien i celle A2 ikke er lig med 15, returneres "OK". Ellers returneres "Ikke OK" (Ikke OK).

=HVIS(IKKE(A2<=15), "OK", "Ikke OK")

Hvis værdien i celle A2 ikke er mindre end eller lig med 15, returneres "OK". Ellers returneres "Ikke OK" (Ikke OK).

=HVIS(A5<>"TANDHJUL", "OK", "Ikke OK")

Hvis værdien i celle A5 ikke er lig med "TANDHJUL", returneres "OK". Ellers returneres (Ikke OK) (Ikke OK).

=HVIS(OG(A2>A3, A2<A4), "OK", "Ikke OK")

Hvis værdien i celle A2 er større end værdien i A3, og værdien i A2 samtidig er mindre end værdien i A4, returneres "OK". Ellers returneres "Ikke OK" (Ikke OK).

=HVIS(OG(A2<>A3, A2<>A4), "OK", "Ikke OK")

Hvis værdien i celle A2 ikke er lig med A3, og værdien i A2 desuden ikke er lig med værdien i A4, returneres "OK". Ellers returneres "Ikke OK" (OK).

=HVIS(ELLER(A2>A3; A2<A4); "OK"; "Ikke OK")

Hvis værdien i celle A2 er større end værdien i A3, eller værdien i A2 er mindre end værdien i A4, returneres "OK". Ellers returneres "Ikke OK" (OK).

=HVIS(ELLER(A5<>"Tandhjul", A6<>"Knapper"), "OK", "Ikke OK")

Hvis værdien i celle A5 ikke er lig med "Tandhjul", eller værdien i A6 ikke er lig med "Knapper", returneres "OK". Ellers returneres "Ikke OK" (Ikke OK).

=HVIS(ELLER(A2<>A3, A2<>A4), "OK", "Ikke OK")

Hvis værdien i celle A2 ikke er lig med værdien i A3, eller værdien i A2 ikke er lig med værdien i A4, returneres "OK". Ellers returneres "Ikke OK" (OK).

Der er flere oplysninger om, hvordan du bruger disse funktioner, i Funktionen HVIS, Funktionen OG og Funktionen ELLER.

Øverst på siden

Bemærk: Ansvarsfraskrivelse for maskinoversættelse: Denne artikel er blevet oversat af et computersystem uden menneskelig indgriben. Microsoft tilbyder disse maskinoversættelse for at hjælpe ikke-engelsktalende brugere til at kunne nyde indhold om Microsofts produkter, tjenester og teknologier. Da artiklen er maskinoversat, kan den indeholde forkerte ord eller syntaks- eller grammatikfejl.

Del Facebook Facebook Twitter Twitter Mail Mail

Var disse oplysninger nyttige?

Fantastisk! Har du mere feedback?

Hvordan kan vi forbedre det?

Tak for din feedback!

×