Opret, eller slet en makro

Hvis gentagne opgaver skal automatiseres, kan du hurtigt indspille en makro i Microsoft Excel. Du kan også oprette en makro ved at bruge Visual Basic Editor i Microsoft Visual Basic for Applications (VBA) for at skrive din egen makrokode eller for at kopiere hele makroen eller en del af den til en ny makro. Når du opretter en makro, kan du tildele den et objekt (f.eks. en værktøjslinjeknap, grafik eller et kontrolelement), så du kan køre den ved at klikke på objektet. Når du ikke længere har brug for en makro, kan du slette den.

Følgende trin er til at oprette og slette makroer i Excel 2013 og 2016.

Indspille en makro

Når du indspiller en makro, indspilles alle de trin, der er brug for til at fuldføre de handlinger, du vil have, at makroen skal udføre. Disse trin kan omfatte at angive tekst eller tal, klikke på celler eller kommandoer på båndet eller i menuer, formatering, markering af celler, rækker eller kolonner og trækning af din musemærker for at markere celler i dit regneark. Kommandoerne for optagelse, oprettelse og sletning af makroer findes under fanen Udvikler på båndet.

  1. Hvis fanen Udviklerikke kan vælges, skal du benytte følgende fremgangsmåde for at få den vist:

    1. Klik på fanen Filer.

    2. Klik på Indstillinger, og klik derefter på Tilpas båndet.

    3. Markér afkrydsningsfeltet Udvikler på listen Hovedfaner i kategorien Tilpas båndet, og klik derefter på OK.

  2. Du skal muligvis først angive sikkerhedsniveauet for at aktivere alle makroer. Sådan gør du.

    1. Klik på Makrosikkerhed i gruppen Kode under fanen Udvikler.

      Gruppen Kode under fanen Udvikler i Excel

    2. Klik på Aktiver alle koder (anbefales ikke, da potentielt farlig kode kan køres) under Indstillinger for makro, og klik derefter på OK.

      Advarsel: For at forhindre, at der køres potentielt farlig kode, anbefales det, at du vender tilbage til en af de indstillinger, der deaktiverer alle makroer, når du er færdig med at arbejde med makroer.

  3. Klik på Indspil makro i gruppen Kode under fanen Udvikler.

  4. Indtast et navn til makroen i boksen Makronavn.

    Bemærk: Det første tegn i makronavnet skal være et bogstav. Efterfølgende tegn kan være bogstaver, tal eller understregningstegn. Mellemrum kan ikke bruges i et makronavn; et understregningstegn fungerer godt som en ordseparator. Hvis du bruger et makronavn, der også er en cellereference, kan du få vist en fejlmeddelelse om, at makronavnet er ugyldigt.

  5. Hvis du vil tildele en genvejstast med en CTRL-kombination til at køre makroen, skal du i feltet Genvejstast indtaste et vilkårligt lille eller stort bogstav, som du vil bruge.

    Genvejstasten tilsidesætter alle tilsvarende Excel-standardgenvejstaster, mens den projektmappe, der indeholder makroen, er åben.

  6. Vælg den projektmappe, hvor du vil gemme makroen, på listen Gem makro i.

    Hvis du ønsker, at en makro skal være tilgængelig, hver gang du bruger Excel, skal du markere Personlig makroprojektmappe. Når du vælger Personlig makroprojektmappe, oprettes der en skjult personlig makroprojektmappe (Personal.xlsb), hvis den ikke allerede findes, og makroen gemmes i denne projektmappe. I Windows 7 og Windows Vista gemmes denne projektmappe i mappen C:\Users\brugernavn\AppData\Local\Microsoft\Excel\XLStart. I Microsoft Windows XP gemmes projektmappen i mappen C:\Documents and Settings\brugernavn\Application Data\Microsoft\Excel\XLStart. Projektmapper i mappen XLStart åbnes automatisk, når Excel starter. Hvis du vil have, at en makro i din personlige makroprojektmappe skal afspilles automatisk i en anden projektmappe, skal du også gemme den pågældende projektmappe i XLStart-mappen, så begge projektmapper åbnes, når Excel starter.

  7. Indtast en beskrivelse af makroen i feltet Beskrivelse.

  8. Klik på OK for at starte indspilningen.

  9. Udfør de funktioner, som du vil indspille.

  10. Klik på Stop indspilning Knapflade i gruppen Kode under fanen Udvikler.

Toppen af siden

Oprette en makro ved hjælp af VBA

  1. Klik på Visual Basic i gruppen Kode under fanen Udvikler.

  2. Klik om nødvendigt på Modul i menuen Indsæt i Visual Basic Editor.

    Bemærk: Der oprettes automatisk moduler for alle ark i projektmappen.

  3. Skriv eller kopier den makrokode, du vil bruge, i kodevinduet i modulet.

  4. Hvis du vil køre makroen fra modulvinduet, skal du trykke på F5.

  5. Klik på Luk og vend tilbage til Microsoft Excel i menuen Filer i Visual Basic Editor, når du har skrevet makroen.

Toppen af siden

Kopiere en del af en makro for at oprette en anden makro

  1. Åbn den projektmappe, der indeholder den makro, du vil kopiere.

  2. Klik på Makroer i gruppen Kode under fanen Udvikler.

  3. Klik på navnet på den makro, du vil kopiere, i boksen Makronavn.

  4. Klik på Rediger.

  5. Marker de linjer af makroen, du vil kopiere, i kodevinduet i Visual Basic Editor.

    Tip: Medtag linjerne Sub og End Sub i det markerede for at kopiere hele makroen.

  6. Klik på Kopier i menuen Rediger.

  7. Klik på det modul, hvor du vil placere koden, i boksen Procedure i kodevinduet.

  8. Klik på Sæt ind i menuen Rediger.

Du kan muligvis ikke redigere din personlige makroprojektmappefil (Personal.xlsb), da den er en skjult projektmappe, der altid er åben. Du skal først gøre den synlig ved at bruge kommandoen Vis. Du kan også åbne den i Visual Basic Editor ved at trykke på Alt+F11.

Toppen af siden

Tildele en makro et objekt, grafik eller et kontrolelement

  1. Højreklik i et regneark på det objekt, grafik eller kontrolelement, som du vil tildele en eksisterende makro, og klik derefter på Tildel makro.

  2. Klik på den makro, du vil tildele, i feltet Makronavn.

Toppen af siden

Slette en makro

  1. Benyt en af følgende fremgangsmåder:

    • Åbn den projektmappe, der indeholder makroen, du vil slette.

    • Hvis den makro, du vil slette, er gemt i den personlige makroprojektmappe (Personal.xlsb), og denne projektmappe er skjult, skal du benytte følgende fremgangsmåde for at vise projektmappen:

      1. Klik på Vis under fanen Vis i gruppen Vindue.

      2. Klik på PERSONLIG under Vis projektmappe, og klik derefter på OK.

  2. Markér den projektmappe, som indeholder den makro, du vil slette, på listen Makroer i. Klik f.eks. på Denne projektmappe.

  3. Klik på navnet på den makro, du ønsker at slette, i boksen Makronavn.

  4. Klik på Slet.

Toppen af siden

Følgende trin er til at oprette og slette makroer i Excel 2010.

Indspille en makro

Når du indspiller en makro, optager makrooptageren alle de trin, der er brug for til at fuldføre de handlinger, du vil have makroen til at udføre. Navigering på båndet er ikke med i de indspillede trin.

  1. Hvis fanen Udviklerikke kan vælges, skal du benytte følgende fremgangsmåde for at få den vist:

    1. Klik på fanen Filer.

    2. Klik på Indstillinger, og klik derefter på Tilpas båndet.

    3. Markér afkrydsningsfeltet Udvikler på listen Hovedfaner i kategorien Tilpas båndet, og klik derefter på OK.

  2. Benyt følgende fremgangsmåde, når du vil angive sikkerhedsniveauet midlertidigt for at aktivere alle makroer:

    1. Klik på Makrosikkerhed i gruppen Kode under fanen Udvikler.

      Gruppen Kode under fanen Udvikler

    2. Klik på Aktiver alle koder (anbefales ikke, da potentielt farlig kode kan køres) under Indstillinger for makro, og klik derefter på OK.

      Bemærk    For at forhindre at der køres potentielt farlig kode, anbefales det, at du vender tilbage til en af de indstillinger, der deaktiverer alle makroer, når du er færdig med at arbejde med makroer.

      Du kan finde flere oplysninger om, hvordan du ændrer indstillingerne, under Ændre indstillinger for makrosikkerhed i Excel.

  3. Klik på Indspil makro i gruppen Kode under fanen Udvikler.

  4. Indtast et navn til makroen i boksen Makronavn.

    Bemærk    Det første tegn i makronavnet skal være et bogstav. Efterfølgende tegn kan være bogstaver, tal eller understregningstegn. Mellemrum kan ikke bruges i et makronavn; et understregningstegn fungerer godt som en ordseparator. Hvis du bruger et makronavn, der også er en cellereference, kan du få vist en fejlmeddelelse om, at makronavnet er ugyldigt.

  5. Hvis du vil tildele en genvejstast med en CTRL-kombination til at køre makroen, skal du i boksen Genvejstast indtaste et vilkårligt lille eller stort bogstav, som du vil bruge.

    Bemærk    Genvejstasten tilsidesætter alle tilsvarende Excel-standardgenvejstaster, mens den projektmappe, der indeholder makroen, er åben.

    Se en liste over CTRL-kombinationer for genvejstaster, der allerede er tildelt i Excel, i Excel-genvej og -funktionstaster.

  6. Vælg den projektmappe, hvor du vil gemme makroen, på listen Gem makro i.

    Tip    Hvis du ønsker, at en makro skal være tilgængelig, hver gang du bruger Excel, skal du markere Personlig makroprojektmappe. Når du vælger Personlig makroprojektmappe, oprettes der en skjult personlig makroprojektmappe (Personal.xlsb), hvis den ikke allerede findes, og makroen gemmes i denne projektmappe. I Windows Vista gemmes denne projektmappe i mappen C:\Users\brugernavn\AppData\Local\Microsoft\Excel\XLStart. I Microsoft Windows XP gemmes projektmappen i mappen C:\Documents and Settings\brugernavn\Application Data\Microsoft\Excel\XLStart. Projektmapper i mappen XLStart åbnes automatisk, når Excel starter. Hvis du vil have, at en makro i din personlige makroprojektmappe skal afspilles automatisk i en anden projektmappe, skal du også gemme den pågældende projektmappe i XLStart-mappen, så begge projektmapper åbnes, når Excel starter.

  7. Indtast en beskrivelse af makroen i feltet Beskrivelse.

  8. Klik på OK for at starte indspilningen.

  9. Udfør de funktioner, som du vil indspille.

  10. Klik på Stop indspilning Knapflade i gruppen Kode under fanen Udvikler.

    Tip</ui> Du kan også klikke på Stop indspilning   i venstre side af statuslinjen.

Toppen af siden

Oprette en makro ved hjælp af VBA

  1. Hvis fanen Udviklerikke kan vælges, skal du benytte følgende fremgangsmåde for at få den vist:

    1. Klik på fanen Filer.

    2. Klik på Indstillinger, og klik derefter på Tilpas båndet.

    3. Markér afkrydsningsfeltet Udvikler på listen Hovedfaner i kategorien Tilpas båndet, og klik derefter på OK.

  2. Benyt følgende fremgangsmåde, når du vil angive sikkerhedsniveauet midlertidigt for at aktivere alle makroer:

    1. Klik på Makrosikkerhed i gruppen Kode under fanen Udvikler.

      Gruppen Kode under fanen Udvikler

    2. Klik på Aktiver alle koder (anbefales ikke, da potentielt farlig kode kan køres) under Indstillinger for makro, og klik derefter på OK.

      Bemærk    For at forhindre at der køres potentielt farlig kode, anbefales det, at du vender tilbage til en af de indstillinger, der deaktiverer alle makroer, når du er færdig med at arbejde med makroer.

      Du kan finde flere oplysninger om, hvordan du ændrer indstillingerne, under Ændre indstillinger for makrosikkerhed i Excel.

  3. Klik på Visual Basic i gruppen Kode under fanen Udvikler.

  4. Klik om nødvendigt på Modul i menuen Indsæt i Visual Basic Editor.

    Bemærk    Der oprettes automatisk moduler for alle ark i projektmappen.

  5. Skriv eller kopier den makrokode, du vil bruge, i kodevinduet i modulet.

  6. Hvis du vil køre makroen fra modulvinduet, skal du trykke på F5.

  7. Klik på Luk og vend tilbage til Microsoft Excel i menuen Filer i Visual Basic Editor, når du har skrevet makroen.

Toppen af siden

Kopiere en del af en makro for at oprette en anden makro

  1. Hvis fanen Udviklerikke kan vælges, skal du benytte følgende fremgangsmåde for at få den vist:

    1. Klik på fanen Filer.

    2. Klik på Indstillinger, og klik derefter på Tilpas båndet.

    3. Markér afkrydsningsfeltet Udvikler på listen Hovedfaner i kategorien Tilpas båndet, og klik derefter på OK.

  2. Benyt følgende fremgangsmåde, når du vil angive sikkerhedsniveauet midlertidigt for at aktivere alle makroer:

    1. Klik på Makrosikkerhed i gruppen Kode under fanen Udvikler.

      Gruppen Kode under fanen Udvikler

    2. Klik på Aktiver alle koder (anbefales ikke, da potentielt farlig kode kan køres) under Indstillinger for makro, og klik derefter på OK.

      Bemærk    For at forhindre at der køres potentielt farlig kode, anbefales det, at du vender tilbage til en af de indstillinger, der deaktiverer alle makroer, når du er færdig med at arbejde med makroer.

      Du kan finde flere oplysninger om, hvordan du ændrer indstillingerne, under Ændre indstillinger for makrosikkerhed i Excel.

  3. Åbn den projektmappe, der indeholder den makro, du vil kopiere.

  4. Klik på Makroer i gruppen Kode under fanen Udvikler.

  5. Klik på navnet på den makro, du vil kopiere, i boksen Makronavn.

  6. Klik på Rediger.

  7. Marker de linjer af makroen, du vil kopiere, i kodevinduet i Visual Basic Editor.

    Tip    Medtag linjerne Sub og End Sub i det markerede for at kopiere hele makroen.

  8. Klik på Kopier i menuen Rediger.

    Tip    Du kan også højreklikke og derefter klikke på Kopier, eller du kan trykke på CTRL+C.

  9. Klik på det modul, hvor du vil placere koden, i boksen Procedure i kodevinduet.

  10. Klik på Sæt ind i menuen Rediger.

    Tip    Du kan også højreklikke og derefter klikke på Sæt ind, eller du kan trykke på CTRL+V.

Tip    Du kan ikke redigere din personlige makroprojektmappefil (Personal.xlsb), da den er en skjult projektmappe, der altid er åben. Du skal først gøre den synlig ved at bruge kommandoen Vis. Du kan også åbne den i Visual Basic Editor ved at trykke på ALT+F11.

Toppen af siden

Tildele en makro et objekt, grafik eller et kontrolelement

  1. Højreklik i et regneark på det objekt, grafik eller kontrolelement, som du vil tildele en eksisterende makro, og klik derefter på Tildel makro.

  2. Klik på den makro, du vil tildele, i feltet Makronavn.

Toppen af siden

Slette en makro

  1. Benyt en af følgende fremgangsmåder:

    • Åbn den projektmappe, der indeholder makroen, du vil slette.

    • Hvis den makro, du vil slette, er gemt i den personlige makroprojektmappe (Personal.xlsb), og denne projektmappe er skjult, skal du benytte følgende fremgangsmåde for at vise projektmappen:

      1. Klik på Vis under fanen Vis i gruppen Vindue.

      2. Klik på PERSONLIG under Vis projektmappe, og klik derefter på OK.

  2. Hvis fanen Udvikler ikke er synlig, skal du benytte følgende fremgangsmåde for at få den vist:

    1. Klik på fanen Filer.

    2. Klik på Indstillinger, og klik derefter på Tilpas båndet.

    3. Markér afkrydsningsfeltet Udvikler på listen Hovedfaner i kategorien Tilpas båndet, og klik derefter på OK.

  3. Klik på Makroer i gruppen Kode under fanen Udvikler.

    Gruppen Kode under fanen Udvikler

  4. Markér den projektmappe, som indeholder den makro, du vil slette, på listen Makroer i. Klik f.eks. på Denne projektmappe.

  5. Klik på navnet på den makro, du ønsker at slette, i boksen Makronavn.

  6. Klik på Slet.

Toppen af siden

Følgende trin er til at oprette og slette makroer i Excel 2007.

Indspille en makro

Når du indspiller en makro, optager makrooptageren alle de trin, der er brug for til at fuldføre de handlinger, du vil have makroen til at udføre. Navigering på båndet er ikke med i de indspillede trin.

Bemærk: Båndet er en komponent i Brugergrænsefladen Microsoft Fluent (båndet).

  1. Hvis fanen Udvikler ikke er synlig, skal du benytte følgende fremgangsmåde for at få den vist:

    1. Klik på Microsoft Office-knappen Office-knapflade , og klik derefter på Excel-indstillinger.

    2. Marker afkrydsningsfeltet Vis fanen Udvikler på båndet i kategorien Populær under Vigtigste indstillinger for arbejde med Excel, og klik derefter på OK.

  2. Benyt følgende fremgangsmåde, når du vil angive sikkerhedsniveauet midlertidigt for at aktivere alle makroer:

    1. Klik på Makrosikkerhed i gruppen Kode under fanen Udvikler.

      Gruppen Kode under fanen Udvikler

    2. Klik på Aktiver alle koder (anbefales ikke, da potentielt farlig kode kan køres) under Indstillinger for makro, og klik derefter på OK.

      Bemærk: For at forhindre, at der køres potentielt farlig kode, anbefales det, at du vender tilbage til en af de indstillinger, der deaktiverer alle makroer, når du er færdig med at arbejde med makroer. Der er flere oplysninger om, hvordan du ændrer indstillingerne, under Ændre indstillinger for makrosikkerhed i Excel.

  3. Klik på Indspil makro i gruppen Kode under fanen Udvikler.

  4. Indtast et navn til makroen i boksen Makronavn.

Bemærk: Det første tegn i makronavnet skal være et bogstav. Efterfølgende tegn kan være bogstaver, tal eller understregningstegn. Mellemrum kan ikke bruges i et makronavn; et understregningstegn fungerer godt som en ordseparator. Hvis du bruger et makronavn, der også er en cellereference, kan du få vist en fejlmeddelelse om, at makronavnet er ugyldigt.

  1. Hvis du vil tildele en genvejstast med en CTRL-kombination til at køre makroen, skal du i boksen Genvejstast indtaste et vilkårligt lille eller stort bogstav, som du vil bruge.

    Bemærk: Genvejstasten ignorerer alle tilsvarende Excel-standardgenvejstaster, mens den projektmappe, der indeholder makroen, er åben. Hvis du vil have vist en liste over genvejstaster med CTRL-kombinationer, der allerede er tildelt i Excel, henvises til Genvejs- og funktionstaster i Excel.

  2. Vælg den projektmappe, hvor du vil gemme makroen, på listen Gem makro i.

    Tip: Hvis du ønsker, at en makro skal være tilgængelig, hver gang du bruger Excel, skal du markere Personlig makroprojektmappe. Når du vælger Personlig makroprojektmappe, oprettes der en skjult personlig makroprojektmappe (Personal.xlsb), hvis den ikke allerede findes, og makroen gemmes i denne projektmappe. I Windows Vista gemmes denne projektmappe i mappen C:\Users\brugernavn\AppData\Local\Microsoft\Excel\XLStart. I Microsoft Windows XP gemmes projektmappen i mappen C:\Documents and Settings\brugernavn\Application Data\Microsoft\Excel\XLStart. Projektmapper i mappen XLStart åbnes automatisk, når Excel starter. Hvis du vil have, at en makro i din personlige makroprojektmappe skal afspilles automatisk i en anden projektmappe, skal du også gemme den pågældende projektmappe i XLStart-mappen, så begge projektmapper åbnes, når Excel starter.

  3. Indtast en beskrivelse af makroen i feltet Beskrivelse.

  4. Klik på OK for at starte indspilningen.

  5. Udfør de funktioner, som du vil indspille.

  6. Klik på Stop indspilning Knapflade i gruppen Kode under fanen Udvikler.

    Du kan også klikke på Stop indspilning Knapflade i venstre side af statuslinjen.

Toppen af siden

Oprette en makro ved hjælp af Microsoft Visual Basic for Applications

  1. Hvis fanen Udvikler ikke er synlig, skal du benytte følgende fremgangsmåde for at få den vist:

    1. Klik på Microsoft Office-knappen Office-knapflade , og klik derefter på Excel-indstillinger.

    2. Marker afkrydsningsfeltet Vis fanen Udvikler på båndet i kategorien Populær under Vigtigste indstillinger for arbejde med Excel, og klik derefter på OK.

  2. Benyt følgende fremgangsmåde, når du vil angive sikkerhedsniveauet midlertidigt for at aktivere alle makroer:

    1. Klik på Makrosikkerhed i gruppen Kode under fanen Udvikler.

      Gruppen Kode under fanen Udvikler

    2. Klik på Aktiver alle koder (anbefales ikke, da potentielt farlig kode kan køres) under Indstillinger for makro, og klik derefter på OK.

      Bemærk: For at forhindre, at der køres potentielt farlig kode, anbefales det, at du vender tilbage til en af de indstillinger, der deaktiverer alle makroer, når du er færdig med at arbejde med makroer.

  3. Klik på Visual Basic i gruppen Kode under fanen Udvikler.

  4. Klik om nødvendigt på Modul i menuen Indsæt i Visual Basic Editor.

    Bemærk: Der oprettes automatisk moduler for alle ark i projektmappen.

  5. Skriv eller kopier den makrokode, du vil bruge, i kodevinduet i modulet.

  6. Hvis du vil køre makroen fra modulvinduet, skal du trykke på F5.

  7. Klik på Luk og vend tilbage til Microsoft Excel i menuen Filer i Visual Basic Editor, når du har skrevet makroen.

Toppen af siden

Kopiere en del af en makro for at oprette en anden makro

  1. Hvis fanen Udvikler ikke er synlig, skal du benytte følgende fremgangsmåde for at få den vist:

    1. Klik på Microsoft Office-knappen Office-knapflade , og klik derefter på Excel-indstillinger.

    2. Marker afkrydsningsfeltet Vis fanen Udvikler på båndet i kategorien Populær under Vigtigste indstillinger for arbejde med Excel, og klik derefter på OK.

  2. Benyt følgende fremgangsmåde, når du vil angive sikkerhedsniveauet midlertidigt for at aktivere alle makroer:

    1. Klik på Makrosikkerhed i gruppen Kode under fanen Udvikler.

      Gruppen Kode under fanen Udvikler

    2. Klik på Aktiver alle koder (anbefales ikke, da potentielt farlig kode kan køres) under Indstillinger for makro, og klik derefter på OK.

      Bemærk: For at forhindre, at der køres potentielt farlig kode, anbefales det, at du vender tilbage til en af de indstillinger, der deaktiverer alle makroer, når du er færdig med at arbejde med makroer.

  3. Åbn den projektmappe, der indeholder den makro, du vil kopiere.

  4. Klik på Makroer i gruppen Kode under fanen Udvikler.

  5. Klik på navnet på den makro, du vil kopiere, i boksen Makronavn.

  6. Klik på Rediger.

  7. Marker de linjer af makroen, du vil kopiere, i kodevinduet i Visual Basic Editor.

Tip: Medtag linjerne Sub og End Sub i det markerede for at kopiere hele makroen.

  1. Klik på Kopier i menuen Rediger.

    Du kan også højreklikke og derefter klikke på Kopier, eller du kan trykke på CTRL+C.

  2. Klik på det modul, hvor du vil placere koden, i boksen Procedure i kodevinduet.

  3. Klik på Sæt ind i menuen Rediger.

    Du kan også højreklikke og derefter klikke på æt ind, eller du kan trykke på CTRL+V.

Tip: Du kan ikke redigere din personlige makroprojektmappefil (Personal.xlsb), da den er en skjult projektmappe, der altid er åben. Du skal først gøre den synlig ved at bruge kommandoen Vis. Du kan også åbne den i Visual Basic Editor ved at trykke på ALT+F11.

Toppen af siden

Tildele en makro et objekt, grafik eller et kontrolelement

  1. Højreklik i et regneark på det objekt, grafik eller kontrolelement, som du vil tildele en eksisterende makro, og klik derefter på Tildel makro.

  2. Klik på den makro, du vil tildele, i feltet Makronavn.

Slette en makro

  1. Benyt en af følgende fremgangsmåder:

    • Åbn den projektmappe, der indeholder makroen, du vil slette.

    • Hvis den makro, du vil slette, er gemt i den personlige makroprojektmappe (Personal.xlsb), og denne projektmappe er skjult, skal du benytte følgende fremgangsmåde for at vise projektmappen:

      1. Klik på Vis under fanen Vis i gruppen Vindue.

      2. Klik på PERSONLIG under Vis projektmappe, og klik derefter på OK.

  2. Hvis fanen Udvikler ikke er synlig, skal du benytte følgende fremgangsmåde for at få den vist:

    1. Klik på Microsoft Office-knappen Office-knapflade , og klik derefter på Excel-indstillinger.

    2. Marker afkrydsningsfeltet Vis fanen Udvikler på båndet i kategorien Populær under Vigtigste indstillinger for arbejde med Excel, og klik derefter på OK.

  3. Klik på Makroer i gruppen Kode under fanen Udvikler.

    Gruppen Kode under fanen Udvikler

  4. Markér den projektmappe, som indeholder den makro, du vil slette, på listen Makroer i. Klik f.eks. på Denne projektmappe.

  5. Klik på navnet på den makro, du ønsker at slette, i boksen Makronavn.

  6. Klik på Slet.

Toppen af siden

Har du et bestemt spørgsmål til en funktion?

Stil et spørgsmål i Excel-community'et

Hjælp os med at forbedre Excel

Har du forslag til, hvordan vi kan forbedre den næste version af Excel? Hvis det er tilfældet, skal du gå til emner i Excel User Voice.

Se også

Hurtig Start: Oprette en makro

Redigere en makro

Afspille en makro

Kopiere et makro-modul til en anden projektmappe

Oversigt over formler i Excel

Sådan undgår du ødelagte formler

Finde og rette fejl i formler

Tastaturgenveje i Excel til Windows

Tastaturgenveje i Excel til Mac

Excel-funktioner (alfabetisk)

Excel-funktioner (efter kategori)

Del Facebook Facebook Twitter Twitter Mail Mail

Var disse oplysninger nyttige?

Fantastisk! Har du mere feedback?

Hvordan kan vi forbedre det?

Tak for din feedback!

×