Introduktion til databeregninger

Du kan bruge formler og funktioner i lister eller biblioteker til at beregne data på en række forskellige måder. Ved at føje en beregnet kolonne til en liste eller et bibliotek kan du oprette en formel, der medtager data fra andre kolonner og udfører funktioner for at beregne datoer og klokkeslæt, for at udføre matematiske ligninger eller for at redigere tekst. På en opgaveliste kan du f.eks. bruge en kolonne til at beregne det antal dage, det tager at udføre de enkelte opgaver, baseret på kolonnerne Startdato og Fuldførelsesdato.

Bemærk: I denne artikel beskrives de grundlæggende begreber i forbindelse med brug af formler og funktioner. Du kan finde specifikke oplysninger om en bestemt funktion i artiklen om den pågældende funktion.

Denne artikel indeholder

Oversigt over formler

Oversigt over funktioner

Brug af kolonnereferencer i en formel

Brug af konstanter i en formel

Brug af beregningsoperatorer i en formel

Oversigt over formler

Formler er ligninger, der udfører beregninger på værdier på en liste eller i et bibliotek. En formel indledes med et lighedstegn (=). Følgende formel ganger f.eks. 2 med 3 og lægger derefter 5 til resultatet.

=5+2*3

Du kan bruge en formel i en beregnet kolonne og til at beregne standardværdier for en kolonne. En formel kan indeholde funktionen, kolonnereferencer, operator og konstant som i følgende eksempel.

=PI()*[Result]^2

Element

Beskrivelse

Funktion

Funktionen PI() returnerer værdien af pi: 3,141592654.

Reference (eller kolonnenavn)

[Resultat] repræsenterer værdien i kolonnen Resultat for den aktuelle række.

Konstant

Tal eller tekstværdier, der er indsat direkte i en formel, f.eks. 2.

Operator

Operatoren ^ (indsætningstegn) opløfter et tal i en potens, og operatoren stjerne (*) multiplicerer.

En formel kan bruge et eller flere af elementerne i tabellen ovenfor. Følgende er eksempler på formler (ordnet efter kompleksitet).

Simple formler (f.eks. =128+345)

Følgende formler indeholder konstanter og operatorer.

Eksempel

Beskrivelse

=128+345

Lægger 128 og 345 sammen

=5^2

Kvadrerer 5

Formler, der indeholder kolonnereferencer (f.eks. =[Indtægt] >[Udgift])

Følgende formel refererer til andre kolonner på samme liste eller i samme bibliotek.

Eksempel

Beskrivelse

=[Indtægt]

Bruger værdien i kolonnen Indtægt.

=[Indtægt]*10/100

10 % af værdien i kolonnen Indtægt.

=[Indtægt] > [Udgift]

Returnerer Ja, hvis værdien i kolonnen Indtægt er større end værdien i kolonnen Udgift.

Formler, der kalder funktioner (f.eks. =MIDDEL(1; 2; 3; 4; 5))

Følgende formler kalder indbyggede funktioner.

Eksempel

Beskrivelse

=MIDDEL(1; 2; 3; 4; 5)

Returnerer gennemsnittet af et værdisæt.

=MAKS(K1; K2; K3; K4)

Returnerer den største værdi i et værdisæt.

=HVIS([Udgift]>[Indtægt], "Ikke OK"; "OK")

Returnerer Ikke OK, hvis udgift er større end indtægt. Ellers returneres OK.

=DAG("15-apr-2008")

Returnerer dagen i en dato. Denne formel returnerer tallet 15.

Formler med indlejrede funktioner (f.eks. =SUM(HVIS([A]>[B]; [A]-[B]; 10); [C]))

I følgende formler angives en eller flere funktioner som funktionsargumenter.

Eksempel

Beskrivelse

=SUM(HVIS([A]>[B]; [A]-[B]; 10); [C])

Funktionen HVIS returnerer forskellen mellem værdierne i kolonne A og B eller 10.

Funktionen SUM lægger returværdien af funktionen HVIS til værdien i kolonne C.

=GRADER(PI())

Funktionen PI returnerer tallet 3,141592654.

Funktionen GRADER konverterer en værdi, der er angivet i radianer, til grader. Denne formel returnerer værdien 180.

=ER.TAL(FIND("BD",[Kolonne1]))

Funktionen FIND søger efter strengen BD i Kolonne1 og returnerer strengens startposition. Der returneres en fejlværdi, hvis strengen ikke findes.

Funktionen ER.TAL returnerer Ja, hvis funktionen FIND har returneret en numerisk værdi. Ellers returneres Nej.

Toppen af siden

Oversigt over funktioner

Funktioner er foruddefinerede formler, der foretager beregninger ved hjælp af bestemte værdier, kaldet argumenter, i en bestemt rækkefølge, også kaldet syntaks. Funktioner kan bruges til at foretage simple eller avancerede beregninger. Følgende forekomst af funktionen AFRUND afrunder f.eks. et tal i kolonnen Udgift til to decimaler.

=ROUND([Cost], 2)

Det er nyttigt at kende følgende termer, når du er ved at lære om funktioner og formler:

Struktur     En funktions struktur begynder med et lighedstegn (=) efterfulgt af funktionsnavnet, en venstreparentes og argumenterne for funktionen adskilt med semikoloner og afsluttes med en højreparentes.

Funktionsnavn     Dette er navnet på en funktion, som understøttes af lister eller biblioteker. Hver funktion tager et bestemt antal argumenter, behandler dem og returnerer en værdi.

Argumenter     Argumenter kan være tal, tekst, logiske værdier som f.eks. Sand eller Falsk eller kolonnereferencer. Det argument, du angiver, skal frembringe en gyldig værdi for argumentet. Argumenter kan også være konstanter, formler eller andre funktioner.

I visse tilfælde kan du få brug for at anvende en funktion som argument i en anden funktion. I følgende formel bruges f.eks. en indlejret MIDDEL-funktion til at sammenligne resultatet med summen af to kolonneværdier.

=AVERAGE([Cost1], SUM([Cost2]+[Discount]))

Gyldige returværdier     Når en funktion bruges som argument, skal den returnere samme type værdi, som argumentet benytter. Hvis argumentet f.eks. bruger Ja eller Nej, skal den indlejrede funktion returnere værdien Ja eller Nej. Ellers vises fejlværdien #VÆRDI! på listen.

Niveaugrænse for indlejring     En formel kan indeholde op til otte niveauer af indlejrede funktioner. Hvis funktion B bruges som argument i funktion A, er funktion B indlejret på andet niveau. I eksemplet ovenfor er funktionen SUM f.eks. indlejret på det andet niveau, fordi den er argument i funktionen MIDDEL. Hvis en funktion er indlejret i funktionen SUM, er den på tredje niveau osv.

Bemærkninger: 

  • Lister og biblioteker understøtter ikke funktionerne SLUMP og NU.

  • Funktionerne IDAG og MIG understøttes ikke i beregnede kolonner, men de understøttes som standardværdi i en kolonne.

Toppen af siden

Brug af kolonnereferencer i en formel

En reference identificerer en celle i den aktuelle række og angiver over for listen eller biblioteket, hvor der skal søges efter de værdier eller data, du vil bruge i en formel. [Udgift] refererer f.eks. til værdien i kolonnen Udgift i den aktuelle række. Hvis kolonnen Udgift har værdien 100 for den aktuelle række, returnerer =[Udgift]*3 300.

Med referencer kan du bruge de data, der er indeholdt i forskellige kolonner på en liste eller i et bibliotek i en eller flere formler. Der kan refereres til kolonner af følgende datatyper i en formel: enkelt tekstlinje, tal, valuta, dato og klokkeslæt, valg, ja/nej og beregnet.

Du kan referere til kolonnens viste navn i en formel. Hvis navnet indeholder mellemrum eller specialtegn, skal du indsætte navnet i firkantede parenteser ([ ]). Der skelnes ikke mellem store og små bogstaver i referencer. Du kan f.eks. referere til kolonnen Enhedspris med [Enhedspris] eller [enhedspris].

Bemærkninger: 

  • Du kan ikke referere til en værdi i en anden række end den aktuelle række.

  • Du kan ikke referere til en værdi på en anden liste eller i et andet bibliotek.

  • Du kan ikke referere til id for en række, der netop er indsat. Id'et findes endnu ikke, når beregningen udføres.

  • Du kan ikke referere til en anden kolonne, der opretter en standardværdi for en kolonne.

Toppen af siden

Brug af konstanter i en formel

En konstant er en værdi, der ikke beregnes. Datoen 10-09-2008, tallet 210 og teksten "Kvartalsvis omsætning" er alle konstanter. Konstanter kan være af følgende datatyper:

  • Streng (eksempel: =[Efternavn] = "Smith")

    Strengkonstanter er omgivet af anførselstegn og kan indeholde op til 255 tegn.

  • Tal (eksempel: =[Udgift] >= 29,99)

    Numeriske konstanter kan indeholde decimaler og kan være positive eller negative.

  • Dato (eksempel: =[Dato] > DATO(2007;7;1))

    Datokonstanter kræver brug af funktionen DATO(år;måned;dag).

  • Boolesk (eksempel: =HVIS([Udgift]>[Indtægt]; "Tab"; "Intet tab")

    Ja og Nej er booleske konstanter. Du kan bruge dem i betingede udtryk. Hvis Udgift f.eks. er større end Indtægt i ovenstående eksempel, returnerer funktionen HVIS resultatet Ja, og formlen returnerer strengen "Tab". Hvis Udgift er mindre end eller lig med Indtægt, returnerer funktionen resultatet Nej, og formlen returnerer strengen "Intet tab".

Toppen af siden

Brug af beregningsoperatorer i en formel

Operatorer angiver den type beregning, du vil udføre på elementerne i en formel. Lister og biblioteker understøtter tre forskellige typer beregningsoperatorer: matematiske operatorer, sammenligningsoperatorer og tekstoperatorer.

Matematiske operatorer

Brug følgende matematiske operatorer til at udføre grundlæggende matematiske funktioner, f.eks. addition, subtraktion eller multiplikation, for at kombinere tal eller producere numeriske resultater.

Matematisk operator

Betydning (eksempel)

+ (plustegn)

Addition (3+3)

– (minustegn)

Subtraktion (3–1)
Negation (–1)

* (stjerne)

Multiplikation (3*3)

/ (skråstreg)

Division (3/3)

% (procenttegn)

Procent (20 %)

^ (indsætningstegn)

Eksponering (3^2)

Sammenligningsoperatorer

Du kan sammenligne to værdier med følgende operatorer. Når to værdier sammenlignes ved brug af disse operatorer, er resultatet en logisk værdi, enten Ja eller Nej.

Sammenligningsoperator

Betydning (eksempel)

= (lighedstegn)

Lig med (A=B)

> (større end-tegn)

Større end (A>B)

< (mindre end-tegn)

Mindre end (A<B)

>= (tegnet større end eller lig med)

Større end eller lig med (A>=B)

<= (tegnet mindre end eller lig med)

Mindre end eller lig med (A<=B)

<> (tegnet forskellig fra)

Forskellig fra (A<>B)

Tekstoperator

Brug &-tegnet, hvis du vil sammenkæde eller sammenføje en eller flere tekststrenge, så de frembringer én tekstværdi.

Tekstoperator

Betydning (eksempel)

& (ampersand)

Forbinder, eller sammenføjer, to værdier og fremstiller en sammenhængende tekstværdi ("Norden"&"vind")

Rækkefølge, som en liste eller et bibliotek udfører funktioner i en formel i

I formler beregnes værdier i en bestemt rækkefølge. En formel kan f.eks. begynde med et lighedstegn (=). Efter lighedstegnet kommer de elementer, der skal beregnes (operander), og som er adskilt af beregningsoperatorer. På lister og i biblioteker beregnes en formel fra venstre mod højre i overensstemmelse med en bestemt rækkefølge for hver operator i formlen.

Rækkefølgen af operatorer

Hvis du kombinerer flere operatorer i en enkelt formel, udfører lister og biblioteker funktionerne i den rækkefølge, der vises i følgende tabel. Hvis en formel indeholder operatorer med samme placering i rækkefølgen, f.eks. hvis en formel indeholder både en multiplikationsoperator og en divisionsoperator, evalueres operatorerne fra venstre mod højre.

Operator

Beskrivelse

Negation (f.eks. –1)

%

Procent

^

Eksponering

* og /

Multiplikation og division

+ og –

Addition og subtraktion

&

Sammenkædning (forbinder to tekststrenge)

= < > <= >= <>

Sammenligning

Brug af parenteser

Hvis du vil ændre evalueringsrækkefølgen, skal du indsætte den del af formlen, som skal beregnes først, i parenteser. Følgende formel giver f.eks. resultatet 11, fordi en liste eller et bibliotek udregner multiplikationen før additionen. I formlen ganges 2 med 3, og derefter lægges der 5 til resultatet.

=5+2*3

Hvis du bruger parenteser til at ændre syntaksen, lægger listen eller biblioteket 5 og 2 sammen og ganger derefter resultatet med 3, hvilket giver 21.

=(5+2)*3

I eksemplet nedenfor tvinger parenteserne omkring den første del af formlen listen eller biblioteket til at beregne [Udgift]+25 først og derefter dividere resultatet med summen af værdierne i kolonne EC1 og EC2.

=([Cost]+25)/SUM([EC1]+[EC2])

Toppen af siden

Del Facebook Facebook Twitter Twitter Mail Mail

Var disse oplysninger nyttige?

Fantastisk! Har du mere feedback?

Hvordan kan vi forbedre det?

Tak for din feedback!

×