Hente data fra Analysis Services

Vigtigt: Denne artikel er maskinoversat. Se ansvarsfraskrivelsen. Du kan finde den engelske version af denne artikel her til din orientering.

Analysis Services giver dig dimensionelle data, der egner sig godt til undersøgelse af data i pivottabeller og Power View-rapporter. Du kan hente Analysis Services-data fra:

  • OLAP-kuber på en flerdimensional Analysis Services-server.

  • Tabelmodeller på en Analysis Services tabelserver.

  • Excel-projektmapper i SharePoint 2010 eller nyere, hvis projektmappen indeholder en datamodel.

Du kan analysere data fra en ekstern Analysis Services-datakilde vha. en onlineforbindelse. Efterhånden som du pivoterer, inddeler og filtrerer en rapport, sender Excel forespørgsler til Analysis Services efter de data, du beder om. Analyse af data på denne måde kræver en onlineforbindelse til datakilden.

En anden tilgang er at arbejde offline. Du kan arbejde offline ved at importere data til projektmappen, så både data- og rapportvisualiseringer er selvstændige og kan flyttes i en enkelt fil. Hvis du importerer data, skal du vide, at dette medfører nye krav, herunder tilføjelsesprogrammet Power Pivot, et vist kendskab til MDX-og tilstrækkelig diskplads til at lagre større projektmapper. Denne artikel beskriver, hvordan du importerer data fra forskellige Analysis Services-datakilder.

Excel-projektmapper, du gemmer på SharePoint eller Office 365 er underlagt en maksimale filstørrelse. Ved hjælp af guiden Import af tabel i tilføjelsesprogrammet Power Pivot, kan du selektivt importere tabeller, kolonner og rækker for at reducere overordnede filstørrelse. Hvis din projektmappe er for stor til at få vist i Excel Online, kan du i stedet åbne den i Excel.

Office 365 forhindrer dataopdatering mod eksterne datakilder, herunder Analysis Services-løsninger, der kører på servere i et netværk. Hvis dine behov omfatter data, der skal opdateres, skal du vælge SharePoint eller bruge en netværksfildeling i stedet.

Denne artikel indeholder

Forudsætninger

Oprette forbindelse til en kube, tabelmodel eller Power Pivot-datamodel

Importere data fra en kube

Importere data fra en tabelmodel

Importere data fra en projektmappedatamodel på SharePoint

Opdatere data fra en ekstern Analysis Services-database

Forudsætninger

Analysis Services-kuber skal være version SQL Server 2005 eller nyere.

Analysis Services tabelmodeldatabaser findes kun i SQL Server 2012 eller nyere.

Du skal vide, hvordan du opretter forbindelse til en Analysis Services-database. Spørg din Analysis Services-database administrator for at afgøre, hvilke server- og databasenavne og hvilke legitimationsoplysninger, du skal bruge.

For at importere data til en datamodel, skal du have Power Pivot, som følger med Office Professional Plus. Du har muligvis også brug for at vide, hvordan du skal skrive en MDX-forespørgsel, der henter de data, du vil bruge. Alternativer til at skrive en MDX-forespørgsel omfatter brug af en forespørgselsgenerator til at vælge, hvilke målinger, dimensionsattributter og hierarkier du vil analysere.

For at oprette forbindelse til en pivottabel eller et pivotdiagram interaktivt via Excel er kendskab til MDX ikke påkrævet. Excel opretter forbindelse til en hel OLAP-kube eller en tabelmodel.

Filstørrelser bliver større end det, du måske er vant til. Til sammenligning kan en projektmappe, der anvendes med en dataforbindelse, nemt falde under 100 kilobyte, hvorimod den samme projektmappe med importerede data kan være 10 gange større. Hvis diskplads er et problem, skal du lave plads til større filer.

Power Pivot projektmapper, der bruges som datakilder kan publiceres til SharePoint 2010 eller nyere. SharePoint-webstedet skal køre på en anden computer end det, du bruger til at oprette en rapport. Du skal have Vis tilladelser på SharePoint-webstedet kan rapportere med projektmapper på SharePoint.

Oprette forbindelse til en kube, tabelmodel eller Power Pivot-datamodel

Den nemmeste måde at analysere data i en Analysis Services-kube eller model er at konfigurere en forbindelse til en ekstern database. Pivottabellen eller rapporten har en direkte forbindelse til datakilden. Hver gang, du trækker et felt over områderne Værdier, Rækker, Kolonner eller Filtre i en Feltliste, opretter Excel en forespørgsel og sender den til Analysis Services.

Der har sine fordele at have en direkte forbindelse til de data, du analyserer. Du kan udføre en frihåndsanalyse. Tilføj et felt til en pivottabel eller rapport, og Analysis Services giver tilbage de data, du har anmodet om. En feltliste, der knyttes til Analysis Services, indeholder alle objekterne i en kube eller model, så du ikke behøver at skrive MDX for at få de ønskede data.

Ulemperne omfatter afhængighed af en serverforbindelse. Hvis serveren går ned, eller du vil arbejde offline, stopper datainteraktionenhelt.

Toppen af siden

Importere data fra en kube

Data, der er indeholdt i en SQL Server Analysis Services-database, kan kopieres til en datamodel i Excel. Du kan udtrække hele eller dele af en dimension eller få slicere eller sammenlægninger fra kuben. Det kan f.eks. være sum for salg måned for måned for det aktuelle år.

Følgende procedure viser, hvordan du bruger tilføjelsesprogrammet og MDX til at hente et undersæt af data fra en traditionel kube på en Analysis Service-forekomst. MDX-altid bruges når du opretter en forespørgsel med Power Pivot-tilføjelsesprogrammet.

Denne procedure bruger Adventure Works DW Multidimensional 2012-eksempeldatabasen til at forklare, hvordan en delmængde af en kube importeres. Hvis du har adgang til en Analysis Services-server, der har AdventureWorks DW Multidimensional 2012-eksempeldatabasen, kan du følge disse trin for at lære, hvordan data importeres fra Analysis Services.

  1. Klik på Hent eksterne data > Fra database > Fra Analysis Services eller Power Pivot i Power Pivot vinduet.

  2. I Oprette forbindelse til Microsoft SQL Server Analysis Services, i Server- eller Filnavn, skal du skrive navnet på den computer, der kører Analysis Services.

  3. Klik på pil ned til højre for listen Databasenavn, og vælg en Analysis Services-database på listen. Hvis du f.eks. har adgang til Adventure Works DW Multidimensional 2012-eksempeldatabasen, skal du vælge Adventure Works DW Multidimensional 2012.

  4. Klik på Test forbindelse for at kontrollere, at Analysis Services-serveren er tilgængelig.

  5. Klik på Næste.

  6. Klik på Design på siden Angiv en MDX-forespørgsel for at åbne en MDX-forespørgselsgenerator.

    I dette trin trækker du alle målinger, dimensionsattributter, hierarkier og beregnede medlemmer, som du vil importere, til det store forespørgselsdesignområde.

    Vælg mindst ét mål og en eller flere dimensioner.

    Hvis du har en eksisterende MDX-sætning, du vil bruge, kan du sætte sætningen inden i tekstfeltet og klikke på Valider for at sikre, at den pågældende sætning virker. Du kan finde flere oplysninger, hvordan du bruger designeren under MDX-forespørgselsdesigner til Analysis Services (Power Pivot).

    Benyt følgende fremgangsmåde for denne procedure, og brug Adventure Works-eksempelkuben:

    1. Udvid Målinger i ruden Metadata, og udvid derefter Salgsoversigt.

    2. Træk Gennemsnitligt salgsbeløb til den store designrude.

    3. Udvid dimensionen Produkt i ruden Metadata.

    4. Træk Produktkategorier til venstre for Gennemsnitligt salgsbeløb i det store designområde.

    5. Udvid dimensionen dato i ruden Metadata, og udvid derefter kalender.

    6. Træk Dato.kalenderår til venstre for kategori i det store designområde.

    7. Du kan også tilføje et filter for at importere et undersæt af dataene. I ruden øverst til højre i designvisningen for Dimension, træk dato til dimensionsfeltet. I hierarkiet, Vælg Dato.kalenderår. operatoren, vælge Ikke lig med. Klik på pil ned for Filterudtrykket, og Vælg kalenderår 2009 og kalenderår 2010.

      Dermed oprettes et filter på kuben, så værdierne for 2009 ikke medtages.

  7. Klik på OK, og gennemgå den MDX-forespørgsel, der blev oprettet af forespørgselsdesigneren.

  8. Skriv det fulde navn på datasættet. Dette navn bruges som tabelnavnet i datamodellen. Hvis du ikke tildeler et nyt navn, gemmes resultaterne af forespørgslerne som standard i en ny tabel, der kaldes Forespørgsel.

  9. Klik på Udfør.

  10. Når indlæsningen af dataene er afsluttet, skal du klikke på Luk.

Alle de data, du importerer fra en kube-database, er komprimerede. I din model vises data som en enkelt tabel, der indeholder alle de kolonner, du angav i din forespørgsel. Hvis du definerer en forespørgsel, der henter målinger fra flere dimensioner, importeres dataene med hver enkelt dimension i en separat kolonne.

Når du importerer data på datamodellen kan du kontrollere datatypen i kolonner, der indeholder numeriske eller finansielle data. Hvis Power Pivot finder tomme værdier i en kolonne, ændres datatypen til tekst. Du kan kontrollere og ændre datatypen ved at vælge hver kolonne og visning af Datatype i gruppen Formatering på båndet. Du kan bruge datatype-funktionen til at korrigere datatypen, hvis dine numeriske eller finansielle data er tildelt den forkerte type.

Så du kan bruge dataene i en pivottabel, skal du skifte tilbage til Excel:

  1. Klik på Indsæt > Tabel > Pivottabel.

  2. Klik på Brug en ekstern datakilder, og klik på Vælg forbindelser.

  3. Klik på Tabeller.

  4. I Denne projektmappes datamodel skal du vælge den tabel, du lige har importeret.

Toppen af siden

Importere data fra en tabelmodel

Følgende procedure beskriver dataimport med den tabelopdelte eksempeldatabase som eksempel. Du kan bruge eksempeldataene, Adventure Works Tabular Model SQL 2012, som kører på en Analysis Services tabelserver, til at følge med.

  1. Kontrollér, at tabeldatabasen indeholder mindst ét mål. Importen vil mislykkes, hvis databasen mangler målinger. Hvis du bruger prøveløsningen, inkluderer denne målinger.

  2. Klik på Hent eksterne data > Fra database > Fra Analysis Services eller Power Pivot i Power Pivot vinduet.

  3. I Oprette forbindelse til Microsoft SQL Server Analysis Services, i Server- eller Filnavn, skal du skrive navnet på den computer, der kører Analysis Services.

  4. Klik på pil ned til højre for listen Databasenavn, og vælg en Analysis Services-database på listen. Hvis du f.eks. har adgang til AW Internetsalg tabelmodeleksempeldatabasen, skal du vælge Adventure Works Tabular Model SQL 2012

  5. Klik på Test forbindelse for at kontrollere, at Analysis Services-serveren er tilgængelig.

  6. Klik på Næste.

  7. Klik på Design på siden Angiv en MDX-forespørgsel for at åbne en MDX-forespørgselsgenerator.

    I dette trin trækker du alle målinger, kolonner og hierarkier, som du vil importere, til det store forespørgselsdesignområde.

    Hvis du har en eksisterende MDX-sætning, du vil bruge, kan du sætte sætningen inden i tekstfeltet og klikke på Valider for at sikre, at den pågældende sætning virker. Se MDX-forespørgselsdesigner til Analysis Services (Power Pivot) for flere oplysninger om designeren.

    Benyt følgende fremgangsmåde for denne procedure, og brug Adventure Works-eksempelkuben:

    1. Udvid Målinger i ruden Metadata, og udvid derefter Internetsalg.

    2. Træk Samlet internetsalg til den store designrude.

    3. Udvid Produkt-tabellen.

    4. Rul til bunden af listen, og træk kategori til venstre for Internet samlet salg i det store designområde. Dette er et hierarki, så den returnerer alle felterne i hierarkiet.

    5. Udvid tabellen Dato.

    6. Træk dato.kalenderår til venstre for kategori i det store designområde.

    7. Udvid Salgsdistrikt.

    8. Træk Salgsdistrikt område til filteret område øverst i designeren. I udtrykket Filter, skal du vælge Australien.

      MDX-forespørgsel til at prøve tabeldatabase

  8. Klik på OK, og gennemgå den MDX-forespørgsel, der blev oprettet af forespørgselsdesigneren.

  9. Skriv det fulde navn på datasættet. Dette navn bruges som tabelnavnet i datamodellen. Hvis du ikke tildeler et nyt navn, gemmes resultaterne af forespørgslerne som standard i en ny tabel, der kaldes Forespørgsel.

  10. Klik på Udfør.

  11. Når indlæsningen af dataene er afsluttet, skal du klikke på Luk.

Når du importerer data på datamodellen kan du kontrollere datatypen i kolonner, der indeholder numeriske eller finansielle data. Hvis Power Pivot finder tomme værdier i en kolonne, ændres datatypen til tekst. Du kan kontrollere og ændre datatypen ved at vælge hver kolonne og visning af Datatype i gruppen Formatering på båndet. Du kan bruge datatype-funktionen til at korrigere datatypen, hvis dine numeriske eller finansielle data er tildelt den forkerte type.

Så du kan bruge dataene i en pivottabel, skal du skifte tilbage til Excel:

  1. Klik på Indsæt > Tabel > Pivottabel.

  2. Klik på Brug en ekstern datakilder, og klik på Vælg forbindelser.

  3. Klik på Tabeller.

  4. I Denne projektmappes datamodel skal du vælge den tabel, du lige har importeret.

Toppen af siden

Importere data fra en projektmappedatamodel på SharePoint

SharePoint muligvis yderligere software til at indlæse dataene. Hvis du bruger SharePoint 2010, skal du have Power Pivot til SharePoint 2010. I modsætning indeholder SharePoint 2013 eller nyere indbyggede muligheder for at indlæse og forespørgsler en datamodel. Hvis du bruger SharePoint skal du bede administratoren af SharePoint, om Excel Services er aktiveret og konfigureret til BI arbejdsbelastninger.

  1. Klik på Hent eksterne data > Fra database > Fra Analysis Services eller Power Pivot i Power Pivot vinduet.

  2. Skriv et beskrivende navn til dataforbindelsen for Fuldt forbindelsesnavn i Oprette forbindelse til Microsoft SQL Server Analysis Services. Med beskrivende navne for forbindelsen kan du lettere huske, hvordan den bruges.

  3. Skriv webadressen for den publicerede .xlsx-fil i Server- eller filnavn. F.eks. http://Contoso-srv/Shared Documents/ContosoSales.xlsx.

    Bemærk: Du kan ikke bruge en lokal Excel-projektmappe som datakilde. Projektmappen skal have været publiceret på et Sharepoint-websted.

  4. Klik på Test forbindelse for at kontrollere, at projektmappen er tilgængelig på SharePoint.

  5. Klik på Næste.

  6. Klik på Design.

  7. Opret forespørgslen ved at trække målinger, dimensionsattributter eller hierarkier til det store designområde. Du kan også bruge filterruden i øverste højre hjørne til at vælge en delmængde af data til importen.

  8. Klik på OK.

  9. Klik på Valider.

  10. Klik på Udfør.

Power Pivot-data kopieres til datamodellen og gemmes i et komprimeret format. Når dataene er importeret, lukkes forbindelsen til projektmappen. Hvis du vil forespørge de oprindelige data igen, kan du opdatere projektmappen i Excel.

Toppen af siden

Opdatere data fra en ekstern Analysis Services-database

Klik på Data > Forbindelser > Opdater alt i Excel for at genoprette forbindelse til en Analysis Services-database og opdatere dataene i din projektmappe.

Opdateringen opdaterer de enkelte celler og tilføjer eventuelle nye rækker, der er tilføjet i den eksterne database siden den seneste import. Det er kun rækker og eksisterende kolonner, der opdateres. Hvis du vil tilføje en ny kolonne i modellen, skal du importere den ved hjælp af de trin, der blev beskrevet tidligere i denne artikel.

Opdateringen kører den forespørgsel, der oprindeligt blev brugt til at importere dataene. Hvis datakilden ikke længere findes på den samme placering, eller hvis tabeller eller kolonner er blevet fjernet eller omdøbt, kan opdateringen ikke fuldføres. Du vil stadig have de data, som du importerede tidligere. Hvis du vil se den forespørgsel, der er blevet brugt under dataopdateringen, skal du klikke på Power Pivot > Administrer for at åbne Power Pivot-vinduet. Klik på Design > Egenskaber for tabel for at se forespørgslen.

Analysis Services anvender din Windows-brugerkonto til at læse data fra sine databaser. Før du kunne importere data, var en databaseadministrator nødt til at give din Windows-brugerkonto læsetilladelser til databasen. Disse samme tilladelser bruges også til at opdatere data. Hvis andre vil opdatere dataene, skal de også have læsetilladelser til databasen.

Husk på, hvordan du dele din projektmappe der bestemmer, om opdatering af data kan forekomme. I Office 365, kan du opdatere data i en projektmappe, der er gemt på Office 365. På SharePoint Server 2013 eller nyere, kan du planlægge automatiske dataopdatering på serveren, men at gøre dette kræver, Power Pivot til SharePoint er installeret og konfigureret i dit SharePoint-miljø. Spørg administratoren af SharePoint til at finde ud af, om planlagt dataopdatering er tilgængelig.

Toppen af siden

Bemærk: Ansvarsfraskrivelse for maskinoversættelse: Denne artikel er blevet oversat af et computersystem uden menneskelig indgriben. Microsoft tilbyder disse maskinoversættelse for at hjælpe ikke-engelsktalende brugere til at kunne nyde indhold om Microsofts produkter, tjenester og teknologier. Da artiklen er maskinoversat, kan den indeholde forkerte ord eller syntaks- eller grammatikfejl.

Del Facebook Facebook Twitter Twitter Mail Mail

Var disse oplysninger nyttige?

Fantastisk! Har du mere feedback?

Hvordan kan vi forbedre det?

Tak for din feedback!

×