Funktionen TÆL.HVIS

I denne artikel beskrives formelsyntaksen for og brugen af funktionenTÆL.HVIS i Microsoft Office Excel.

Beskrivelse

Funktionen TÆL.HVIS tæller det antal celler i et område, der opfylder et enkelt kriterium, du angiver. Du kan f.eks. tælle alle de celler, der starter med et bestemt bogstav, eller du kan tælle alle de celler, der indeholder et tal, der er større eller mindre end et tal, du angiver. Antag f.eks., at du har et regneark, der indeholder en liste over opgaver i kolonne A, og fornavnet på de personer, der er tildelt til de enkelte opgaver, i kolonne B. Du kan bruge funktionen TÆL.HVIS til at tælle, hvor mange gange en persons navn vises i kolonne B, og på den måde bestemme, hvor mange opgaver der er tildelt til den pågældende person, f.eks.:

=TÆL.HVIS(B2:B25;"Nancy")

Bemærk   Hvis du vil tælle celler på basis af flere kriterier, skal du se Funktionen TÆL.HVISER.

Syntaks

TÆL.HVIS(område; kriterier)

Syntaksen for funktionen TÆL.HVIS har følgende argument:

  • område    Påkrævet. En eller flere celler, der skal tælles, herunder tal eller navne, matrixer eller referencer, der indeholder tal. Tomme celler og tekstværdier ignoreres

  • kriterier    Påkrævet. Et tal, et udtryk, en cellereference eller en tekststreng, som definerer, hvilke celler der skal tælles. Kriterier kan f.eks. udtrykkes som 32, ">32", B4, "æbler" eller "32".

    Bemærk   

    • Du kan bruge jokertegnene – spørgsmålstegn (?) og stjerne (*) – i kriterier. Et spørgsmålstegn repræsenterer et vilkårligt enkelttegn, og en stjerne repræsenterer en vilkårlig tegnsekvens. Hvis du vil søge efter et spørgsmålstegn eller en stjerne i selve teksten, skal du angive en tilde (~) foran tegnet.

    • Der skelnes ikke mellem store og små bogstaver i kriterier. Strengen "æbler" og strengen "ÆBLER" matcher f.eks. de samme celler.

Eksempel 1: Almindelige TÆL.HVIS-formler

Det kan være lettere at forstå eksemplet, hvis du kopierer det til et tomt regneark.

Hvordan kan et eksempel kopieres?

  1. Markér eksemplet i denne artikel. Hvis du kopierer eksemplet i Excel Online, skal du kopiere og indsætte én celle ad gangen.
    Important: Markér ikke række‑ eller kolonneoverskrifter.

    Markere et eksempel i Hjælp

  2. Tryk på Ctrl+C.

  3. Opret en tom projektmappe eller et tomt regneark.

  4. Markér celle A1 i regnearket, og tryk på Ctrl+V. Hvis du arbejder i Excel Online, skal du kopiere og indsætte hver enkelt celle i eksemplet.
    Important: Hvis eksemplet skal fungere korrekt, skal du indsætte det i celle A1 i regnearket.

  5. Hvis du vil skifte mellem visning af resultaterne og visning af de formler, der returnerer resultaterne, skal du trykke på Ctrl+` (accent grave) eller klikke på knappen Vis formler i gruppen Formelrevision under fanen Formler.

Når du har kopieret eksemplet til et tomt regneark, kan du tilpasse det til dine behov.

1

2

3

4

5

6


7


8


9



10


11




12

A

B

C

Data

Data

æbler

32

appelsiner

54

ferskner

75

æbler

86

Formel

Beskrivelse

Resultat

=TÆL.HVIS(A2:A5;"æbler")

Antal celler med æbler i cellerne A2 til og med A5.

2

=TÆL.HVIS(A2:A5;A4)

Antal celler med ferskner i cellerne A2 til og med A5.

1

=TÆL.HVIS(A2:A5;A3)+TÆL.HVIS(A2:A5;A2)

Antal celler med appelsiner og æbler i cellerne A2 til og med A5.

3

=TÆL.HVIS(B2:B5;">55")

Antal celler med en højere værdi end 55 i cellerne B2 til og med B5.

2

=TÆL.HVIS(B2:B5;"<>"&B4)

Antal celler med en værdi, der er forskellig fra 75, i cellerne B2 til og med B5.

3

=TÆL.HVIS(B2:B5;">=32")-TÆL.HVIS(B2:B5;">85")

Antal celler med en værdi, der er større end eller lig med 32 og mindre end eller lig med 85 i cellerne B2 til og med B5.

3

Eksempel 2: TÆL.HVIS-formler med jokertegn og håndtering af tomme værdier

Det kan være lettere at forstå eksemplet, hvis du kopierer det til et tomt regneark.

Hvordan kan et eksempel kopieres?

  1. Markér eksemplet i denne artikel. Hvis du kopierer eksemplet i Excel Online, skal du kopiere og indsætte én celle ad gangen.
    Important: Markér ikke række‑ eller kolonneoverskrifter.

    Markere et eksempel i Hjælp

  2. Tryk på Ctrl+C.

  3. Opret en tom projektmappe eller et tomt regneark.

  4. Markér celle A1 i regnearket, og tryk på Ctrl+V. Hvis du arbejder i Excel Online, skal du kopiere og indsætte hver enkelt celle i eksemplet.
    Important: Hvis eksemplet skal fungere korrekt, skal du indsætte det i celle A1 i regnearket.

  5. Hvis du vil skifte mellem visning af resultaterne og visning af de formler, der returnerer resultaterne, skal du trykke på Ctrl+` (accent grave) eller klikke på knappen Vis formler i gruppen Formelrevision under fanen Formler.

Når du har kopieret eksemplet til et tomt regneark, kan du tilpasse det til dine behov.

1

2

3

4

5

6

7

8




9






10




11



12





13





14

A

B

C

Data

Data

æbler

Ja

appelsiner

NEJ

ferskner

Nej

æbler

ja

Formel

Beskrivelse

Resultat

=TÆL.HVIS(A2:A7;"<>"&"*")

Antal celler, der slutter med bogstaverne "er" i cellerne A2 til og med A7.

4

=TÆL.HVIS(A2:A7;"?????er")=

Antal celler, der slutter med bogstaverne "er" og har nøjagtigt syv bogstaver i cellerne A2 til og med A7.

2

=TÆL.HVIS(A2:A7;"*")=

Antal celler, der ikke indeholder tekst i cellerne A2 til og med A7.

4

=TÆL.HVIS(A2:A7;"<>"&"*")

Antal celler, der indeholder tekst i cellerne A2 til og med A7.

2

=TÆL.HVIS(B2:B7;"Nej") / RÆKKER(B2:B7)

Det gennemsnitlige antal Nej-stemmer inklusive tomme celler i cellerne B2 til og med B7.

0,333333333

=TÆL.HVIS(B2:B7;"Ja") / (RÆKKER(B2:B7) -TÆL.HVIS(B2:B7;"<>"&"*"))

Det gennemsnitlige antal Ja-stemmer eksklusive tomme celler i cellerne B2 til og med B7.

0,5

Bemærk    Hvis du vil have vist tallet som en procentsats, skal du markere cellen, og klikke på Procentsatstypografi i gruppen Tal under fanen Ark .

Gælder: Excel 2007



Var disse oplysninger nyttige?

Ja Nej

Hvordan kan vi forbedre det?

255 tegn tilbage

Inkluder ikke kontaktoplysninger i din feedback for at beskytte dine personlige oplysninger. Gennemse vores erklæring om beskyttelse af personlige oplysninger.

Tak for din feedback!

Supportressourcer

Skift sprog