Funktionen OG

Vigtigt: Denne artikel er maskinoversat. Se ansvarsfraskrivelsen. Du kan finde den engelske version af denne artikel her til din orientering.

Brug funktionen OG, én af de logiske funktioner,til at bestemme, om alle tilstande i en test er SANDE.

Eksempel

Eksempler på funktionen OG

Funktionen OG returnerer SAND, hvis alle argumenterne evalueres til SAND og returnerer FALSK, hvis ét eller flere argumenter evalueres til FALSK.

Funktionen OG bruges ofte til at udvide anvendeligheden af andre funktioner, der udfører logiske test. Funktionen HVIS udfører f.eks. en logisk test og returnerer derefter én værdi, hvis testen evalueres til SAND, og en anden værdi, hvis testen evalueres til FALSK. Ved at bruge funktionen OG som logisk_test-argument for funktionen HVIS kan du teste mange forskellige betingelser i stedet for blot én.

Syntaks

OG(logisk1, [logisk2], ...)

Syntaksen for funktionen OG har følgende argumenter:

Argument

Beskrivelse

Logisk1

Obligatorisk. Den første tilstand, du vil teste, der kan evalueres til enten SAND eller FALSK.

Logisk2, ...

Valgfrit. Yderligere tilstande, du vil teste, der kan evalueres til enten SAND eller FALSK, op til maksimalt 255 tilstande.

Bemærkninger

  • Argumenterne skal evalueres til logiske værdier, f.eks. SAND eller FALSK, eller de skal være matrixer eller referencer, der indeholder logiske værdier.

  • Hvis et matrix- eller referenceargument indeholder tekst eller tomme celler, ignoreres disse værdier.

  • Hvis det angivne område ikke indeholder logiske værdier, returnerer OG fejlværdien #VALUE!.

Eksempler

Her er nogle generelle eksempler på brug af OG alene og sammen med HVIS.

Eksempler på brug af funktionen HVIS med OG


Formel

Beskrivelse

= OG(A2>1,A2<100)

Viser SAND, hvis A2 er større end 1 OG mindre end 100, og ellers vises FALSK.

=HVIS(OG(A2<A3,A2<100),A2,"Værdien er uden for området")

Viser værdien i A2, hvis den er mindre end A3 OG mindre end 100, ellers vises meddelelsen "Værdien er uden for området".

=HVIS (OGD(A3>1,A3<100),A3,"Værdien er uden for området")

Viser værdien i celle A3, hvis den er større end 1 OG mindre end 100, ellers vises en meddelelse. Du kan erstatte en meddelelse efter eget valg.

Beregning af bonus

Her er et ret almindelige scenarie, hvor vi er har brug for at beregne, om sælgere er berettiget en provision ved hjælp af HVIS og OG.

Eksempel på beregning af salgsbonus med funktionerne HVIS og OG.  Formlen i celle E14 er =HVIS (OG(B14>=$B$7,C14>=$B$5),B14*$B$8,0)
  • =HVIS(OG(B14>=$B$7;C14>=$B$5);B14*$B$8;0)HVIS samlet salg er større end eller lig med (>=) salgsmålet, OG konti er højere end eller lig med (>=) kontomålet, så ganges det samlede salg med bonus i %, ellers returneres 0.

Har du et bestemt spørgsmål til en funktion?

Send et spørgsmål i forummet Excel community

Hjælp os med at forbedre Excel

Har du forslag til, hvordan vi kan forbedre den næste version af Excel? Hvis det er tilfældet, skal du gå til emner i Excel User Voice

Bemærk: Ansvarsfraskrivelse for maskinoversættelse: Denne artikel er blevet oversat af et computersystem uden menneskelig indgriben. Microsoft tilbyder disse maskinoversættelse for at hjælpe ikke-engelsktalende brugere til at kunne nyde indhold om Microsofts produkter, tjenester og teknologier. Da artiklen er maskinoversat, kan den indeholde forkerte ord eller syntaks- eller grammatikfejl.

Se også

Se en video om, hvordan du bruger funktionen OG

Lær at bruge indlejrede funktioner i en formel

Funktionen HVIS

Funktionen ELLER

Funktionen IKKE

Oversigt over formler i Excel

Sådan undgår du ødelagte formler

Brug fejlkontrol til at registrere fejl i formler

Tastaturgenveje i Excel 2016 til Windows

Tastaturgenveje i Excel 2016 til Mac

Logiske funktioner (reference)

Excel-funktioner (alfabetisk)

Excel-funktioner (efter kategori)

Del Facebook Facebook Twitter Twitter Mail Mail

Var disse oplysninger nyttige?

Fantastisk! Har du mere feedback?

Hvordan kan vi forbedre det?

Tak for din feedback!

×