Funktionen LOPSLAG

Vigtigt: Denne artikel er maskinoversat. Se ansvarsfraskrivelsen. Du kan finde den engelske version af denne artikel her til din orientering.

Brug LOPSLAG, en af opslags- og referencefunktionerne, når du skal finde ting i en tabel eller i et område ud fra rækker. Du kan f.eks. slå en medarbejders efternavn op ud fra vedkommendes medarbejdernummer, eller du kan finde vedkommendes telefonnummer ved at slå efternavnet op (præcis ligesom i en telefonbog).

Din browser understøtter ikke video. Installer Microsoft Silverlight, Adobe Flash Player eller Internet Explorer 9.

Denne video er en del af et kursus kaldet LOPSLAG: hvornår og hvordan du bruger den.

Tip: Hemmeligheden bag LOPSLAG er at organisere dine data, så den værdi du slår op (medarbejderens efternavn), er til venstre for den returværdi, du vil finde (medarbejderens telefonnummer).

Syntaks

LOPSLAG(opslagsværdi; tabelmatrix; kolonneindeks_nr; [områdeopslag])

Det kunne f.eks. være:

  • =LOPSLAG(105;A2:C7;2;SAND)

  • =LOPSLAG( "Fontana";B2:E7;2;FALSK)

Argumentnavn

Beskrivelse

opslagsværdi    (påkrævet)

Den værdi, du vil slå op. Den værdi, du vil slå op, skal være i den første kolonne i det celleområde, du angiver i tabelmatrix .

Hvis tabelmatrix indeholder celleområdet B2:D7, så skal din opslagsværdi være i kolonne B. Se nedenstående grafik. Opslagsværdi kan være en værdi eller en reference til en celle.

Tabelmatrix    (påkrævet)

Det celleområde, hvor LOPSLAG vil søge efter opslagsværdi, samt returværdien.

Den første kolonne i celleområdet skal indeholde opslagsværdien (f.eks. Efternavn i nedenstående billede). Celleområdet skal også indeholde den returværdi (f.eks. Fornavn i nedenstående grafik), som du vil finde.

Lær at markere områder i et regneark.

kolonneindeks_nr    (påkrævet)

Kolonnenummeret (starter med 1 for kolonnen yderst til venstre i et tabelmatrix), som indeholder returværdien.

områdeopslag    (valgfrit)

En logisk værdi, der angiver, om LOPSLAG skal søge efter en præcis værdi eller en omtrentlig værdi.

  • SAND antager, at den første kolonne i tabellen er sorteret enten numerisk eller alfabetisk, og der søges så efter den nærmeste værdi. Dette er standardmetoden, hvis du ikke selv angiver en.

  • FALSK søger efter den nøjagtige værdi i den første kolonne.

Følgende billede viser, hvordan du skal konfigurere dit regneark med =VLOOKUP("Akers",B2:D5,2,FALSE) for at returnere Kim.

Eksempel på værdi og matrix, der skal bruges til at oprette en LOPSLAG-formel i Excel

Eksempler

Du bruger disse eksempler i Excel ved at kopiere dataene i tabellen herunder, og sætte dem ind i celle A1 i et nyt regneark.

Id

Efternavn

Fornavn

Titel

Fødselsdato

10,1

Davis

Sara

Sælger

08/12/1968

1,02

Fontana

Olivier

Adm. salgsdirektør

19/02/1952

103

Leal

Karina

Sælger

30/08/1963

1,04

Patten

Michael

Sælger

19/09/1958

=10-5

Burke

Brian

Salgschef

04/03/1955

106

Sousa

Luis

Sælger

02/07/1963

Formel

Beskrivelse

=LOPSLAG( "Fontana";B2:E7;2;FALSK)

Søger efter værdien Fontana i første kolonne (kolonne B) af tabelmatrix B2:E7 og returnerer værdien Olivier, der findes i den anden kolonne (kolonne C) af tabelmatrix. Områdeopslaget FALSK returnerer et nøjagtigt match.

=LOPSLAG(102,A2:C7,2,FALSK)

Søger efter et nøjagtigt match med efternavnet for opslagsværdi102 i kolonne A. Fontana returneres. Hvis Opslagsværdi er 105, returneres Burke.

=HVIS(LOPSLAG(103,A1:E7,2,FALSK)="Sousa","Fundet","Ikke fundet")

Kontrollerer, om det sidste navn på medarbejder med ID 103 er Sousa. Bruger funktionen Hvis til at returnere en værdi, hvis en betingelse er sand, og en anden værdi, hvis den er falsk. Da 103 er faktisk Leal, er resultatet blev ikke fundet. Hvis du ændrer "Sousa" til "Leal" i formlen, er resultatet placeret.

=HELTAL(ÅR.BRØK(DATO(2014,6,30);LOPSLAG(105,A2:E7,5,FALSK), 1))

For regnskabsåret 2014 findes alderen på medarbejderen med id nr. 105. Funktionen ÅR.BRØK bruges til at trække fødselsdatoen fra regnskabsåret, og resultatet 59 vises som et heltal ved hjælp af funktionen HELTAL.

=HVIS(ER.IKKE.TILGÆNGELIG(LOPSLAG(105,A2:E7,2,FALSK)) = SAND; "Medarbejder ikke fundet"; LOPSLAG(105,A2:E7,2,FALSK))

Hvis der findes en medarbejder med id nr. 105, vises medarbejderens efternavn, som er Burke. Ellers vises meddelelsen Medarbejder ikke fundet. Funktionen ER.IKKE.TILGÆNGELIG (se ER-funktioner) returnerer en SAND-værdi, hvis funktionen LOPSLAG returnerer fejlværdien #I/T.

=LOPSLAG(104,A2:E7,3,FALSK) & " " & LOPSLAG(104,A2:E7,2,FALSK) & " er " & LOPSLAG(104,A2:E7,4,FALSK)

For medarbejderen med id nr. 104sammensættes (kombineres) værdierne af tre celler i en hel sætning Michael Patten er sælger.

Almindelige problemer

Problem

Hvad der gik galt

Der blev returneret en forkert værdi

Hvis områdeopslag er SAND eller udeladt, skal den første kolonne sorteres alfabetisk eller numerisk. Hvis den første kolonne ikke er sorteret, kan den returnerede værdi være noget uventet. Sortér enten den første kolonne, eller brug FALSK som et nøjagtigt match.

#I/T i en celle

  • Hvis områdeopslag er SAND, og hvis værdien i opslagsværdi er mindre end den mindste værdi i første kolonne i tabelmatrix, så får du fejlværdien #I/T.

  • Hvis områdeopslag er FALSK, så angiver fejlværdien #I/T, at det nøjagtige tal ikke blev fundet.

Få mere at vide om fejl i regneark, f.eks. #I/T, #REFERENCE og resten.

#REFERENCE! i en celle

Hvis kolonneindeks_nr er større end antallet af kolonner i tabelmatrix, får du fejlværdien #REFERENCE!.

#VÆRDI! i en celle

Hvis tabelmatrix er mindre end 1, får du fejlværdien #VÆRDI!.

#NAVN? i en celle

Fejlværdien #NAVN? betyder som regel, at der mangler anførselstegn i formlen. For at finde en persons navn skal du sørge for at bruge anførselstegn omkring navnet i formlen. Du kan f.eks. skrive navnet som "Fontana" i =VOPSLAG("Fontana",B2:E7,2,FALSK).

Bedste fremgangsmåder

Gør dette

Hvorfor?

Brug af absolutte referencer til områdeopslag

Brug af absolutte referencer giver dig mulighed for at udfylde en formel, så den altid ser på præcis det samme opslagsområde.

Lær at bruge absolutte cellereferencer.

Gem ikke tal- eller datoværdier som tekst.

Når du søger efter tal eller datoværdier, skal du sikre dig, at dataene i den første kolonne af tabelmatrix ikke er gemt som tekstværdier. Ellers kan LOPSLAG returnere en forkert eller uventet værdi.

Sortere den første kolonne

Sortér den første kolonne i tabellen, inden du bruger LOPSLAG, når områdeopslag er SAND .

Brug af jokertegn

Hvis områdeopslag er FALSK, og opslagsværdien er tekst, kan du bruge jokertegn – spørgsmålstegn (?) og stjerne (*) – i opslagsværdi. Et spørgsmålstegn repræsenterer et vilkårligt enkelttegn, mens en stjerne repræsenterer en vilkårlig tegnsekvens. Hvis du vil søge efter et spørgsmålstegn eller en stjerne i selve teksten, skal du skrive en tilde (~) foran tegnet.

Eksempelvis søger =VLOOKUP("Fontan?",B2:E7,2,FALSE) efter alle forekomster af Fontana, hvor det sidste bogstav kan variere.

Kontrollér, at dine data ikke indeholder nogen forkerte tegn.

Når du søger efter tekstværdier i den første kolonne, skal du sikre dig, at dataene i den første kolonne ikke indeholder indledende mellemrum, afsluttende mellemrum, inkonsekvent brug af lige ( ' eller " ) og krøllede ( ‘ eller “) anførselstegn eller tegn, der ikke kan udskrives. I så fald kan LOPSLAG returnere en forkert eller uventet værdi.

For at få præcise resultater kan du prøve at bruge funktionen RENS eller funktionen FJERN.OVERFLØDIGE.BLANKE for at fjerne efterstillede mellemrum efter tabeværdier i en celle.

Relateret

Bemærk: Ansvarsfraskrivelse for maskinoversættelse: Denne artikel er blevet oversat af et computersystem uden menneskelig indgriben. Microsoft tilbyder disse maskinoversættelse for at hjælpe ikke-engelsktalende brugere til at kunne nyde indhold om Microsofts produkter, tjenester og teknologier. Da artiklen er maskinoversat, kan den indeholde forkerte ord eller syntaks- eller grammatikfejl.

Del Facebook Facebook Twitter Twitter Mail Mail

Var disse oplysninger nyttige?

Fantastisk! Har du mere feedback?

Hvordan kan vi forbedre det?

Tak for din feedback!

×