Funktionen INDEKS

INDEKS-funktionen returnerer en værdi eller referencen til en værdi fra en tabel eller et område.

Din browser understøtter ikke video. Installer Microsoft Silverlight, Adobe Flash Player eller Internet Explorer 9.

Der er to måder at bruge funktionen INDEKS på:

  • Hvis du vil returnere værdien af en bestemt celle eller en cellematrix, skal du se Matrixform.

  • Hvis du vil returnere en reference til bestemte celler, skal du se Referenceform.

Matrixform

Beskrivelse

Returnerer værdien for et element i en tabel eller en matrix, som vælges efter række- og kolonnenummerindeks.

Brug matrix, hvis det første argument til INDEKS er en matrixkonstant.

Syntaks

INDEKS(matrix;rækkenr;[kolonnenr])

Syntaksen for funktionen INDEKS har følgende argumenter:

  • Matrix    Påkrævet. Et celleområde eller en matrixkonstant.

    • Hvis matrix kun indeholder én række eller kolonne, er det tilsvarende rækkenr eller kolonnenr valgfrit.

    • Hvis matrix har mere end én række og mere end én kolonne og kun rækkenr eller kolonnenr bruges, returnerer INDEKS en matrix over hele rækken eller kolonnen i matrix.

  • Rækkenr    Påkrævet. Vælger den række i matrix, der skal returneres en værdi fra. Hvis rækkenr er udeladt, kræves kolonnenr.

  • Kolonnenr    Valgfrit. Vælger den kolonne i matrix, der skal returneres en værdi fra. Hvis kolonnenr er udeladt, kræves rækkenr.

Bemærkninger

  • Hvis både argumentet rækkenr og kolonnenr bruges, returnerer INDEKS værdien i cellen i fællesmængden for rækkenr og kolonnenr.

  • Hvis du sætter rækkenr eller kolonnenr til 0 (nul), returneres matrixen med værdier for henholdsvis hele kolonnen og hele rækken. Hvis du vil bruge værdier, der returneres som en matrix, skal du skrive funktionen INDEKS som en matrixformel i et vandret celleområde for en række og i et lodret celleområde for en kolonne. Du kan skrive en matrixformel ved at trykke på Ctrl+Skift+Enter.

    Bemærk: Du kan ikke oprette matrixformler i Excel Web App.

  • Rækkenr og kolonnenr skal pege på en celle inden for matrixen. Ellers returnerer INDEKS fejlværdien #REF!.

Eksempler

Eksempel 1

I eksemplerne bruges funktionen INDEKS til at finde værdien i den celle, hvor en række og en kolonne krydser hinanden.

Kopiér eksempeldataene i følgende tabel, og sæt dem ind i celle A1 i et nyt Excel-regneark. For at få formlerne til at vise resultater skal du markere dem, trykke på F2 og derefter trykke på Enter. Hvis der er brug for det, kan du justere bredden på kolonnerne, så du kan se alle dataene.

Data

Data

Æbler

Citroner

Bananer

Pærer

Formel

Beskrivelse

Resultat

=INDEKS(A2:B3,2,2)

Værdi ved skæringen af anden række og anden kolonne i området A2:B3.

Pærer

=INDEKS(A2:B3;2;1)

Værdi ved skæringen af anden række og første kolonne i området A2:B3.

Bananer

Eksempel 2

I dette eksempel bruges funktionen INDEKS i en matrixformel til at finde værdierne i to celler, der er angivet en 2x2-matrix.

Vælg her to vilkårlige, lodrette celler, som f.eks. A1:A2, indsæt den følgende formel =INDEKS({1,2;3,4},0,2) i den første celle og tryk derefter på CTRL+SKIFT+ENTER. Når den indtastes som en matrixformel, indsætter Excel automatisk formlen i den anden celle.

Formel

Beskrivelse

Resultat

=INDEKS({1,2;3,4},0,2)

Den værdi, der findes i den første række og anden kolonne i matrixen. Matrixen indeholder 1 og 2 i den første række og 3 og 4 i den anden række.

2

Den værdi, der findes i den anden række, anden kolonne i matrixen (samme matrix som herover).

4

Bemærk: Dette er en matrixformel, som skal indtastes med CTRL+SHIFT+ENTER. Excel omgiver automatisk formlen med parenteser {}. Hvis du forsøger at angive dem selv, vises Excel formlen som tekst. Hvis du ikke bruger CTRL+SKIFT+ENTER, vil formlen returnere en #VÆRDI! fejl.

Toppen af siden

Referenceform

Beskrivelse

Returnerer referencen fra cellen i skæringspunktet mellem en bestemt række og kolonne. Hvis referencen består af separate markeringer, kan du vælge, hvilken markering der skal søges i.

Syntaks

INDEKS(reference;rækkenr;[kolonnenr];[områdenr])

Syntaksen for funktionen INDEKS har følgende argumenter:

  • Reference    Påkrævet. En reference til et eller flere celleområder.

    • Hvis du indtaster et separat område som reference, skal du skrive reference i parenteser.

    • Hvis hvert område i reference kun indeholder én række eller kolonne, er det tilsvarende argument, dvs. rækkenr eller kolonnenr, valgfrit. Du kan f.eks. bruge INDEKS(reference;;kolonnenr) til en reference med én række.

  • Rækkenr    Påkrævet. Nummeret på rækken i den reference, der skal returneres en reference fra.

  • Kolonnenr    Valgfrit. Nummeret på kolonnen i den reference, der skal returneres en reference fra.

  • Områdenr    valgfri. Markerer et referenceområde, der skal returnere skæringspunktet for rækkenr og kolonnenr. Det første område, der markeres eller angives, tildeles nummer 1, andet er nummer 2 osv. Hvis områdenr udelades bruger indekset område 1.  De områder, der er angivet her, skal alle være placeret på ét ark.  Hvis du angiver områder, der ikke er på samme ark som hinanden, vil det medføre en #VÆRDI! fejl.  Hvis du skal bruge områder, der er placeret på forskellige ark, anbefales det, at du bruger matrixformen i indeks-funktionen, og bruger en anden funktion til at beregne det område, der udgør matrixen.  Du kan f.eks bruge funktionen VÆLG til at beregne, hvilket område der skal bruges.

Hvis reference f.eks. henviser til cellerne (A1:B4;D1:E4;G1:H4), er områdenr 1 celleområdet A1:B4, områdenr 2 er celleområdet D1:E4, og områdenr 3 er celleområdet G1:H4.

Bemærkninger

  • Når reference og områdenr har markeret et bestemt celleområde, markerer rækkenr og kolonnenr en bestemt celle: rækkenr 1 er den første række i området, kolonnenr 1 er den første kolonne osv. Referencen, der returneres af INDEKS, er skæringspunktet for rækkenr og kolonnenr.

  • Hvis du definerer rækkenr eller kolonnenr som 0 (nul), returnerer INDEKS referencen til hele den respektive kolonne eller række.

  • Rækkenr, kolonnenr og områdenr skal pege på en celle i reference. Ellers returnerer INDEKS fejlværdien #REFERENCE! Hvis rækkenr og kolonnenr udelades, returnerer INDEKS området i reference, som er angivet af områdenr.

  • Resultatet af INDEKS-funktionen er en reference og fortolkes som sådan af andre formler. Alt efter formlen kan værdien, som INDEKS returnerer, bruges som en reference eller en værdi. Formlen CELLE("bredde";INDEKS(A1:B2;1;2)) svarer f.eks. til CELLE("bredde";B1). CELLE-funktionen bruger værdien, som INDEKS returnerer, som en cellereference. Omvendt oversætter f.eks. formlen 2*INDEKS(A1:B2;1;2) den værdi, som INDEKS returnerer, til tallet i cellen B1.

Bemærk: Funktionen CELLE er ikke tilgængelig i Excel Web App.

Eksempler

Kopiér eksempeldataene i følgende tabel, og sæt dem ind i celle A1 i et nyt Excel-regneark. For at få formlerne til at vise resultater skal du markere dem, trykke på F2 og derefter trykke på Enter. Hvis der er brug for det, kan du justere bredden på kolonnerne, så du kan se alle dataene.

Frugt

Pris

Antal

Æbler

DKK 0,69

40

Bananer

DKK 0,34

38

Citroner

DKK 0,55

15

Appelsiner

DKK 0,25

25

Pærer

DKK 0,59

40

Mandler

DKK 2,80

10

Cashewnødder

DKK 3,55

16

Jordnødder

DKK 1,25

20

Valnødder

DKK 1,75

12

Formel

Beskrivelse

Resultat

=INDEKS(A2:C6; 2; 3)

Skæringen mellem anden række og tredje kolonne i området A2:C6, der er indholdet af celle C3.

38

=INDEKS((A1:C6; A8:C11), 2; 2; 2)

Skæringen mellem anden række og anden kolonne i det andet område af A8:C11, der er indholdet af celle B9.

1,25

=SUM(INDEKS(A1:C11; 0; 3; 1))

Summen af tredje kolonne i det første område i området A1:C11, der er summen af C1:C11.

216

=SUM(B2:INDEKS(A2:C6; 5; 2))

Summen af området, der starter fra B2 og slutter ved skæringen af den femte række og den anden kolonne i området A2:A6, som er summen af B2:B6.

2,42

Toppen af siden

Se også

Funktionen LOPSLAG

funktionen SAMMENLIGN

funktionen INDIREKTE

Retningslinjer for og eksempler på matrixformler

Opslags- og referencefunktioner (reference)

Udvid dine færdigheder
Gå på opdagelse i kurser
Få nye funktioner først
Bliv Office Insider

Var disse oplysninger nyttige?

Tak for din feedback!

Tak for din feedback! Det lyder, som om det vil kunne hjælpe, hvis du bliver sat i forbindelse med en af vores Office-supportteknikere.

×