Funktionen IKKE

Brug funktionen IKKE, en af de logiske funktioner, når du vil sikre dig, at en værdi ikke er lig med en anden.

Eksempel

Eksempler på, at funktionen IKKE vender om på argumenter.  Eksempel  =IKKE(1+1=2)

Funktionen IKKE vender værdien af dets argument om.

En almindelig anvendelse af funktionen IKKE er at øge anvendeligheden af andre funktioner, der udfører logiske test. Funktionen HVIS udfører f.eks. en logisk test og returnerer derefter én værdi, hvis testen evalueres til SAND, og en anden værdi, hvis testen evalueres til FALSK. Ved hjælp af funktionen IKKE som det logiske testargument i funktionen HVIS, kan du teste mange forskellige betingelser i stedet for blot én.

Syntaks

IKKE(logisk)

Syntaksen for funktionen IKKE har følgende argumenter:

  • Logisk    Påkrævet. En værdi eller et udtryk, der kan evalueres som SAND eller FALSK.

Bemærkninger

Hvis logisk er FALSK, returnerer IKKE SAND, og hvis logisk er SAND, returnerer IKKE FALSK.

Eksempler

Her er nogle generelle eksempler på brug af IKKE alene og sammen med HVIS, OG og ELLER.

Eksempler på IKKE med funktionerne HVIS, OG og ELLER


Formel

Beskrivelse

= IKKE (A2>100)

A2 er IKKE større end 100

=HVIS(OG(IKKE(A2>1),IKKE(A2<100)),A2,"Værdien er uden for området")

50 er større end 1 (SAND), OG 50 er mindre end 100 (SAND), så IKKE vender begge argumenter til FALSK. OG kræver, at begge argumenter er SAND, så resultatet returneres i tilfælde af FALSK.

=HVIS(ELLER(IKKE(A3<0),IKKE(A3>50)),A3,"Værdien er uden for området")

100 er ikke mindre end 0 (FALSK), og 100 er større end 50 (SAND), så IKKE vender argumenterne til SAND/FALSK. ELLER kræver kun ét argument for at være SAND, så resultatet returneres i tilfælde af SAND.

Beregning af salgsprovision

Her er et ret almindeligt scenarie, hvor vi har brug for at beregne, om sælgere er berettiget en provision ved hjælp af IKKE med HVIS og OG.

Eksempel på beregning af salgsbonus med funktionerne HVIS, OG og IKKE.  Formlen i celle E14 er =HVIS(OG(IKKE(B14<$B$7),IKKE(C14<$B$5)),B14*$B$8,0)
  • =HVIS(OG(IKKE(B14<$B$7),IKKE(C14<$B$5)),B14*$B$8,0)- HVIS samlet salg IKKE er mindre end salgsmålet, OG konti IKKE er mindre end kontomålet, så ganges det samlede salg med provision i procent, ellers returneres 0.

Har du et bestemt spørgsmål til en funktion?

Stil et spørgsmål i Excel-communityforummet

Hjælp os med at forbedre Excel

Har du forslag til, hvordan vi kan forbedre den næste version af Excel? Hvis det er tilfældet, skal du gå til emner i Excel User Voice

Se også

Se en video om, hvordan du bruger funktionen HVIS

Lær at bruge indlejrede funktioner i en formel

Funktionen HVIS

Funktionen OG

Funktionen ELLER

Oversigt over formler i Excel

Sådan undgår du ødelagte formler

Brug fejlkontrol til at registrere fejl i formler

Tastaturgenveje i Excel 2016 til Windows

Tastaturgenveje i Excel 2016 til Mac

Logiske funktioner (reference)

Excel-funktioner (alfabetisk)

Excel-funktioner (efter kategori)

Del Facebook Facebook Twitter Twitter Mail Mail

Var disse oplysninger nyttige?

Fantastisk! Har du mere feedback?

Hvordan kan vi forbedre det?

Tak for din feedback!

×