Funktionen HVIS.FEJL

denne artikel beskrives formelsyntaksen for og brugen af funktionen HVIS.FEJL i Microsoft Excel.

Beskrivelse

Returnerer en værdi, du angiver, hvis en formel evalueres som en fejl. I modsat fald returneres resultatet af formlen. Brug funktionen HVIS.FEJL til at fange og håndtere fejl i en formel.

Syntaks

HVIS.FEJL(værdi;værdi_hvis_fejl)

Syntaksen for funktionen HVIS.FEJL har følgende argumenter:

  • Værdi    Påkrævet. Det argument, der kontrolleres for fejl.

  • Værdi_hvis_fejl    Påkrævet. Den værdi, der returneres, hvis formlen evalueres som en fejl. Følgende fejltyper evalueres: #I/T, #VÆRDI!, #REFERENCE!, #DIVISION/0!, #NUM!, #NAVN? eller #NUL!

Bemærkninger

  • Hvis værdi eller værdi_hvis_fejl er en tom celle, behandler HVIS.FEJL den som en tom strengværdi ("").

  • Hvis værdi er en matrixformel, returnerer HVIS.FEJL matrixresultater for hver celle i området, der er angivet i værdien. Se det andet eksempel nedenfor.

Eksempler

Kopiér eksempeldataene i følgende tabel, og sæt dem ind i celle A1 i et nyt Excel-regneark. For at få formlerne til at vise resultater skal du markere dem, trykke på F2 og derefter trykke på Enter. Hvis der er brug for det, kan du justere bredden på kolonnerne, så du kan se alle dataene.

Kvote

Solgte enheder

210

35

55

0

23

Formel

Beskrivelse

Resultat

=HVIS.FEJL(A2/B2; "Fejl i beregning")

Kontrollerer, om der er fejl i formlens første argument (divider 210 med 35), finder ingen fejl, og returnerer derefter resultatet af formlen.

6

=HVIS.FEJL(A3/B3; "Fejl i beregning")

Kontrollerer, om der er fejl i formlens første argument (divider 55 med 0), finder en "division med 0"-fejl og returnerer derefter værdi_hvis_fejl.

Der opstod fejl i beregningen

=HVIS.FEJL(A4/B4; "Fejl i beregning")

Kontrollerer, om der er fejl i formlens første argument (divider "" med 23), finder ingen fejl, og returnerer derefter resultatet af formlen.

0

Eksempel 2

Kvote

Solgte enheder

Forhold

210

35

6

55

0

Der opstod fejl i beregningen

23

0

Formel

Beskrivelse

Resultat

=C2

Kontrollerer, om der er fejl i formlens første argument i det første element i matrixen (A2/B2 eller divider 210 med 35), finder ingen fejl, og returnerer derefter resultatet af formlen.

6

=C3

Kontrollerer, om der er fejl i formlens første argument i det andet element i matrixen (A3/B3 eller divider 55 med 0), finder en "division med 0"-fejl og returnerer derefter værdi_hvis_fejl.

Der opstod fejl i beregningen

=C4

Kontrollerer, om der er fejl i formlens første argument i det tredje element i matrixen (A4/B4 eller divider "" med 23), finder ingen fejl, og returnerer derefter resultatet af formlen.

0

Bemærk! Formlen i eksemplet skal angives som en matrixformel. Når du har kopieret eksemplet til et tomt regneark, skal du markere området C2:C4. Tryk på F2, og tryk derefter på Ctrl+Skift+Enter.

Del Facebook Facebook Twitter Twitter Mail Mail

Var disse oplysninger nyttige?

Fantastisk! Har du mere feedback?

Hvordan kan vi forbedre det?

Tak for din feedback!

×