Funktionen HVIS

Funktionen HVIS er en af de mest populære funktioner i Excel, og den gør det muligt at foretage logiske sammenligninger mellem en værdi, og hvad du forventer. Funktionen HVIS lyder i sin mest enkle form:

  • HVIS (Noget er sandt, så gør noget, ellers gør noget andet)

Så en HVIS-sætning kan have to resultater. Det første resultat er, hvis din sammenligning er Sand, det andet hvis din sammenligning er Falsk.

Hvis du vil gå videre og arbejde med flere HVIS-sætninger, skal du læse: Avancerede HVIS-funktioner – Arbejd med indlejrede formler og undgå fejl.

Brug funktionen HVIS, som er en af de logiske funktioner, til at få returneret én værdi, hvis en betingelse er sand, og en anden værdi, hvis den er falsk.

Syntaks

HVIS(logisk_test, værdi_hvis_sand, [værdi_hvis_falsk])

Det kunne f.eks. være:

  • =HVIS(A2>B2;"Overskredet budget";"OK")

  • =HVIS(A2=B2,B4-A4,"")

Argumentnavn

Beskrivelse

logisk_test    (påkrævet)

Den betingelse, du vil teste.

værdi_hvis_sand    (påkrævet)

Den værdi, der skal returneres, hvis resultatet af logisk_test er SAND.

værdi_hvis_falsk    (valgfri)

Den værdi, der skal returneres, hvis resultatet af logisk_test er FALSK.

Simple HVIS-eksempler

Celle D2 indeholder en formel =HVIS(C2="Ja",1,2)
  • =HVIS(C2=”Ja”,1,2)

I eksemplet ovenfor står der i celle D2: HVIS(C2 = Ja, så returneres 1, ellers returneres 2)

Celle D2 indeholder formlen =HVIS(C2=1,"JA","NEJ")
  • =HVIS(C2=1,”Ja”,”Nej”)

I dette eksempel lyder formlen i celle D2 således: HVIS(C2 = 1, så returneres Ja, ellers returneres Nej)

Som du kan se, kan funktionen HVIS bruges til at evaluere både tekst og værdier. Den kan også anvendes til at evaluere fejl. Du behøver ikke kun at kontrollere, om én ting er lig med en anden og returnere et enkelt resultat, du kan også bruge matematiske operatorer og udføre yderligere beregninger afhængigt af dine kriterier. Du kan også indlejre flere HVIS-funktioner i rækkefølge for at udføre flere sammenligninger.

Bemærk: Hvis du vil bruge tekst i formler, skal du pakke teksten ind i anførselstegn (f.eks. "Tekst"). Den eneste undtagelse til dette er anvendelsen af SAND eller FALSK, som Excel automatisk forstår.

Sådan kommer du i gang

Den bedste måde at begynde at skrive en HVIS-sætning på er ved at tænke over, hvad du forsøger at opnå. Hvilken sammenligning forsøger du at lave? Mange gange kan oprettelsen af en HVIS-sætning være noget så enkelt som at tænke logikken igennem i dit hoved: "Hvad skal ske, hvis betingelsen er opfyldt i forhold til, hvad der skal ske, hvis den ikke er det?" Du skal altid sørge for, at dine trin følger et logisk forløb, ellers vil din formel ikke gøre, hvad du ønsker, den skal gøre. Dette er især vigtigt, når du opretter komplekse (indlejrede) HVIS-sætninger.

Flere HVIS-eksempler

Formlen i celle D2 er =HVIS(C2>B2,”Overskredet Budget”,”Inden for Budget”)
  • =HVIS(C2>B2,”Overskredet Budget”,”Inden for Budget”)

I eksemplet ovenfor siger funktionen HVIS i D2 HVIS (C2 er større end B2, returneres derefter "Overskredet Budget", ellers returneres "Inden for Budget")

Formlen i celle E2 er =HVIS(C2>B2,C2-B2,"")
  • = HVIS(C2>B2,C2-B2,0)

I den ovenstående illustration vil vi i stedet for at returnere et tekstresultat returnere en matematisk beregning. Så formlen i E2 siger HVIS(Faktisk er større end Budgetteret, så træk det budgetterede beløb fra det faktiske beløb, ellers returneres ingenting).

Formlen i celle F7 er HVIS(E7="Ja",F5*0,0825,0)
  • =HVIS(E7="Ja",F5*0.0825,0)

I dette eksempel står der i formlen i F7, at HVIS(E7 = "Ja", så beregn det samlede beløb i F5 * 8,25 %, ellers opkræves der ingen afgift, så der returneres 0)

Bedste fremgangsmåder – konstanter

I det sidste eksempel kan du se både "Ja" og afgift (0,0825) skrevet direkte ind i formlen. Det er generelt ikke en god fremgangsmåde at angive konstanter (værdier, der muligvis skal ændres fra tid til anden) direkte i formler, da de kan være svære at finde og ændre i fremtiden. Det er meget bedre at angive konstanter i deres egne celler, hvor de er synlige og nemme at finde og ændre. I dette tilfælde er det OK, fordi der kun er én HVIS-funktion, og afgiften sjældent ændrer sig. Selv hvis den gør, vil det være nemt at ændre den i formlen.

Beregningsoperatorer

Hvis du vil have mere at vide om de forskellige beregningsoperatorer, du kan bruge i formler (< mindre end > større end, = lig med, <> forskellig fra osv.), skal du se denne artikel: Beregningsoperatorer og prioriteret rækkefølge.

Brug af HVIS til at kontrollere, om en celle er tom

Nogle gange skal du kontrollere, om en celle er tom, fordi du måske ikke ønsker, at en formel viser et resultat uden input.

Formlen i celle E2 er =HVIS(D2=1,"Ja",IF(D2=2,"Nej","Måske"))

I dette tilfælde bruger vi HVIS med funktionen ER.TOM:

  • = HVIS(ER.TOM(D2),"Tom","Ikke tom")

Det betyder, at HVIS(D2 er tom, returneres "Tom", ellers returneres "Ikke tom"). Du kan også nemt bruge din egen formel for betingelsen "Ikke tom". I det næste eksempel bruger vi "" i stedet for ER.TOM. Anførselstegnene "" betyder "intet".

Kontrollér, om en celle er tom – formlen i celle E2 er =HVIS(ER.TOM(D2),"Tom","ikke tom")
  • = HVIS(D3="","Tom","Ikke tom")

Denne formel siger, at HVIS(D3 er intet, så returneres "Tom", ellers returneres "Ikke tom"). Her er et eksempel på en meget almindelig metode med brug af "" til at forhindre, at en formel beregnes, hvis en relateret celle er tom:

  • =HVIS(D3="","",Din formel())

    HVIS (D3 er intet, så returneres intet, ellers beregnes formlen).

Indlejret HVIS-eksempel

Hvis en simpel HVIS-funktion kun har to resultater (Sand eller Falsk), kan indlejrede HVIS-funktioner have fra 3 til 64 resultater.

Brug "" til at kontrollere, om der er en tom celle – formlen i celle E3 er =HVIS(D3="","Tom","Ikke tom")
  • =HVIS(D2=1,”JA”,HVIS(D2=2,”Nej”,”Måske”))

I illustrationen ovenfor står der i formlen i E2: HVIS(D2 er lig med 1, så returneres "Ja", ellers HVIS(D2 er lig med 2, så returneres "Nej", ellers returneres "Måske")). Bemærk, at der er to højreparenteser i slutningen af formlen. Disse er nødvendige for at udføre begge HVIS-funktioner, og hvis du forsøger at angive formlen uden begge højreparenteser, forsøger Excel at rette det for dig.

Vær forsigtig

Mens Excel gør det muligt for dig at indlejre op til 64 forskellige HVIS-funktioner, kan det slet ikke anbefales at gøre dette. Hvorfor?

  • Flere HVIS-sætninger kræver en hel del omtanke at bygge korrekt og sørge for, at deres logik kan regne korrekt gennem hver betingelse hele vejen igennem. Hvis ikke du indlejrer dine HVIS-sætninger 100 % præcist, fungerer en formel muligvis 75 % af tiden, men returnerer uventede resultater 25 % af tiden. Sandsynligheden for, at du kommer ud for de 25 %, er desværre stor.

  • Flere HVIS-sætninger kan blive meget svære at vedligeholde, især når du vender tilbage på et senere tidspunkt og forsøger at finde ud af, hvad du, eller værre, en anden, forsøgte at gøre.

  • Flere HVIS-sætninger kræver flere venstre- og højreparenteser (), hvilket kan være svært at administrere, afhængigt af hvor kompleks formlen bliver.

Almindelige problemer

Problem

Hvad der gik galt

0 (nul) i celle

Der var ikke noget argument for hverken værdi_hvis_sand eller værdi_hvis_falsk. For at få returneret den rigtige værdi skal du føje argumenttekst til de to argumenter eller føje SAND eller FALSK til argumentet.

#NAVN? i en celle

Dette betyder som regel, at formlen er stavet forkert.

Har du brug for mere hjælp?

Du kan altid spørge en ekspert i Excel Tech Community, få support i Answers community eller foreslå en ny funktion eller forbedring i Excel User Voice.

Se også

Video: Avancerede HVIS-funktioner

HVISER-funktionen (Office 365, Excel 2016 og nyere)

Avancerede HVIS-funktioner – Arbejd med indlejrede formler og undgå fejl

Kursusvideoer: Avancerede HVIS-funktioner

Funktionen TÆL.HVIS vil tælle værdier, der er baseret på et enkelt kriterium

Funktionen TÆL.HVISER vil tælle værdier, der er baseret på flere kriterier

Funktionen SUM.HVIS vil sammenlægge værdier, der er baseret på et enkelt kriterium

Funktionen SUM.HVISER vil sammenlægge værdier, der er baseret på flere kriterier

Funktionen OG

Funktionen ELLER

Funktionen LOPSLAG

Oversigt over formler i Excel

Sådan undgår du ødelagte formler

Brug fejlkontrol til at registrere fejl i formler

Logiske funktioner

Excel-funktioner (alfabetisk)

Excel-funktioner (efter kategori)

Udvid dine færdigheder
Gå på opdagelse i kurser
Få nye funktioner først
Bliv Office Insider

Var disse oplysninger nyttige?

Tak for din feedback!

Tak for din feedback! Det lyder, som om det vil kunne hjælpe, hvis du bliver sat i forbindelse med en af vores Office-supportteknikere.

×