FEJLTYPE, funktionen

I denne artikel beskrives formelsyntaksen for og brugen af funktionen FEJLTYPE i Microsoft Excel.

Beskrivelse

Returnerer et tal, der svarer til en af fejlværdierne i Microsoft Excel eller returnerer fejlen #I/T, hvis der ikke er nogen fejl. Brug funktionen FEJLTYPE i en HVIS-funktion til at søge efter en fejlværdi og returnere en tekststreng, som f.eks. en meddelelse, i stedet for fejlværdien.

Syntaks

FEJLTYPE(fejlværdi)

Syntaksen for funktionen FEJLTYPE har følgende argumenter:

  • Fejlværdi    Påkrævet. Den fejlværdi, hvis identifikationsnummer du vil finde. Selvom fejlværdi kan være den egentlige fejlværdi, vil den normalt være en reference til en celle, som indeholder en formel, der skal testes.

Hvis fejlværdi er

returnerer FEJLTYPE

#NUL!

1

#DIVISION/0!

2

#VÆRDI!

3

#REFERENCE!

4

#NAVN?

5

#NUM!

6

#I/T

7

#HENTER_DATA

8

Alt andet end ovenstående

#I/T

Eksempel

Kopiér eksempeldataene i følgende tabel, og sæt dem ind i celle A1 i et nyt Excel-regneark. For at få formlerne til at vise resultater skal du markere dem, trykke på F2 og derefter trykke på Enter. Hvis der er brug for det, kan du justere bredden på kolonnerne, så du kan se alle dataene.

Data

#NUL!

#DIVISION/0!

Formel

Beskrivelse

Resultat

=FEJLTYPE(A2)

Tallet på fejlen #NUL! Fejl(1).

1

=HVIS(FEJLTYPE(A3)<3;VÆLG(FEJLTYPE(A3);"Områderne krydser ikke hinanden";"Divisoren er nul"))

Den følgende formel undersøger celle A3 for at se, om cellen indeholder enten fejlværdien #NUL! eller #DIVISION/0!. Hvis det er tilfældet, bruges tallet til fejlværdien i regnearksfunktionen VÆLG til at få vist en eller to meddelelser. Hvis det ikke er tilfældet, returneres fejlværdien #I/T.

Divisoren er nul.

Del Facebook Facebook Twitter Twitter Mail Mail

Var disse oplysninger nyttige?

Fantastisk! Har du mere feedback?

Hvordan kan vi forbedre det?

Tak for din feedback!

×