Eksempler på almindelige formler

Vigtigt: Denne artikel er maskinoversat. Se ansvarsfraskrivelsen. Du kan finde den engelske version af denne artikel her til din orientering.

Du kan bruge følgende eksempler i kolonner i dit Excel-ark. Eksempler, der ikke skal medtage kolonnereferencer kan bruges til at angive standardværdien for en kolonne.

Betingede formler

Du kan bruge følgende formler til at teste betingelsen af en sætning og returnerer en SAND eller FALSK værdi til at afprøve en alternativ værdi sådanne som OK eller ikke OK eller på Retur en tom eller bindestreg til at repræsentere en null-værdi.

Kontrollér, om et tal er større eller mindre end et andet tal

Brug funktionen HVIS til at udføre denne sammenligning.

Kolonne1

Kolonne2

Formel

Beskrivelse (resultat)

15000

9000

[Kolonne1] & BT; [Kolonne2])

Er Kolonne1 større end Kolonne2? (SAND)

15000

9000

= IF([Column1]<=[Column2], "OK", "Not OK")

Er Kolonne1 mindre end eller lig med Kolonne2? (Ikke OK)

Returnér en logisk værdi efter at have sammenlignet kolonnernes indhold

Et resultat, der er en logisk værdi (SAND eller FALSK), kan du bruge funktionerne OG, eller, og IKKE fungerer.

Kolonne1

Kolonne2

Kolonne3

Formel

Beskrivelse (resultat)

15

9

8

= AND([Column1]>[ Kolonne2], [Kolonne1] & lt; [Kolonne3])

Er 15 større end 9 og mindre end 8? (FALSK)

15

9

8

= OR([Column1]>[ Kolonne2], [Kolonne1] & lt; [Kolonne3])

Er 15 større end 9 eller mindre end 8? (SAND)

15

9

8

=IKKE([Kolonne1]+[Kolonne2]=24)

Er 15 plus 9 ikke lig med 24? (FALSK)

Brug funktionerne HVIS, et resultat, der er en anden beregning eller en anden værdi end TRUE eller FALSE, OG og ELLER funktioner.

Kolonne1

Kolonne2

Kolonne3

Formel

Beskrivelse (resultat)

15

9

8

=HVIS([Kolonne1]=15, "OK"; "Ikke OK")

Hvis værdien i Kolonne1 er lig med 15, returneres "OK". (OK)

15

9

8

= HVIS (OG ([Kolonne1] & BT; [ Kolonne2], [Kolonne1] & lt; [Kolonne3]), "OK", "Ikke OK")

Hvis 15 er større end 9 og mindre end 8, returneres "OK". (Ikke OK)

15

9

8

= HVIS (ELLER ([Kolonne1] & BT; [ Kolonne2], [Kolonne1] & lt; [Kolonne3]), "OK", "Ikke OK")

Hvis 15 er større end 9 eller mindre end 8, returneres "OK" (OK)

Få vist nuller som blanktegn eller bindestreger

Udfør en simpel beregning for at få vist et nul. Brug funktionen HVIS til at få vist en tom værdi eller en bindestreg.

Kolonne1

Kolonne2

Formul a

Beskrivelse (resultat)

10

10

=[Kolonne1]-[Kolonne2]

Andet tal trukket fra det første (0)

15

9

=HVIS([Kolonne1]-[Kolonne2];"-",[Kolonne1]-[Kolonne2])

Returnerer en bindestreg, når værdien er nul (-)

Skjul fejlværdier i kolonner

Brug funktionen ER.FEJL for at få vist en bindestreg, #I/T eller I/T i stedet for en fejlværdi.

Kolonne1

Kolonne2

Formel

Beskrivelse (resultat)

10

0

=[Kolonne1]/[Kolonne2]

Resulterer i en fejl (#DIV/0)

10

0

=HVIS(ER.FEJL([Kolonne1]/[Kolonne2]),"I/T",[Kolonne1]/[Kolonne2])

Returnerer IKKE.TILGÆNGELIG, når værdien er en fejl (NA)

10

0

=HVIS(ER.FEJL([Kolonne1]/[Kolonne2]),"-",[Kolonne1]/[Kolonne2])

Returnerer en bindestreg, når værdien er en fejl (-)

Dato og klokkeslæt formler

Du kan bruge følgende formler til at udføre beregninger, der er baseret på datoer og klokkeslæt, f.eks. addition af antal dage, måneder eller år til en dato, beregning af forskellen mellem to datoer og konvertering af klokkeslættet til en decimal værdi.

Tilføj datoer

Brug additionsoperatoren (+), hvis du vil lægge et antal dage til en dato.

Bemærk: Når du arbejder med datoer, skal returtypen for den beregnede kolonne indstilles til Dato og klokkeslæt.

Kolonne1

Kolonne2

Formel

Beskrivelse (resultat)

9-6-2007

3

=[Kolonne1]+[Kolonne2]

Lægger 3 dage til 6/9/2007 (6/12/2007)

10.12.08

54

=[Kolonne1]+[Kolonne2]

Lægger 54 dage til 12/10/2008 (2/2/2009)

Brug funktionerne DATO, ÅR, MÅNED og DAG, hvis du vil lægge et antal måneder til en dato.

Kolonne1

Kolonne2

Formel

Beskrivelse (resultat)

9-6-2007

3

=DATO(ÅR([Kolonne1]);MÅNED([Kolonne1])+[Kolonne2];DAG([Kolonne1]))

Lægger 3 måneder til 6/9/2007 (9/9/2007)

10.12.08

25

=DATO(ÅR([Kolonne1]);MÅNED([Kolonne1])+[Kolonne2];DAG([Kolonne1]))

Lægger 25 måneder til 12/10/2008 (1/10/2011)

Brug funktionerne DATO, ÅR, MÅNED og DAG, hvis du vil lægge et antal år til en dato.

Kolonne1

Kolonne2

Formel

Beskrivelse (resultat)

9-6-2007

3

=DATO(ÅR([Kolonne1])+[Kolonne2];MÅNED([Kolonne1]);DAG([Kolonne1]))

Lægger 3 år til 9-6-2007 (6-9-2010))

10-12-2008

25

=DATO(ÅR([Kolonne1])+[Kolonne2];MÅNED([Kolonne1]);DAG([Kolonne1]))

Lægger 25 år til 12/10/2008 (12/10/2033)

Brug funktionerne DATO, ÅR, MÅNED og DAG, hvis du vil lægge en kombination af dage, måneder og år til en dato.

Kolonne1

Formel

Beskrivelse (resultat)

09.06.07

=DATO(ÅR([Kolonne1])+3,MÅNED([Kolonne1])+1,DAG([Kolonne1])+5)

Lægger 3 år, 1 måned og 5 dage til 6/9/2007 (7/14/2010)

10.12.08

=DATO(ÅR([Kolonne1])+1,MÅNED([Kolonne1])+7,DAG([Kolonne1])+5)

Lægger 1 år, 7 måneder og 5 dage til 12/10/2008 (7/15/2010)

Beregn forskellen mellem to datoer

Brug funktionen DATO.FORSKEL til at udføre denne beregning.

Kolonne1

Kolonne2

Formel

Beskrivelse (resultat)

01.01.95

15.06.99

=DATO.FORSKEL([Kolonne1]; [Kolonne2];"d")

Returnerer antallet af dage mellem to datoer (1626)

01.01.95

15.06.99

=DATO.FORSKEL([Kolonne1]; [Kolonne2];"åm")

Returnerer antallet af måneder mellem datoerne og ignorerer årstalsdelen (5)

01.01.95

15.06.99

=DATO.FORSKEL([Kolonne1]; [Kolonne2];"yd")

Returnerer antallet af dage mellem datoerne og ignorerer årstalsdelen (165)

Beregn forskellen mellem to klokkeslæt

Brug subtraktionsoperatoren (-) og funktionen TEKST, hvis du vil vise resultatet i standardklokkeslætsformatet (timer:minutter:sekunder). Hvis denne metode skal fungere, må antal timer ikke overskride 24, og antal minutter og sekunder må ikke overskride 60.

Kolonne1

Kolonne2

Formel

Beskrivelse (resultat)

06/09/2007 10:35

06/09/2007 15:30

=TEKST([Kolonne2]-[Kolonne1];"t")

Timer mellem to klokkeslæt (4)

06/09/2007 10:35

06/09/2007 15:30

=TEKST([Kolonne2]-[Kolonne1];"t:mm")

Timer og minutter mellem to klokkeslæt (4:55)

06/09/2007 10:35

06/09/2007 15:30

=TEKST([Kolonne2]-[Kolonne1];"t:mm:ss")

Timer, minutter og sekunder mellem to klokkeslæt (4:55:00)

Brug funktionen HELTAL eller funktionen TIME, MINUT eller SEKUND til at vise resultatet som en total, der er baseret på én tidsenhed.

Kolonne1

Kolonne2

Formel

Beskrivelse (resultat)

06/09/2007 10:35

06/10/2007 15:30

=HELTAL(([Kolonne2]-[Kolonne1])*24)

Antal timer mellem to klokkeslæt (28)

06/09/2007 10:35

06/10/2007 15:30

=HELTAL(([Kolonne2]-[Kolonne1])*1440)

Antal minutter mellem to klokkeslæt (1735)

06/09/2007 10:35

06/10/2007 15:30

=HELTAL(([Kolonne2]-[Kolonne1])*86400)

Antal sekunder mellem to klokkeslæt (104100)

06/09/2007 10:35

06/10/2007 15:30

=TIME([Kolonne2]-[Kolonne1])

Timer mellem to klokkeslæt, når forskellen ikke overstiger 24 (4)

06/09/2007 10:35

06/10/2007 15:30

=MINUT([Kolonne2]-[Kolonne1])

Minutter mellem to klokkeslæt, når forskellen ikke overstiger 60 (55)

06/09/2007 10:35

06/10/2007 15:30

=SEKUND([Kolonne2]-[Kolonne1])

Sekunder mellem to klokkeslæt, når forskellen ikke overstiger 60 (0)

Konvertér klokkeslæt

Brug funktionen HELTAL, hvis du vil konvertere timer fra standardklokkeslætsformatet til et decimaltal.

Kolonne1

Formel

Beskrivelse (resultat)

10:35

=([Kolonne1]-HELTAL([Kolonne1]))*24

Antal timer siden 00:00 (10,583333)

12:15

=([Kolonne1]-HELTAL([Kolonne1]))*24

Antal timer siden 00:00 (12,25)

Brug divisionsoperatoren og funktionen TEKST, hvis du vil konvertere timer fra et decimaltal til standardklokkeslætsformatet (timer:minutter:sekunder).

Kolonne1

Formel

Beskrivelse (resultat)

23:58

=TEKST(Kolonne1/24, "tt:mm:ss")

Timer, minutter og sekunder siden 00:00 (00:59:55)

2:06

=TEKST(Kolonne1/24, "t:mm")

Timer og minutter siden 00:00 (0:05)

Indsæt julianske datoer

En juliansk dato refererer til et datoformat, der er en kombination af det indeværende år og antallet af dage siden begyndelsen af året. 1. januar 2007 er f.eks. repræsenteret som 2007001 og 31. december 2007 som 2007356. Vær opmærksom på, at formatet ikke er baseret på den julianske kalender.

Brug funktionerne TEKST og DATOVÆRDI, hvis du vil konvertere en dato til en juliansk dato.

Kolonne1

Formel

Beskrivelse (resultat)

23.06.07

=TEKST([Kolonne1];"åå")&TEKST(([Kolonne1]-DATOVÆRDI("1/1/"& TEKST([Kolonne1];"åå"))+1),"000")

Dato i juliansk format med tocifret årstal (07174)

23.06.07

=TEKST([Kolonne1];"åååå")&TEKST(([Kolonne1]-DATOVÆRDI("1/1/"&TEKST([Kolonne1];"åå"))+1),"000")

Dato i juliansk format med firecifret årstal (07174)

Hvis du vil konvertere en dato til et juliansk datoformat, der bruges inden for astronomi, skal du bruge konstanten 2415018,50. Denne formel fungerer kun for datoer efter 1-3-1901, og hvis du bruger 1900-datosystemet.

Kolonne1

Formel

Beskrivelse (resultat)

23.06.07

=[Kolonne1]+2415018,50

Dato i juliansk format, der bruges i astronomi (2454274,50)

Vis datoer som ugedage

Brug funktionerne TEKST og UGEDAG, hvis du vil konvertere datoer til tekst, der beskriver ugedage.

Kolonne1

Formel

Beskrivelse (resultat)

19.02.07

=TEKST(UGEDAG([Kolonne1]), "dddd")

Beregner ugedagen for datoen og returnerer dagens fulde navn (Mandag)

03.01.08

=TEKST(UGEDAG([Kolonne1]), "ddd")

Beregner ugedagen for datoen og returnerer dagens forkortede navn (to)

Matematiske formler

Du kan bruge følgende formler til at udføre en række matematiske beregninger, f.eks. addition, subtraktion, multiplikation og division af tal, beregning af gennemsnittet eller medianen af tal, afrunding af tal og optælling af værdier.

Addition af tal

Brug additionsoperatoren (+) eller funktionen SUM, hvis du vil addere tal i to eller flere kolonner i en række.

Kolonne1

Kolonne2

Kolonne3

Formel

Beskrivelse (resultat)

6

5

4

=[Kolonne1]+[Kolonne2]+[Kolonne3]

Lægger værdierne i de første tre kolonner sammen (15)

6

5

4

=SUM([Kolonne1];[Kolonne2];[Kolonne3])

Lægger værdierne i de første tre kolonner sammen (15)

6

5

4

=SUM(HVIS([Kolonne1]>[Kolonne2]; [Kolonne1]-[Kolonne2]; 10), [Kolonne3])

Hvis Kolonne1 er større end Kolonne2, lægges forskellen og Kolonne3 til. Ellers lægges 10 og Kolonne3 til (5)

Subtraktion af tal

Brug subtraktionsoperatoren (-) eller funktionen SUM med negative tal, hvis du vil subtrahere tal i to eller flere kolonner i en række.

Kolonne1

Kolonne2

Kolonne3

Formel

Beskrivelse (resultat)

15000

9000

-8000

=[Kolonne1]-[Kolonne2]

Trækker 9000 fra 15000 (6000)

15000

9000

-8000

=SUM([Kolonne1];[Kolonne2];[Kolonne3])

Lægger tallene i de første tre kolonner £sammen, herunder negative værdier (16000)

Beregn forskellen mellem to tal som procentdel

Brug subtraktionsoperatoren (-) og divisionsoperatoren (/) og funktionen ABS.

Kolonne1

Kolonne2

Formel

Beskrivelse (resultat)

2342

2500

=([Kolonne2]-[Kolonne1])/ABS([Kolonne1])

Procentvis forskel (6,75% eller 0,06746)

Multiplikation af tal

Brug mulitiplikationsoperatoren (*) eller funktionen PRODUKT, hvis du vil multiplicere tal i to eller flere kolonner i en række.

Kolonne1

Kolonne2

Formel

Beskrivelse (resultat)

5

2

=[Kolonne1]*[Kolonne2]

Multiplicerer tallene i de to første kolonner (10)

5

2

=PRODUKT([Kolonne1]; [Kolonne2])

Multiplicerer tallene i de to første kolonner (10)

5

2

=PRODUKT([Kolonne1];[Kolonne2];2)

Multiplicerer tallene i de to første kolonner og tallet 2 (20)

Division af tal

Brug divisionsoperatoren, hvis du vil dividere tal i to eller flere kolonner i en række (/).

Kolonne1

Kolonne2

Formel

Beskrivelse (resultat)

15000

12

=[Kolonne1]/[Kolonne2]

Dividerer 15000 med 12 (1250)

15000

12

=([Kolonne1]+10000)/[Kolonne2]

Lægger 15000 og 10000 sammen og dividerer derefter totalen med 12 (2083)

Beregn gennemsnittet af tal

Gennemsnittet kaldes også middelværdien. Brug funktionen MIDDEL, hvis du vil beregne gennemsnittet af tal i to eller flere kolonner i en række.

Kolonne1

Kolonne2

Kolonne3

Formel

Beskrivelse (resultat)

6

5

4

=MIDDEL([Kolonne1]; [Kolonne2];[Kolonne3])

Gennemsnittet af tallene i de tre første kolonner (5)

6

5

4

=MIDDEL(HVIS([Kolonne1]>[Kolonne2]; [Kolonne1]-[Kolonne2]; 10), [Kolonne3])

Hvis Kolonne1 er større end Kolonne2, beregnes gennemsnittet af forskellen og Kolonne3. Ellers beregnes gennemsnittet af værdien 10 og Kolonne3 (2,5)

Beregn medianen af tal

Medianen er værdien i midten af en talrække. Brug funktionen MEDIAN til at beregne medianen af en talgruppe.

A

B

C

D

E

F

Formel

Beskrivelse (resultat)

10

7

9

27

0

4

=MEDIAN(A; B; C; D; E; F)

Medianen af tallene i de seks første kolonner (8)

Beregn det mindste eller største tal i et område

Brug funktionerne MIN og MAKS, hvis du vil beregne det mindste eller største tal i to eller flere kolonner i en række.

Kolonne1

Kolonne2

Kolonne3

Formel

Beskrivelse (resultat)

10

7

9

=MIN([Kolonne1]; [Kolonne2]; [Kolonne3])

Mindste tal (7)

10

7

9

=MAKS([Kolonne1]; [Kolonne2]; [Kolonne3])

Største tal (10)

Optæl værdier

Brug funktionen TÆL, hvis du vil tælle numeriske værdier.

Kolonne1

Kolonne2

Kolonne3

Formel

Beskrivelse (resultat)

Æble

12.12.07

=TÆL([Kolonne1]; [Kolonne2]; [Kolonne3])

Tæller antallet af kolonner, der indeholder numeriske værdier, herunder dato- og klokkeslætsværdier. Udelader tekst- og null-værdier (0)

$12

#DIVISION/0!

1,01

=TÆL([Kolonne1]; [Kolonne2]; [Kolonne3])

Tæller antallet af kolonner, der indeholder numeriske værdier, men udelader fejl og logiske værdier (2)

Øg eller mindsk et tal med en procentdel

Brug procentoperatoren (%) til at udføre denne beregning.

Kolonne1

Kolonne2

Formel

Beskrivelse (resultat)

23

3%

=[Kolonne1]*(1+5%)

Øger tallet i Kolonne1 med 5% (24,15)

23

3%

=[Kolonne1]*(1+[Kolonne2])

Øger tallet i Kolonne1 med procentværdien i Kolonne2: 3% (23,69)

23

3%

=[Kolonne1]*(1-[Kolonne2])

Reducerer tallet i Kolonne1 med procentværdien i Kolonne2: 3% (22,31)

Opløft et tal til en potens

Brug eksponeringsoperatoren (^) eller funktionen POTENS til at udføre denne beregning.

Kolonne1

Kolonne2

Formel

Beskrivelse (resultat)

5

2

=[Kolonne1]^[Kolonne2]

Beregner kvadratet af fem (25)

5

3

=POTENS([Kolonne1]; [Kolonne2])

Beregner kubiktallet af fem (125)

Afrund et tal

Brug funktionerne RUND.OP, ULIGE og LIGE, hvis du vil runde et tal op.

Kolonne1

Formel

Beskrivelse (resultat)

20,3

=RUND.OP([Kolonne1];0)

Runder 20,3 op til nærmeste hele tal (21)

-5,9

=RUND.OP([Kolonne1];0)

Runder -5,9 op til nærmeste hele tal (-5)

12,5493

=RUND.OP([Kolonne1]0,2)

Runder 12,5493 op til nærmeste hundrededel (to decimalpladser) (12,55)

20,3

=LIGE([Kolonne1])

Runder 20,3 op til nærmeste lige tal (22)

20,3

=ULIGE([Kolonne1])

Runder 20,3 op til nærmeste ulige tal (21)

Brug funktionen RUND.NED, hvis du vil runde et tal ned.

Kolonne1

Formel

Beskrivelse (resultat)

20.3

=RUND.NED([Kolonne1];0)

Runder 20,3 ned til nærmeste hele tal (20)

-5,9

=RUND.NED([Kolonne1];0)

Runder -5,9 ned til nærmeste hele tal (-6)

12,5493

=RUND.NED([Kolonne1]0,2)

Runder 12,5493 ned til nærmeste hundreder med to decimalpladser (12,54)

Brug funktionen AFRUND, hvis du vil afrunde et tal til nærmeste tal eller brøk.

Kolonne1

Formel

Beskrivelse (resultat)

20,3

=AFRUND([Kolonne1];0)

Runder 20;3 ned, fordi brøkdelen er mindre end ,5 (20)

5,9

=AFRUND([Kolonne1];0)

Runder 5,9 op, fordi brøkdelen er større end ,5 (6)

-5.9

=AFRUND([Kolonne1];0)

Runder -5,9 ned, fordi brøkdelen er mindre end -,5 (-6)

1,25

=AFRUND([Kolonne1]; 1)

Afrunder tallet til nærmeste tiendedel (én decimalplads). Da den brøkdel, der afrundes, er større end eller lig med 0,05, rundes tallet op (resultat: 1,3)

30,452

=AFRUND([Kolonne1]; 2)

Afrunder tallet til nærmeste hundrededel (to decimalpladser). Da den brøkdel, der afrundes (0,002), er mindre end 0,005, rundes tallet ned (resultat: 30,45)

Brug funktionerne AFRUND, RUND.OP, RUND.NED, HELTAL og LÆNGDE, hvis du vil afrunde et tal til det betydende ciffer over 0.

Kolonne1

Formel

Beskrivelse (resultat)

5492820

=AFRUND([Kolonne1];3-LÆNGDE(HELTAL([Kolonne1])))

Afrunder tallet til 3 betydende cifre (5490000)

22230

=RUND.NED([Kolonne1];3-LÆNGDE(HELTAL([Kolonne1])))

Runder det nederste tal ned til 3 betydende cifre (22200)

5492820

=RUND.OP([Kolonne1]; 5-LÆNGDE(HELTAL([Kolonne1])))

Runder det øverste tal op til 5 betydende cifre (5492900)

Tekst formler

Du kan bruge følgende formler til at manipulere tekst, f.eks. kombinere eller sammenkæde værdier fra flere kolonner, sammenligne indholdet af kolonner, fjerne tegn eller mellemrum og gentage tegn.

Udskift store bogstaver med små eller omvendt i teksten

Brug funktionerne STORE.BOGSTAVER, SMÅ.BOGSTAVER og STORT.FORBOGSTAV til at bytte om på store og små bogstaver i tekst.

Kolonne1

Formel

Beskrivelse (resultat)

hanne Dahl

=STORE.BOGSTAVER([Kolonne1])

Ændrer tekst til ene store bogstaver (HANNE DAHL)

hanne Dahl

=SMÅ.BOGSTAVER([Kolonne1])

Ændrer tekst til ene små bogstaver (hanne dahl)

hanne Dahl

=STORT.FORBOGSTAV([Kolonne1])

Ændrer tekst til store forbogstaver (Hanne Dahl)

Kombinér for- og efternavn

Brug operatoren & (ampersand) eller funktionen SAMMENKÆDNING, hvis du vil kombinere for- og efternavn.

Kolonne1

Kolonne2

Formel

Beskrivelse (resultat)

Hanne

Dahl

=[Kolonne1]&[Kolonne2]

Kombinerer de to strenge (HanneDahl)

Hanne

Dahl

=[Kolonne1]&" "&[Kolonne2]

Kombinerer de to strenge, som adskilles af mellemrum (Hanne Dahl)

Hanne

Dahl

=[Kolonne2]&", "&[Kolonne1]

Kombinerer de to strenge, som adskilles af komma og et mellemrum (Dahl, Hanne)

Hanne

Dahl

=SAMMENKÆDNING([Kolonne2]; ",", [Kolonne1])

Kombinerer de to strenge, som adskilles af komma (Dahl,Hanne)

Kombiner tekst og tal fra forskellige kolonner

Brug funktionen SAMMENKÆDNING, operatoren & (ampersand) eller funktionen TEKST og operatoren & (ampersand), hvis du vil kombinere tekst og tal.

Kolonne1

Kolonne2

Formel

Beskrivelse (resultat)

Peter

28

=[Kolonne1]&" solgte "&[Kolonne2]&" enheder."

Kombinerer indholdet ovenfor i et udtryk (Peter solgte 28 enheder).

Dubios

40%

=[Kolonne1]&" har solgt "&TEKST([Kolonne2];"0%")&" af det samlede salg"

Kombinerer indholdet ovenfor i et udtryk (David har solgt 40% af det samlede salg).

Bemærk: Funktionen TEKST tilføjer den formaterede værdi af Kolonne2 i stedet for den underliggende værdi, som er 4

Peter

28

=SAMMENKÆDNING([Kolonne1];" solgte ",[Kolonne2];" enheder")

Kombinerer indholdet ovenfor i et udtryk (Peter solgte 28 enheder).

Kombiner tekst med en dato eller et klokkeslæt

Brug funktionen TEKST og operatoren & (ampersand), hvis du vil kombinere tekst med en dato eller et klokkeslæt.

Kolonne1

Kolonne2

Formel

Beskrivelse (resultat)

Faktureringsdato

05.06.07

="Fakturadato: "&TEKST([Kolonne2]; "d-mmm-åååå")

Kombinerer tekst med en dato (Fakturadato: 5-jun-2007)

Afregningsdato

05.06.07

=[Kolonne1]&" "&TEKST([Kolonne2]; "mmm-dd-åååå")

Kombinerer tekst og dato fra forskellige kolonner i én kolonne (Afregningsdato Jun-05-2007)

Sammenlign indhold i kolonner

Brug funktionerne EKSAKT og ELLER, hvis du vil sammenligne en kolonne med en anden kolonne eller en liste over værdier.

Kolonne1

Kolonne2

Formel

Beskrivelse (resultat)

BD122

BD123

=EKSAKT([Kolonne1];[Kolonne2])

Sammenligner indholdet af to første kolonner (FALSK)

BD122

BD123

=EKSAKT([Kolonne1]; "BD122")

Sammenligner indholdet af Kolonne1 og strengen "BD122" (SAND)

Kontrollér, om en kolonneværdi eller en del af den svarer til en bestemt tekst

Brug funktionerne HVIS, FIND, SØG og ER.TAL, hvis du vil undersøge, om en hel eller dele af en kolonneværdi er lig med en bestemt tekst.

Kolonne1

Formel

Beskrivelse (resultat)

Dahl

=HVIS([Kolonne1]="Dahl", "OK"; "Ikke OK")

Undersøger, om Kolonne1 er lig med værdien Dahl (OK)

Dahl

=HVIS(ER.TAL(FIND("d",[Kolonne1])); "OK"; "Ikke OK")

Undersøger, om Kolonne1 indeholder bogstavet d (OK)

BD123

=ER.TAL(FIND("BD";[Kolonne1]))

Kontrollerer, om Kolonne1 indeholder BD (Ja)

Optæl ikke-tomme kolonner

Brug funktionen TÆLV, hvis du vil tælle kolonner, der ikke er tomme.

Kolonne1

Kolonne2

Kolonne3

Formel

Beskrivelse (resultat)

Salg

19

=TÆLV([Kolonne1]; [Kolonne2])

Tæller antallet af kolonner, der ikke er tomme (2)

Salg

19

= COUNTA([Column1], [Column2],[Column3])

Tæller antallet af kolonner, der ikke er tomme (2)

Fjern tegn fra tekst

Brug funktionerne LÆNGDE, VENSTRE og HØJRE, hvis du vil fjerne tegn fra tekst.

Kolonne1

Formel

Beskrivelse (resultat)

Vitamin A

=VENSTRE([Kolonne1];LÆNGDE([Kolonne1])-2)

Returnerer 7 (9-2) tegn startende fra venstre (Vitamin)

Vitamin B1

=HØJRE([Kolonne1]; LÆNGDE([Kolonne1])-8)

Returnerer 2 (10-8) tegn startende fra højre (B1)

Fjern mellemrum fra begyndelsen og slutningen af en kolonne

Brug funktionen FJERN.OVERFLØDIGE.BLANKE, hvis du vil fjerne mellemrum fra en kolonne.

Kolonne1

Formel

Beskrivelse (resultat)

Hej alle sammen!

=FJERN.OVERFLØDIGE.BLANKE([Kolonne1])

Fjerner mellemrum fra begyndelsen og slutningen (Hej alle sammen!)

Gentag et tegn i en kolonne

Brug funktionen GENTAG, hvis du vil gentage et tegn i en kolonne.

Formel

Beskrivelse (resultat)

=GENTAG(".";3)

Gentager et punktum 3 gange (...)

=GENTAG("-";10)

Gentager en bindestreg 10 gange (----------)

Se også

Liste over alle funktioner (efter kategori)

Bemærk: Ansvarsfraskrivelse for maskinoversættelse: Denne artikel er blevet oversat af et computersystem uden menneskelig indgriben. Microsoft tilbyder disse maskinoversættelse for at hjælpe ikke-engelsktalende brugere til at kunne nyde indhold om Microsofts produkter, tjenester og teknologier. Da artiklen er maskinoversat, kan den indeholde forkerte ord eller syntaks- eller grammatikfejl.

Del Facebook Facebook Twitter Twitter Mail Mail

Var disse oplysninger nyttige?

Fantastisk! Har du mere feedback?

Hvordan kan vi forbedre det?

Tak for din feedback!

×