Brug af indlejrede funktioner i en formel

Vigtigt: Denne artikel er maskinoversat. Se ansvarsfraskrivelsen. Du kan finde den engelske version af denne artikel her til din orientering.

Når du bruger en funktion som et af argumenterne i en formel, der bruger en funktion, kaldes det indlejring. Vi refererer til den funktion som en indlejret funktion. Hvis du f.eks. indlejrer funktionerne MIDDEL og SUM i argumenterne til funktionen HVIS, vil følgende formel kun opsummere et sæt tal (G2:G5), hvis gennemsnittet af et andet sæt af tal (F2:F5), er større end 50. Ellers returneres 0.

Indlejrede funktioner

1. funktionerne MIDDEL og SUM er indlejret i funktionen Hvis.

Du kan indlejre op til 64 niveauer af funktioner i en formel.

  1. Klik på den celle, hvor du vil angive formlen.

  2. Hvis du vil starte formlen med funktionen, skal du klikke på Indsæt funktion Knapflade på formellinjen Knapflade .

    Excel indsætter lighedstegnet (=) for dig.

  3. Vælg Alle i feltet Eller vælg en kategori.

    Hvis du kender funktionskategorierne, kan du også vælge en kategori.

    Hvis du ikke er helt sikker på, hvilken funktion du skal bruge, kan du skrive et spørgsmål, som beskriver, hvad du vil gøre, i feltet Søg efter en funktion ("addere tal" returnerer f.eks. funktionen SUM).

    Tip!: Lære mere om formler generelt se Oversigt over formler.

    Du finder en liste over funktionerne i Excel-funktioner (alfabetisk) eller Excel-funktioner (efter kategori).

  4. Hvis du vil angive en anden funktion som et argument, skal du skrive funktionen i det ønskede argumentfelt.

    De formeldele, der er vist i dialogboksen Funktionsargumenter, afspejler den funktion, som du valgte i det forrige trin.

    Hvis du klikkede på HVIS, vises argumenterne for funktionen HVIS i dialogboksen Funktionsargumenter. Hvis du vil indlejre en anden funktion, kan du angive den i argumentfeltet. Du kan f.eks. angive SUM(G2:G5) i feltet Værdi_hvis_sand for funktionen HVIS.

  5. Angiv de resterende argumenter i formlen.

    I stedet for at skrive cellereferencer kan du også markere de celler, du vil referere til. Klik på Knapflade for at minimere dialogboksen, markér de celler, du vil referere til, og klik derefter på Knapflade for at udvide dialogboksen igen.

    Tip: Du kan få flere oplysninger om funktionen og de tilhørende argumenterne ved at klikke på Hjælp til denne funktion.

  6. Når du har angivet argumenterne for formlen, skal du klikke på OK.

Eksempler

Følgende viser et eksempel på brug af, indlejrede Hvis-funktioner til at tildele en bogstavkarakter til en numerisk teste resultat.

Kopiér eksempeldataene i følgende tabel, og sæt dem ind i celle A1 i et nyt Excel-regneark. For at få formlerne til at vise resultater skal du markere dem, trykke på F2 og derefter trykke på Enter. Hvis der er brug for det, kan du justere bredden på kolonnerne, så du kan se alle dataene.

Resultat

45

90

78

Formel

Beskrivelse

Resultat

'=HVIS(A2>89;"A";HVIS(A2>79;"B";HVIS(A2>69;"C";HVIS(A2>59;"D";"F"))))

Bruger indlejrede HVIS-betingelser til at tildele karakteren i celle A2 et karakterbogstav.

=HVIS(A2>89;"A";HVIS(A2>79;"B";HVIS(A2>69;"C";HVIS(A2>59;"D";"F"))))

'=HVIS(A3>89;"A";HVIS(A3>79;"B";HVIS(A3>69;"C";HVIS(A3>59;"D";"F"))))

Bruger indlejrede HVIS-betingelser til at tildele karakteren i celle A3 et karakterbogstav.

=HVIS(A3>89;"A";HVIS(A3>79;"B";HVIS(A3>69;"C";HVIS(A3>59;"D";"F"))))

'=HVIS(A4>89;"A";HVIS(A4>79;"B";HVIS(A4>69;"C";HVIS(A4>59;"D";"F"))))

Bruger indlejrede HVIS-betingelser til at tildele karakteren i celle A4 et karakterbogstav.

=HVIS(A4>89;"A";HVIS(A4>79;"B";HVIS(A4>69;"C";HVIS(A4>59;"D";"F"))))

Toppen af siden

Bemærk: Ansvarsfraskrivelse for maskinoversættelse: Denne artikel er blevet oversat af et computersystem uden menneskelig indgriben. Microsoft tilbyder disse maskinoversættelse for at hjælpe ikke-engelsktalende brugere til at kunne nyde indhold om Microsofts produkter, tjenester og teknologier. Da artiklen er maskinoversat, kan den indeholde forkerte ord eller syntaks- eller grammatikfejl.

Del Facebook Facebook Twitter Twitter Mail Mail

Var disse oplysninger nyttige?

Fantastisk! Har du mere feedback?

Hvordan kan vi forbedre det?

Tak for din feedback!

×