Brug af en formel til at anvende betinget formatering

Betinget formatering fremhæver hurtigt vigtige oplysninger i et regneark. Nogle gange er de integrerede formateringsregler dog ikke helt tilstrækkelige. Hvis du føjer din egen formel til en regel for betinget formatering, gør det tingene meget mere effektive, så du kan udføre ting, du ikke kan med de integrerede regler.

Oprette regler for betinget formatering med formel

Antag f.eks., at du vil spore fødselsdage for dine patienter i tandlægeklinikken for at få vist kommende fødselsdage og derefter markere dem som have modtaget en fødselsdagshilsen fra dig.

I dette regneark får vi vist de ønskede oplysninger ved at bruge betinget formatering, som fungerer via to regler, der hver indeholder en formel. Den første regel (i kolonne A) formaterer kommende fødselsdage, og reglen i kolonne C formaterer celler, så snart der skrives "J", hvilket angiver, at fødselsdagshilsenen er blevet sendt.

Eksempel på betinget formatering i Excel

Sådan oprettes den første regel:

  1. Markér cellerne A2 til og med A7. Gør det ved at trække fra A2 til A7.

  2. Klik derefter på Hjem > Betinget formatering > Ny regel.

  3. I dialogboksen Ny formateringsregel skal du klikke på Brug en formel til at bestemme, hvilke celler der skal formateres.

  4. Under Formatér værdier, hvor denne formel er sand skal du skrive formlen: =A2>IDAG()

    I formlen bruges funktionen IDAG til at se, om datoerne i kolonne A er større end dags dato (i fremtiden). I så fald formateres cellerne.

  5. Klik på Formatér.

  6. I feltet Farve skal du vælge Rød. I feltet Typografi skal du vælgeFed.

  7. Klik på OK, indtil dialogboksene er lukket.

    Formateringen anvendes på kolonne A.

Sådan oprettes den anden regel:

  1. Markér celle C2 til og med celle C7.

  2. Gentag trin 2 til og med 4 ovenfor, og skriv denne formel: =C2="Y"

    Formlen tester, om cellerne i kolonne C indeholder "J" (anførselstegnene omkring dette J fortæller Excel, at dette er tekst). I så fald formateres cellerne.

  3. I feltet Farve skal du vælge Hvid. I feltet Typografi skal du vælgeFed.

  4. Klik på fanen Fyld, og vælg Grøn.

    Formateringen anvendes på kolonne C.

Prøv det!

Du kan kopiere den følgende tabel til et regneark i Excel – sørg for at sætte den ind i celle A1. Markér derefter cellerne D2:D11, og opret en ny regel for betinget formatering, som anvender formlen nedenfor. Når du opretter reglen, skal du sikre dig, at den gælder for cellerne D2:D11. Angiv et farveformat, der skal anvendes på celler, der opfylder kriterierne (der er altså mere end én forekomst af en by i kolonne D – Seattle og Spokane).

Fornavn

Efternavn

Telefon

By

Annik

Stahl

555-1213

Seattle

Josh

Barnhill

555-1214

Portland

Colin

Wilcox

555-1215

Spokane

Harry

Miller

555-1216

Edmonds

Jonathan

Foster

555-1217

Atlanta

Erin

Hagens

555-1218

Spokane

Jeff

Phillips

555-1219

Charleston

Gordon

Hee

555-1220

Youngstown

Yossi

Ran

555-1221

Seattle

Anna

Bedecs

555-1222

San Francisco

=TÆL.HVIS($D$2:$D$11;D2)>1

Mere om betinget formatering

Del Facebook Facebook Twitter Twitter Mail Mail

Var disse oplysninger nyttige?

Fantastisk! Har du mere feedback?

Hvordan kan vi forbedre det?

Tak for din feedback!

×