Brug af argumentet tabelmatrix i en opslagsfunktion

Vigtigt: Denne artikel er maskinoversat. Se ansvarsfraskrivelsen. Du kan finde den engelske version af denne artikel her til din orientering.

Når du opretter en formel ved hjælp af funktionerne LOPSLAG eller VOPSLAG, skal du angive en argumentet tabelmatrix, som er et celleområde, f.eks. D2:F39. Funktionen søger dette område efter de data, du prøver at finde.

Argumentet tabelmatrix er altid det andet argument i en funktion af typen LOPSLAG eller VOPSLAG (det første argument er den værdi, du forsøger at finde). Disse funktioner kan ikke fungere uden argumentet tabelmatrix.

Dit første argument kan være en bestemt værdi som "41" eller "jensen", eller det kan være en cellereference, f.eks. F2. Det første argument kan se ud som følger:

=LOPSLAG(F2,...

Argumentet tabelmatrix følger altid opslagsværdien, som her:

=LOPSLAG(F2,B4:D39, ...

Det celleområde, der er angivet i argumentet tabelmatrix, kan bruge relative eller absolutte cellereferencer. Hvis du vil kopiere formlen til andre celler, skal du bruge absolutte cellereferencer (bemærk $-symbolerne) på følgende måde:

=LOPSLAG(F2,$B$2:BD$39, ...

Hvis cellerne i argumentet tabelmatrix er i et andet regneark i projektmappen, skal argumentet medtage navnet på arket efterfulgt af et udråbstegn. Syntaksen ville se således ud:

=LOPSLAG(F2,Ark2!$C$14:E$42, ...

Den kolonne, der indeholder de værdier, du prøver at finde, er det tredje argument, du skal angive. Dette kaldes opslagskolonnen. Hvis de værdier, du vil have vist, findes i kolonne D (den tredje kolonne i det pågældende celleområde), er det sidste argument et 3-tal.

=LOPSLAG(F2,B4:D39,3)

Selvom det er valgfrit, anbefales det, at du bruger et fjerde argument enten Falsk eller Sand. Brug Falsk, hvis du leder efter en bestemt værdi.

=LOPSLAG(F2,B4:D39,3,Falsk)

Hvis du bruger Sand, eller lader det fjerde argument være tomt, returnerer funktionen en match, der er tilnærmet værdien i dit første argument. Så hvis dit første argument er "jensen", vil LOPSLAG returnere "Jensen", "Jensenius" osv. Hvis du derimod bruger Falsk, returnerer funktionen kun "Jensen" som et præcis match, som er det de fleste foretrækker.

For at gøre brugen af Sand endnu mere besværlig kan du få det forkerte resultat, hvis din opslagskolonne (den kolonne, du angav i dit tredje argument) ikke er sorteret i stigende rækkefølge (A til Å eller laveste til højeste tal).

Få mere at vide om funktionerne LOPSLAG og VOPSLAG under opslags- og referencefunktioner (reference).

Bemærk: Ansvarsfraskrivelse for maskinoversættelse: Denne artikel er blevet oversat af et computersystem uden menneskelig indgriben. Microsoft tilbyder disse maskinoversættelse for at hjælpe ikke-engelsktalende brugere til at kunne nyde indhold om Microsofts produkter, tjenester og teknologier. Da artiklen er maskinoversat, kan den indeholde forkerte ord eller syntaks- eller grammatikfejl.

Del Facebook Facebook Twitter Twitter Mail Mail

Var disse oplysninger nyttige?

Fantastisk! Har du mere feedback?

Hvordan kan vi forbedre det?

Tak for din feedback!

×