Zjištění počtu znaků v buňkách Excelu 2016 pro Mac

Když potřebujete spočítat znaky v buňkách, použijte funkci DÉLKA. Funkce vrátí počet písmen, číslic, znaků a všech mezer. Třeba věta „Dneska je venku 36 stupňů, tak se půjdu koupat.“ je dlouhá 47 znaků (mimo uvozovek). To zahrnuje 35 písmen, 2 číslice, 8 mezer, čárku a tečku.

  • Když chcete tuto funkci použít, zadejte do řádku vzorců vzorec =DÉLKA(buňka) a stiskněte Enter. Argumentem buňka se v těchto příkladech myslí buňka, pro kterou chcete spočítat počet znaků, třeba B1.

  • Pokud chcete znaky spočítat ve víc než jedné buňce, zadejte vzorec a pak ho zkopírujte a vložte do ostatních buněk.

  • Pokud chcete zjistit celkový počet znaků v několika buňkách, použijte společně s funkcí DÉLKA funkci SUMA. Příklad: =SUMA((DÉLKA(buňka1);DÉLKA(buňka2);(DÉLKA(buňka3)))). V tomto příkladu zjistí funkce DÉLKA počty znaků v jednotlivých buňkách a funkce SUMA počty sečte.

  • Ke spočítání některých speciálních znaků v buňkách můžete použít funkci DÉLKA s funkcí DOSADIT. Třeba pokud byste chtěli vědět, kolik malých písmen „b“ bylo v buňce, použili byste tenhle vzorec: = DÉLKA(buňka1)-DÉLKA(DOSADIT(buňka1;"b";""))

Vyzkoušejte si to

Zadejte do nového listu Excelu následující data. Začněte v buňce A1.

Textové řetězce

Vzorce

Příliš žluťoučký kůň

Příliš žluťoučký kůň úpěl

Příliš žluťoučký kůň úpěl ďábelské ódy

Zjištění počtu znaků v jedné buňce

  1. Klikněte na buňku B2.

  2. Zadejte do buňky vzorec =DÉLKA(A2) a stiskněte Enter.

Vzorec spočítá znaky v buňce A2 včetně všech mezer (výsledek je 20). Pokud jsou za závěrečnou tečkou nějaké mezery, vzorec je započítá taky.

Zjištění počtu znaků ve víc buňkách

  1. Stisknutím CTRL+C zkopírujte buňku B2.

  2. Stisknutím CTRL+V vložte její vzorec do buněk B3:B4.

Vzorec se tím zkopíruje do buněk B3 a B4 a funkce zjistí počty znaků v jednotlivých buňkách (25 a 38).

Zjištění celkového počtu znaků

  1. Klikněte na buňku B6.

  2. Zadejte do buňky vzorec =SUMA(DÉLKA(A2);DÉLKA(A3);DÉLKA(A4)) a stiskněte Enter.

Tato funkce zjistí počty znaků v každé ze tří buněk a zobrazí jejich součet (83).

Zjištění počtu konkrétních znaků v buňkách

  1. Klikněte na buňku C4.

  2. Zadejte do buňky =DÉLKA(A4)-DÉLKA(DOSADIT(A4;"b";"")) a stiskněte klávesu Enter.

Spočítají se všechna malá písmena „b“ v buňce A4, výsledek je 1.

Rozšiřte své dovednosti s Office
Projít školení
Získejte nové funkce jako první
Připojte se k účastníkům programu Office Insiders

Byly tyto informace užitečné?

Děkujeme vám za zpětnou vazbu.

Děkujeme vám za váš názor. Vypadá to, že bude užitečné, když vás spojíme s některým z našich agentů z podpory Office.

×