Zjištění počtu znaků v buňkách

Zjištění počtu znaků v buňkách

Když potřebujete spočítat znaky v buňkách, použijte funkci DÉLKA. Funkce vrátí počet písmen, číslic, znaků a všech mezer. Třeba věta „Dneska je venku 36 stupňů, tak se půjdu koupat.“ je dlouhá 47 znaků (mimo uvozovek). To zahrnuje 35 písmen, 2 číslice, 8 mezer, čárku a tečku.

  • Když chcete tuhle funkci použít, zadejte do řádku vzorců vzorec =DÉLKA(buňka) a stiskněte Enter. Argumentem buňka se v těchto příkladech myslí buňka, pro kterou chcete spočítat počet znaků, třeba B1.

  • Pokud chcete zjistit počty znaků ve více buňkách, zadejte vzorec do jedné buňky a pak přetáhněte úchyt v pravém dolním rohu buňky (ve tvaru černého čtverečku) doprava nebo dolů. Tím vyplníte požadovanou oblast buněk vzorci pro výpočet počtu znaků.

Zadání více funkcí DÉLKA v listu

  • Pokud chcete zjistit celkový počet znaků v několika buňkách, použijte společně s funkcí DÉLKA funkci SUMA. Příklad: =SUMA((DÉLKA(buňka1);DÉLKA(buňka2);(DÉLKA(buňka3)))). V tomto příkladu zjistí funkce DÉLKA počty znaků v jednotlivých buňkách a funkce SUMA počty sečte.

Vyzkoušejte si to

Pomocí příkladů v následujícím sešitu uvidíte, jak se funkce DÉLKA používá.

Zkopírujte následující tabulku a na excelovém listu ji vložte do buňky A1. Přetažením vzorce z buňky B2 do buněk B3:B4 zjistíte délku textu v buňkách ve sloupci A.

Textové řetězce

Vzorce

Příliš žluťoučký kůň

=DÉLKA(A2)

Příliš žluťoučký kůň úpěl

Příliš žluťoučký kůň úpěl ďábelské ódy.

Zjištění počtu znaků v jedné buňce

  1. Na listu List1 tohoto ukázkového sešitu klikněte na buňku B2.

  2. Zadejte do buňky vzorec =DÉLKA(A2) a stiskněte Enter.

Vzorec spočítá znaky v buňce A1, a to včetně všech mezer. Pokud jsou za závěrečnou tečkou nějaké mezery, vzorec je započítá taky.

Zjištění počtu znaků ve víc buňkách

  1. V ukázkovém sešitu klikněte na buňku B2.

  2. Zadejte do buňky vzorec =DÉLKA(A2).

  3. Stisknutím kláves CTRL+C zkopírujte buňku B2 a stisknutím kláves CTRL+V vložte její vzorec do buněk B3:B4.

Vzorec se tím zkopíruje do buněk B3 a B4 a funkce DÉLKA zjistí počty znaků v jednotlivých buňkách (20, 25 a 39).

Zjištění celkového počtu znaků

  1. V ukázkovém sešitu klikněte na buňku B6.

  2. Zadejte do buňky vzorec =SUMA(DÉLKA(A2);DÉLKA(A3);DÉLKA(A4)) a stiskněte Enter.

Tato funkce zjistí počty znaků v každé ze tří buněk a zobrazí jejich součet (90).

Rozšiřte své znalosti a dovednosti
Projít školení
Získejte nové funkce jako první
Připojte se k účastníkům programu Office Insiders

Byly tyto informace užitečné?

Děkujeme vám za zpětnou vazbu.

Děkujeme vám za váš názor. Vypadá to, že bude užitečné, když vás spojíme s některým z našich agentů z podpory Office.

×