Vytvoření, spuštění, úprava nebo odstranění makra v Office pro Mac

Pokud chcete při plnění častých úkolů ušetřit čas, můžete jejich postup zaznamenat jako makro. Když pak budete chtít provést některý z těchto nahraných úkolů, můžete aktivovat makro, abyste mohli provést příslušné kroky. 

Word

Ve Wordu 2016 pro Mac můžete vytvořit makro, které má klávesovou zkratku, spustit makro a odstranit makro, které už nepotřebujete.

  1. Klikněte na Zobrazení > Makra > Zaznamenat makro.

    Na kartě zobrazení klikněte na makro a pak kliknutím na nahrát makro vytvořte makro.
  2. Zadejte název makra nebo přijměte výchozí hodnotu, kterou Word poskytuje.

    Do pole název makra zadejte název svého makra nebo přijměte název generického Wordu.
  3. Pokud chcete toto makro použít ve všech nových dokumentech, které vytvoříte, zkontrolujte, že je v seznamu v makru úložiště vybraná možnost všechny dokumenty (Normal) .

  4. Kliknutím na klávesnice přiřaďte svému makru kombinaci kláves.

    Word zobrazí dialogové okno vlastní klávesnice .

  5. Do pole Klávesová zkratka pro stisknutí klávesy New stiskněte kombinaci kláves.

    Po stisknutí kombinace se v Wordu zobrazí příkaz nebo makro, které je již přiřazené k kombinaci kláves.

    Když stisknete kombinaci kláves, Word zobrazí příkaz nebo akci, která je k této kombinaci kláves přiřazena (pokud existují).

  6. Pokud je vybraná kombinace kláves už přiřazená, odstraňte ji z pole Klávesová zkratka nového stisknutí klávesy New a pak zvolte novou kombinaci kláves.

    Přejděte k dalšímu kroku po nalezení nepřiřazené kombinace klíčů.

    Word rozpozná, kdy jste stiskli kombinaci kláves, která ještě není přiřazená k příkazu nebo makru.
  7. Chcete-li tuto klávesovou zkratku použít v některých nových dokumentech, ujistěte se, že je v seznamu Uložit změny v šabloně Normal. dotm.

    Vyberte Normal. dotm, aby se makro mohlo používat v nových dokumentech, které vytvoříte.
  8. Klikněte na tlačítko Přiřadit.

  9. Až budete chtít makro nahrát, klikněte na OK.

  10. Pro každý krok úkolu klikněte na příkaz nebo stiskněte tlačítko.

    Word záznamy kliknutí a stisknutí kláves, ale nezaznamenává text, který vyberete myší. Pokud chcete při záznamu makra vybrat text, použijte klávesnici.

  11. Pro ukončení záznamu klikněte na Zobrazení > Makra > Zastavit záznam.

    Kliknutím na Zastavit záznam v nabídce makra zastavíte záznam makra.

Chcete-li spustit makro, stiskněte klávesovou zkratku, kterou jste přiřadili, nebo makro spusťte ze seznamu maker .

  1. Klikněte na Zobrazení > Makra > Zobrazit makra.

    Kliknutím na Zobrazit makra zobrazíte a upravíte makra spojená s aktuálním dokumentem.
  2. V seznamu název makravyberte makro, které chcete spustit.

  3. Klikněte na Spustit.

    Po výběru makra v části název makra spusťte kliknutím na spustit.

  1. Klikněte na Zobrazení > Makra > Zobrazit makra.

    Kliknutím na Zobrazit makra zobrazíte a upravíte makra spojená s aktuálním dokumentem.
  2. Ověřte, že umístění určené makry obsahuje umístění makra, které chcete odstranit.

    V seznamu makra vyberte umístění maker, která chcete zobrazit.

    V seznamu bude dokument, který je otevřený v aktuálním okně, i globální šablona a příkazy Word.

  3. V části název makravyberte makro, které chcete odstranit, a potom klikněte na symbol minus pod seznamem.

    Vyberte makro, které chcete odstranit, a klikněte na znaménko minus pod seznamem.
  4. Když Word zobrazí dotaz, jestli chcete makro odstranit, klikněte na Ano.

Excel

V Excelu 2016 pro Mac můžete vytvořit makro, které má klávesovou zkratku, spustit makro a odstranit makro, které už nepotřebujete.

Když zaznamenáváte makro, zaznamená program pro záznam makra všechny kroky nutné k provedení akcí, které má makro provést. Tyto kroky mohou zahrnovat psaní textu či čísel, kliknutí na buňky nebo příkazy na pásu karet či v nabídkách, formátování, výběr buněk, řádků nebo sloupců a výběr buněk přetažením myši na listu.

Poznámka: Na pásu karet jsou k dispozici také příkazy pro nahrávání, vytváření a odstraňování maker a další upřesňující funkce. Další informace o použití karty Vývojář naleznete v článku Vytvoření nebo odstranění makra v excelu 2016 pro Mac na kartě Vývojář.

  1. Vyberte nástroje > >nahrát nový.

    Výběr nástroje, pak makra a následné nahrání nového makra

  2. Do pole Název makra zadejte název makra.

    Zadání názvu makra, umístění a klávesové zkratky

  3. Pokud chcete pro makro vytvořit klávesovou zkratku, zadejte ji do pole Option + cmd .

  4. V rozevíracím seznamu vyberte místo pro makro.

    Pokud chcete makro uložit

    Klikněte na

    V dokumentu, ve kterém vytváříte makro

    This Workbook

    do všech otevřených dokumentů

    New Workbook

    tak, aby bylo k dispozici při každém použití Excelu

    Personal Macro Workbook

  5. Option Přidejte popis makra.

  6. Až budete připraveni nahrávat, klikněte na OK.

  7. Pro každý krok úkolu klikněte na příkaz nebo stiskněte tlačítko.

  8. Pokud chcete nahrávání ukončit, vyberte nástroje > makro > Zastavit záznam. (Tento krok se do makra nezaznamená.)

    Vyberte Zastavit záznam

Pokud chcete spustit makro, stiskněte klávesovou zkratku, kterou jste přiřadili, nebo makro spusťte v dialogovém okně makra .

  1. Na kartě Zobrazení klikněte na Zobrazit makra.

  2. V místní nabídce klikněte na makra a vyberte Tento sešit.

  3. Vyberte makro ze seznamu a klikněte na Spustit.

    Excel for Mac Macros dialog

  1. Vyberte nástroje > makro > makra.

    Vyberte makro a pak vyberte makra.

  2. Vyberte makro, které chcete odstranit, a stiskněte symbol mínus.

    Vyberte název makra a pak vyberte minus.

  3. Zobrazí se potvrzovací zpráva. Odstranění potvrďte kliknutím na Ano.

    Potvrdit odstranění

Můžete také odstranit makro z karty vývojář .

  1. Na kartě Vývojář klikněte na Makra.

  2. V seznamu klikněte na makro, které chcete odstranit, a pak klikněte na tlačítko pro odstranění.

    Select a macro and click the minus sign to delete it

Word

Chcete-li automatizovat opakovaný úkol, můžete ve Wordu rychle vytvořit Makro. Můžete také použít Visual Basic Editor v jazyce Microsoft Visual Basic for Applications k napsání vlastního makra nebo jeho částí do nového makra.

Při záznamu makra se zaznamenávají všechny kroky, které jsou nutné k dokončení akcí, které má makro provádět. Navigace zpátky na kartu a zastavení nahrávání se však nenahraje.

  1. Na kartě Developer (Vývojář) klikněte v části Visual Basic na Record (Nahrát).

    Word Developer tab, Visual Basic group

    Pokud není karta Developer k dispozici

    1. Na pravé straně pásu karet klikněte na Action pop-up menu a potom na Předvolby pásu karet.

    2. V části Přizpůsobit zaškrtněte políčko Vývojář.

  2. Do pole Název makra zadejte název makra.

  3. V místní nabídce Store macro in (Uložit makro do) vyberte jednu z těchto možností:

    Pokud chcete makro uložit

    Klikněte na

    do dokumentu, ve kterém makro vytváříte

    [název dokumentu] (document) ([název dokumentu] (dokument))

    do všech otevřených dokumentů

    All Documents (Normal) (Všechny dokumenty (normální))

  4. Klikněte na tlačítko OK a proveďte akce, které chcete zaznamenat.

  5. Na kartě Developer klikněte v části Visual Basic na Stop (Zastavit).

Makro můžete vytvořit v integrovaném Visual Basic Editoru.

  1. Na kartě Developer klikněte v části Visual Basic na Editor.

    Word Developer tab, Visual Basic group

    Pokud není karta Developer k dispozici

    1. Na pravé straně pásu karet klikněte na Action pop-up menu a potom na Předvolby pásu karet.

    2. V části Customize zaškrtněte políčko Developer.

  2. Pokud potřebujete vložit modul, klikněte ve Visual Basic Editoru na příkaz Module (Modul) v nabídce Insert (Vložit).

  3. V okně kódu modulu zadejte nebo vložte kód makra, který chcete použít.

  4. Po dokončení klikněte v nabídce Word na Close and Return to Microsoft Word (Zavřít a vrátit se do Microsoft Wordu).

  1. Na kartě Developer klikněte v části Visual Basic na Macros (Makra).

    Word Developer tab, Visual Basic group

    Pokud není karta Developer k dispozici

    1. Na pravé straně pásu karet klikněte na Action pop-up menu a potom na Předvolby pásu karet.

    2. V části Přizpůsobit zaškrtněte políčko Vývojář.

  2. V seznamu klikněte na makro, které chcete spustit, a pak klikněte na Run (Spustit).

K úpravě maker se používá Visual Basic Editor.

  1. Na kartě Developer klikněte v části Visual Basic na Macros.

    Word Developer tab, Visual Basic group

    Pokud není karta Developer k dispozici

    1. Na pravé straně pásu karet klikněte na Action pop-up menu a potom na Předvolby pásu karet.

    2. V části Přizpůsobit zaškrtněte políčko Vývojář.

  2. V seznamu klikněte na makro, které chcete upravit, a pak klikněte na Edit (Upravit).

    Spustí se Visual Basic Editor.

  3. Proveďte požadované změny.

  4. Po dokončení klikněte v nabídce Word na Close and Return to Microsoft Word.

  1. Na kartě Developer klikněte v části Visual Basic na Macros.

    Word Developer tab, Visual Basic group

    Pokud není karta Developer k dispozici

    1. Na pravé straně pásu karet klikněte na Action pop-up menu a potom na Předvolby pásu karet.

    2. V části Přizpůsobit zaškrtněte políčko Vývojář.

  2. V seznamu klikněte na makro, které chcete zkopírovat, a pak klikněte na Edit.

    Spustí se Visual Basic Editor.

  3. V okně s kódem v editoru Visual Basicu vyberte řádky makra, které chcete zkopírovat.

    Tip: Pokud chcete kopírovat celé makro, musí být součástí výběru řádky Sub a End Sub.

  4. V nabídce Edit (Úpravy) klikněte na příkaz Copy (Kopírovat).

  5. V poli Project (Projekt) v okně s kódem klikněte na modul, do kterého chcete kód umístit.

  6. V nabídce Edit (Úpravy) klikněte na příkaz Paste (Vložit).

  1. Na kartě Developer klikněte v části Visual Basic na Macros.

    Word Developer tab, Visual Basic group

    Pokud není karta Developer k dispozici

    1. Na pravé straně pásu karet klikněte na Action pop-up menu a potom na Předvolby pásu karet.

    2. V části Customize zaškrtněte políčko Developer.

  2. V seznamu klikněte na makro, které chcete odstranit, a pak klikněte na Delete (Odstranit).

PowerPoint

Chcete-li automatizovat opakovaný úkol, můžete v aplikaci PowerPoint vytvořit Makro pomocí jazyka Visual Basic for Applications.

Makro můžete vytvořit v integrovaném Visual Basic Editoru.

  1. Na kartě Developer klikněte v části Visual Basic na Editor.

    PowerPoint Developer tab, Visual Basic group

    Pokud není karta Developer k dispozici

    1. Na pravé straně pásu karet klikněte na Action pop-up menu a potom na Předvolby pásu karet.

    2. V části Customize (Přizpůsobit) zaškrtněte políčko Developer.

  2. Pokud potřebujete vložit modul, klikněte ve Visual Basic Editoru na příkaz Module (Modul) v nabídce Insert (Vložit).

  3. V okně kódu modulu zadejte nebo vložte kód makra, který chcete použít.

  4. Po dokončení klikněte v nabídce PowerPoint na Close and Return to Microsoft PowerPoint (Zavřít a vrátit se do Microsoft PowerPointu).

  1. Na kartě Developer klikněte v části Visual Basic na Macros (Makra).

    PowerPoint Developer tab, Visual Basic group

    Pokud není karta Developer k dispozici

    1. Na pravé straně pásu karet klikněte na Action pop-up menu a potom na Předvolby pásu karet.

    2. V části Přizpůsobit zaškrtněte políčko Vývojář.

  2. V seznamu klikněte na makro, které chcete spustit, a pak klikněte na Run (Spustit).

K úpravě maker se používá Visual Basic Editor.

  1. Na kartě Developer klikněte v části Visual Basic na Macros.

    PowerPoint Developer tab, Visual Basic group

    Pokud není karta Developer k dispozici

    1. Na pravé straně pásu karet klikněte na Action pop-up menu a potom na Předvolby pásu karet.

    2. V části Přizpůsobit zaškrtněte políčko Vývojář.

  2. V seznamu klikněte na makro, které chcete upravit, a pak klikněte na Edit (Upravit).

    Spustí se Visual Basic Editor.

  3. Proveďte požadované změny.

  4. Po dokončení klikněte v nabídce PowerPoint na Close and Return to Microsoft PowerPoint (Zavřít a vrátit se do Microsoft PowerPointu).

  1. Na kartě Developer klikněte v části Visual Basic na Macros.

    PowerPoint Developer tab, Visual Basic group

    Pokud není karta Developer k dispozici

    1. Na pravé straně pásu karet klikněte na Action pop-up menu a potom na Předvolby pásu karet.

    2. V části Přizpůsobit zaškrtněte políčko Vývojář.

  2. V seznamu klikněte na makro, které chcete zkopírovat, a pak klikněte na Edit.

    Spustí se Visual Basic Editor.

  3. V okně s kódem v editoru Visual Basicu vyberte řádky makra, které chcete zkopírovat.

    Tip: Pokud chcete kopírovat celé makro, musí být součástí výběru řádky Sub a End Sub.

  4. V nabídce Edit (Úpravy) klikněte na příkaz Copy (Kopírovat).

  5. V poli Project (Projekt) v okně s kódem klikněte na modul, do kterého chcete kód umístit.

  6. V nabídce Edit (Úpravy) klikněte na příkaz Paste (Vložit).

  1. Na kartě Developer klikněte v části Visual Basic na Macros.

    PowerPoint Developer tab, Visual Basic group

    Pokud není karta Developer k dispozici

    1. Na pravé straně pásu karet klikněte na Action pop-up menu a potom na Předvolby pásu karet.

    2. V části Customize zaškrtněte políčko Developer.

  2. V seznamu klikněte na makro, které chcete odstranit, a pak klikněte na Delete (Odstranit).

Excel

Chcete-li automatizovat opakovaný úkol, můžete rychle vytvořit Makro v Excelu. Můžete také použít Visual Basic Editor v jazyce Microsoft Visual Basic for Applications k napsání vlastního makra nebo jeho částí do nového makra.

Zaznamenají se všechny kroky potřebné k provedení akcí, které má makro vykonávat. Navigace zpátky na kartu a zastavení nahrávání se však nenahraje.

  1. Na kartě Developer (Vývojář) klikněte v části Visual Basic na Record (Nahrát).

    Excel Developer tab, Visual Basic group

    Pokud není karta Developer k dispozici

    1. Na pravé straně pásu karet klikněte na Action pop-up menu a potom na Předvolby pásu karet.

    2. V části Přizpůsobit zaškrtněte políčko Vývojář.

  2. Do pole Název makra zadejte název makra.

    Tip: Pokud chcete pro makro vytvořit klávesovou zkratku, zadejte nějaké písmeno do pole Option+Cmd+.

  3. V místní nabídce Store macro in (Uložit makro do) vyberte jednu z těchto možností:

    Pokud chcete makro uložit

    Klikněte na

    do dokumentu, ve kterém makro vytváříte

    This Workbook

    do všech otevřených dokumentů

    New Workbook

    tak, aby bylo k dispozici při každém použití Excelu

    Personal Macro Workbook

    Osobní sešit maker se nachází na stránce uživatelé/ uživatelské jméno/Library/Application Support/Microsoft/Office/Excel.

  4. Klikněte na tlačítko OK a proveďte akce, které chcete zaznamenat.

  5. Na kartě Developer klikněte v části Visual Basic znovu na Record.

Makro můžete vytvořit v integrovaném Visual Basic Editoru.

  1. Na kartě Developer klikněte v části Visual Basic na Editor.

    Excel Developer tab, Visual Basic group

    Pokud není karta Developer k dispozici

    1. Na pravé straně pásu karet klikněte na Action pop-up menu a potom na Předvolby pásu karet.

    2. V části Customize (Přizpůsobit) zaškrtněte políčko Developer.

  2. Pokud potřebujete vložit modul, klikněte ve Visual Basic Editoru na příkaz Module (Modul) v nabídce Insert (Vložit).

  3. V okně kódu modulu zadejte nebo vložte kód makra, který chcete použít.

  4. Po dokončení klikněte v nabídce Excel na Close and Return to Microsoft Excel (Zavřít a vrátit se do Microsoft Excelu).

  1. Na kartě Developer klikněte v části Visual Basic na Macros (Makra).

    Excel Developer tab, Visual Basic group

    Pokud není karta Developer k dispozici

    1. Na pravé straně pásu karet klikněte na Action pop-up menu a potom na Předvolby pásu karet.

    2. V části Přizpůsobit zaškrtněte políčko Vývojář.

  2. V seznamu klikněte na makro, které chcete spustit, a pak klikněte na Run (Spustit).

    Tip: Pokud chcete makro spustit pomocí klávesové zkratky, stiskněte klávesy OPTION+ COMMAND +písmeno, které jste zadali při vytváření klávesové zkratky.

K úpravě maker se používá Visual Basic Editor.

  1. Na kartě Developer klikněte v části Visual Basic na Macros.

    Excel Developer tab, Visual Basic group

    Pokud není karta Developer k dispozici

    1. Na pravé straně pásu karet klikněte na Action pop-up menu a potom na Předvolby pásu karet.

    2. V části Přizpůsobit zaškrtněte políčko Vývojář.

  2. V seznamu klikněte na makro, které chcete upravit, a pak klikněte na Edit (Upravit).

    Spustí se Visual Basic Editor.

  3. Proveďte požadované změny.

  4. Po dokončení klikněte v nabídce Excel na Close and Return to Microsoft Excel.

Po dokončení tohoto postupu se makro spustí pokaždé, když otevřete sešit, který ho obsahuje.

  1. Na kartě Developer klikněte v části Visual Basic na Record.

    Excel Developer tab, Visual Basic group

    Pokud není karta Developer k dispozici

    1. Na pravé straně pásu karet klikněte na Action pop-up menu a potom na Předvolby pásu karet.

    2. V části Customize zaškrtněte políčko Developer.

  2. Do pole Název makra zadejte Automatické_otevření.

  3. V místní nabídce Store macro in (Uložit makro do) vyberte jednu z těchto možností:

    Pokud chcete makro uložit

    Klikněte na

    do dokumentu, ve kterém makro vytváříte

    This Workbook

    do všech otevřených dokumentů

    New Workbook

    tak, aby bylo k dispozici při každém použití Excelu

    Personal Macro Workbook

  4. Klikněte na tlačítko OK a proveďte akce, které chcete zaznamenat.

  5. Na kartě Developer klikněte v části Visual Basic znovu na Record.

  6. V nabídce File (Soubor) klikněte na příkaz Save As (Uložit jako).

  7. V místní nabídce Format (Formát) klikněte na Excel Macro-Enabled Workbook (.xlsm) (Sešit Excelu s podporou maker (*.xlsm)) a potom klikněte na Save (Uložit).

  1. Na kartě Developer klikněte v části Visual Basic na Macros.

    Excel Developer tab, Visual Basic group

    Pokud není karta Developer k dispozici

    1. Na pravé straně pásu karet klikněte na Action pop-up menu a potom na Předvolby pásu karet.

    2. V části Přizpůsobit zaškrtněte políčko Vývojář.

  2. V seznamu klikněte na makro, které chcete zkopírovat, a pak klikněte na Edit.

    Spustí se Visual Basic Editor.

  3. V okně s kódem v editoru Visual Basicu vyberte řádky makra, které chcete zkopírovat.

    Tip: Pokud chcete kopírovat celé makro, musí být součástí výběru řádky Sub a End Sub.

  4. V nabídce Edit (Úpravy) klikněte na příkaz Copy (Kopírovat).

  5. V poli Project (Projekt) v okně s kódem klikněte na modul, do kterého chcete kód umístit.

  6. V nabídce Edit (Úpravy) klikněte na příkaz Paste (Vložit).

  1. Na kartě Developer klikněte v části Visual Basic na Macros.

    Excel Developer tab, Visual Basic group

    Pokud není karta Developer k dispozici

    1. Na pravé straně pásu karet klikněte na Action pop-up menu a potom na Předvolby pásu karet.

    2. V části Přizpůsobit zaškrtněte políčko Vývojář.

  2. V seznamu klikněte na makro, které chcete odstranit, a pak klikněte na Delete (Odstranit).

Rozšiřte své dovednosti s Office
Projít školení
Získejte nové funkce jako první
Připojte se k účastníkům programu Office Insiders

Byly tyto informace užitečné?

Děkujeme vám za zpětnou vazbu.

Děkujeme vám za váš názor! Pravděpodobně bude užitečné, když vás spojíme s některým z našich agentů podpory Office.

×