Vytvoření součtu součinů odpovídajících hodnot jedné nebo víc matic pomocí funkce SOUČIN.SKALÁRNÍ

Poznámka:  Snažíme se pro vás co nejrychleji zajistit aktuální obsah nápovědy ve vašem jazyce. Tato stránka byla přeložena automaticky a může obsahovat gramatické chyby nebo nepřesnosti. Naším cílem je to, aby pro vás byl její obsah užitečný. Mohli byste nám prosím dát ve spodní části této stránky vědět, jestli vám informace v článku pomohly? Pokud byste se rádi podívali na jeho anglickou verzi, najdete ji tady .

Funkce SOUČIN.skalární používá jako argumenty (částí vzorce, které usnadňují práci) oblastí buněk (nebo pole). Vynásobí společně položky v polích a pak sečte nahoru výsledek.

Tento příklad představuje seznam potravin, kde jedna matice obsahuje ceny jednotlivých položek a druhá matice počet kupovaných položek.

Ceny a množství k vynásobení a následnému sečtení

  1. Pokud chcete vytvořit vzorec, zadejte =součin.skalární(B3:B6;C3:C6) a stiskněte klávesu Enter.

Všechny buňky ve sloupci B se vynásobí odpovídající buňkou na stejném řádku ve sloupci C výsledek se sečte. Celková částka za potraviny je 21,60 USD.

  1. Pokud chcete zapsat delší vzorec, který vám stejný výsledek, zadejte = B3 * C3 + B4 * C4 + B5 * C5 + B6 * C6 a stiskněte klávesu Enter.

Po stisknutí klávesy ENTER je výsledek stejný: 21,60 USD. Buňka B3 se vynásobí C3 výsledek se přičte k výsledku B4 krát C4, a tak dál. Dokážete si představit, nakolik v případě tisíců (nebo i stovek) řádků může funkce SOUČIN.SKALÁRNÍ usnadnit práci.

Poznámky: 

  • Sloupce nebo řádky (matice) musí mít stejnou délku.

  • Pokud je v buňce text místo čísla, považuje se za nulu.

Příklad

Pokud chcete s funkcí součin.skalární a maticemipohrát, tady je sešit Excel Online s jinými daty než jsou v tomto článku.

Zkopírujte vzorová data z následující tabulky a vložte je do buňky A1 v novém listu Excelu. Aby se zobrazily výsledky vzorců, musíte je vybrat a stisknout F2 a potom ENTER. Pokud je to třeba, můžete si přizpůsobit šířku sloupců, abyste viděli všechna data.

A

B

D

E

3

4

2

7

8

6

6

7

1

9

5

3

Vzorec

Výsledek

'=SOUČIN.SKALÁRNÍ(A2:B4,D2:E4)

=SOUČIN.SKALÁRNÍ(A2:B4,D2:E4)

Vynásobí všechny položky dvou matic (A2:B4 a D2:E4) a sečte násobky. Postup výpočtu je následující: 3*2 + 4*7 + 8*6 + 6*7 + 1*5 + 9*3 (156).

Podrobnější zkušenosti můžete otevřít taky tento sešit v Excelu. Stačí kliknout na ikonu Excelu v pravém dolním rohu sešitu Ikona Excelu v Excel Web Appu , uložte soubor na vhodné místo ve vašem počítači a otevřete ho.

Začátek stránky

Rozšiřte své dovednosti s Office
Projít školení
Získejte nové funkce jako první
Připojte se k účastníkům programu Office Insiders

Byly tyto informace užitečné?

Děkujeme vám za zpětnou vazbu.

Děkujeme vám za váš názor. Vypadá to, že bude užitečné, když vás spojíme s některým z našich agentů z podpory Office.

×